Waveform disappears when zoomed

When I try to zoom in on wave forms to see enough detail to time-align two audio files, the wave files disappear. I’m not talking about an extreme zoom-in, just a couple of clicks on the magnifier icon. Zoom back out one step and voila, the wave form reappears. But I can’t even get close to zooming in enough to see enough detail to line up anything. I never saw this problem in earlier versions of ntrack, but I was using a different computer with less display resolution then. (I’m now using a Dell Precision M70 with 1920x1200 pixels with 32 bit display depth. Is this a problem others have seen? If so, is there a work-around?

Hi tspringer:
I had the timeline files dissappear only once when and after I installed build 2080 this morning… After I closed and re-launched n-Track IT never happened sense.

My screen reselution is set at 600 x 800 … However I have some plugs that don’t like that res. When I use those plugs, I set my screen res to fit the plug res… But that is tough on a set of eyes that likes the biggest screen size they can get…

Boy… am I spoiled? or What :O :laugh:

Bill…

Graphics card drivers? Try an update?

Hi Steve A and Woxnerw.

Thanks for the ideas. It just so happened that Dell had just posted a new nVidia display driver that is supposed to improve stability. Downloaded and installed it. No change/improvement in ntrack behavior when I try to zoom in on the waveforms. I also tried stepping back on screen resolution to see if that would help. No dice. One click on the time axis zoom-in icon, and the entire window where wave forms are displayed is filled with closely and equally spaced blue and white vertical lines. There is not even an indication of the separation between tracks. Zoom back out one step and everthing looks perfect. I can zoom out as far as I want with no problem. Just can’t zoom in. Nobody else has seen this problem (except for Woxnerw – once)? Dang.

Oops… thanks to MARK A and Woxnerw.

Hi Again:
The graphics cards that are installed on these machines are all 32meg. Ram cards… They are Matrox and ATI brands… at the moment… I’ve used nVidea cards but even those cards were 32 meg ram cards…

Boy, would I ever like to have an Up-to-Date set of DAWs… Most of the hardware that are in these Boxes aren’t supported by the manufactuerers anymore…

Most of the software I have is old stuff… I have n-Track and a few plugs that are current… Of course… they are supported, and very well… That’s about IT… I think I have a couple of hard drives that are still in the warranty dates… I’d really like to have a couple of 19" Flat Panel monitor screens… Mabey, some day… :O :;):

I got a couple of dial-up modems for my telephone wire… :p

Bill…

My Dell precision M70 has a 1.86 GHz Pentium M with 512 MB of DDR SDRAM and 256 MB of video RAM so it shouldn’t run out of memory.

Tim

<!–QuoteBegin>

Quote
Oops… thanks to MARK A and Woxnerw.


Phew. Had me worried there. Thought my name had been changed and no one had bothered to inform me.

Have you tried deleting your npk files? If you do this, then re-open the project, nTrack will recreate them for you auto-magically. These files are used for rendering the wav file visually.

Hi Katau:
That’s a great reply… I’ve done that before and I’ve used under the “View” drop-down menue… Refresh View/Recalculate wave forms… That builds another set of .npk waveforms…

I’ll say, it’s happened to me now… more than once… But I’ve managed to recall/retrive them…

IT was funny playing the timeline and not seeing any wavefiles/.npk forms in the time-line… The meter was bouncing away and the Time-line was progressing but no .npk files to-be-seen… anywhere :p

There was a couple of things I didn’t pay attention to while that was going on…

I should have checked the CPU Useage and “Solo’d” some tracks while I have the issue happening… I’ll try to remember doing some peeking around if-and-when IT happens, again…

In order to retrieve the .npk files on the timeline I played with the revert to last view, view all song, and zoom selection… (Those Keys)… Low-and-behold the files appeared on the timeline… ??? :;):

Bill…

[EDIT]
Remember guys… I’m playing with a Lo-Performing Intel ASUS P-111’s here. with AGP /32meg graphics cards…

Clever idea, Katau. I deleted the .npk files and reopened the project. As expected ntrack recreated the .npk files. Unfortunately, the waveforms still dissappear when I try to zoom in. I guess that eliminates the possiblility that a corrupt .npk file is the culprit.

Tim

By the way it is possible to zoom in on the amplitude axis without a problem - the problem is isolated to zooming in on the time axis. I wonder if the odd geometry of the my laptop screen is a part of the problem (lots of pixels horizontally, and not so many vertically). Maybe it just outside of the limits that Flavio considered when he wrote his display routines for zooming the horizontal axis.

Quote (woxnerw @ Mar. 29 2006,17:41)
...I've done that before and I've used under the "View" drop-down menu.. Refresh View/Recalculate wave forms...

LOL...I didn't know that menu option existed...I've been doing it the hard way all this time :D Thanks Bill.

Tried Woxnerw’s idea of using the view/recalculate from the drop-down menus. Sigh…still no joy.

Thanks anyway Wox.

I seem to remember back in the early v3 days when some of the guys reported that the .npk view didn’t stretch out to the length of the .sng file Mabey, there’s some kind of intermittent view error creeping into the timeline… Who knows… ? At that time the guys were recalculating the .npk file useing that method and all went fine… till Flavio posted a new build that corrected the issue… That’s if I remember the issue, correctly… IT seems like randomly, the .npk files suddenly re-appear… Well, after playing with some “Mouse clicks” that I am unable to remember… anyway…

This error is purely random for me… as-far-as-I-can-see… so-far. I haven’t been able to recreate the loss and it hasn’t been long enough for me to play with IT to get IT to re-occure…

Mabey, try to come up with some repeatable “Key-Strokes” that you can repeat the error… so Flavio can jump in and come up with a “Fix”…

Bill…

Thanks for the continuing thought. But, what I’m seeing is not intermittent. Zooming in on the time axis always results in the display in the timeline window going blank. As I was probing ntrack’s behavior last night, I discovered that the timeline window blanks out even when I zoom in when there is no project loaded. So it is a display issue pure and simple and has nothing to do with the wavefiles themselves. Also, at the default zoom level, if I scroll back and forth along the time axis, gaps are left in the display of the whole timeline window as the contents of the window move to the right. (l see light blue lines or bars of irregular width at more or less random intervals. )

Another piece to the puzzle…
I loaded a project created in an older release of ntrack into the build that I am currently using (build 2084) ,and I can zoom into the time axis with no problem. So, maybe the problem with the time-line view blanking out when zooming in on the time axis only shows up when the project is created in one of the newer releases of ntrack. This is really a strange bug. Any more thoughts out there on a work-around?

Bump

I’m “bumping” my post.

Bill…

GOT IT!!

woxnerw’s note set me off in another direction in my thinking and…

The problem disappeared when I went to EDIT > grid > properties and changed from snap beat to something else (e.g. snap time). Now I can zoom in as far as I want to.

But this brings up the possibility that I don’t understand the interaction between snapping the grid to beat and something else that I should be doing to set up to make this work – and that is causing a problem. Am I missing something or is this a bug?

Tim