what is compensation ?

Under preferences, audio devices, wave devices advanced settings there is a setting labelled compensation.

Is this a delay in the plarback through the sound card ?

I found no info on this searching the forum.

This compensates the latency created by plugins. What happens is N-track hands the audio off to the plugin to add reverb or whatever and it takes time for the plugin to do it. Compensation allows N to wait for the plugin to finish processing before mixing everyhitng. For instance with reverb, without compensation you would hear the main audio and then the reverb a half second later once the plugin had finished processing everything. Compensation maes sure the audio and the effect come together at the same time. Make sense?

but there are two things - automatic compensation of plugins tickbox, and then a compensation input setting under midi. I am not sure myself what the midi compensation is for, or what it should be set at. Mine seems to be default at 500ms but why?


You are fairly right about this… - it is a way of synchronizing the sound you are recording against the sound(s) already in the project. Read more in the n-Track manual under “Sync & Lag Issues” Usually, there’s no reason to touch it, however, YMMW.

regards, Nils

My guess is that it’s additional latency (lot’s a reasons it might be useful) but I don’t know. This might be a question for Flavio…and the docs.

EDIT: The compensation he’s asking about is under the Audio Device Advanced settings. It’s not plug-in or MIDI compensation. It would be redundant to have those other ones listed in multiple places…thought Nils is probably right. That is one of the reasons for using it.

The compensation he's asking about is under the Audio Device Advanced settings. It's not plug-in or MIDI compensation.


Has anyone got any experience with using this function because I’ve never tried it?

Yes, I’ve tried it. It’s unrelated to latency.

Latency is “I press the key and there’s a delay before I hear it.” This setting doesn’t affect that.

If you have a consistent sync problem when adding a track, this is a correction for that (in samples).

Let’s say I have an audio click track. Then I play the click track and record it (using a mike or electrical loopback). When I look at the new track and the original, I see that the new track lags by 10 msec. (Or, the new track could LEAD the old one, and the amount could be almost anything.)

I fix this by putting a number in “compensation”. For 10 msec, if I’m recording in 44.1kHz, the gap would be 10 * 44.100 = 441 samples. I don’t remember whether the sign is positive or negative, but one is for leads and the other is for lags.

Generally, if you have to do this it means there’s something not quite right with your soundcard or driver, so it shouldn’t be necessary.

To measure time in milliseconds, right click on the time-bar and select “custom”, and enter “1000”. Note that the number displayed in the time-bar to the right of the period is NOT a decimal fraction, it’s a number of milliseconds. So, xxx.20 comes before xxx.100.

Oh – you can also set the timeline to display in samples, and omit the math. Sorry, I’m just used to thinking in milliseconds.