Wheres my song?

.sng file wont open

Hi
did a lot of recording yesterday on a song I’ve been working on for weeks .
To my horror ntrack would not open it this morning, neither would it open the back up copy. I can only open earlier versions(minus all the takes I put down yesterday).
The .wav files are all there for what I recorded but the .sng I saved it all under will not open, ntrack says it has encountered a problem & needs to close.
Any ideas how I can sort this out or ways round it.

thanks

jetboy

Yuck! That is terrable! What version are you using? Is is possable you are trying to use an older version of N_Track than the one that created the sng file? The program is backward compatable, but not forward compateble - new sng files cannot always be open with older versions of a pregrams (they should be the same within versions, but I can’t be sure of the Betas.)
Have you tried going to the directory where the sng file is stored and trying to open it directly with a double click there? You can check the dates on the verious files and see if there is a miss match to the npk files. If nothing works, I think I would delete the npk file.
Keep us posted.
Bax

hi bax3
thanks for the reply, I’m using version 4.0.4 which the whole song’s been done on, I’ve never upgraded.
Tried double clicking on .sng file in directory, no joy there.
Don’t know exactly what you mean about checking for a mismatch to the .npk files or deleting the .npk file,… which one?
strange thing is when I went to the backup this morning to launch it from there , half the files were missing & hadn’t been copied!

jetboy

I hA Ve yOR s O Ng
i f
U E veR W aNT
2 H Ea r It A gaIn


Seriously, sorry to hear that. You are the
second person (recently) to experience this.
I’m at a loss to speculate, but I am a little spooked
by it. I hope someone can figure out how this
happened,
'cus frankly that’s the last thing we need to worry about.

Are the wave files all there?

Quote:

The .wav files are all there for what I recorded



Yeh, I just realized - more scary

Anything that corrupts the .sng file could cause it to not open. The bad part is if the waves are missing. That is what happened to someone else. I would say this is nothing more than .sng corruption. That does not make it any better of course, but at least the waves are still there.

Something in the past that has caused songs to not open or crash when being opened has been the number of AUX channels in the mixer. If a song had been saved with more than the current AUX channel count then that sound might crash when opened. That bug was fixed months ago in V5 (or V4?).

Anyway, the way to get to that scenario is to insert more than 2 AUX returns in the mixer, save the song, revert setting, then try to open the some. Since the default AUX count at that time was 2, any song that had three would go poof.

As I said that was fixed. The idea is to try to think back and see if anything else along those lines was done. Think about sub-groups, or effects that might be used in the song. Anything that might no longer be -there- when the song file is opened.

Just in case you have not tried this, try opening the song file via the file dialog and not by double clicking its icon. Might make a difference.

Thanks for the interest fellas
In the absence of any magic fix I’ve resigned myself to importing each of the .wav files into the last openable version of the song & either trying to sync them manually or (as each one will tell me what I recorded) trying to record them again. Very frustrating

jetboy

I’d suggest running a test to see what happens. I recorded a lot of hours with version 4, used several groups and a ver aux channels on up to 34 tracks, and I never had that happen. I have saved to a location that I did not want, and that screwed up things ( I realize that that is not the case here), but only an example to say that something is wrong, and it may not be an obvious error, before you do to much work, do some checking to see if it happens again and what may be causing the problem.
just a suggeston . . .
Bax

Pleased to say there’s been some developments since yesterday.
From the backup which did not copy the .wav files I noticed the .sng file was a different size to the corrupt one. When pasted into the original directory it managed to open the song with a lot of files missing but it did contain all the ones I’d lost!
I’ve rendered each one down from zero so I can import them into an older version of the song to bring it up to date.
Obviously I’d rather be able to import these files directly. Looking at the song info sheet can I use the information there to manually sync these files in the right place? I notice each file has a figure for offset, length & start but dont understand what these numbers mean exactly.
Any ideas?
I’ve done several tests on the system & it seems to be working & saving songs fine.

jetboy

It’s no fun loosing a song…I did it once, I lost everything, I spent most of the day crying… :heart-break:

turns out, i’d decided to organise my computer (female/ocd ways) and in doing so, had neatly put all my files in new locations and N-track had no idea where to look for them anymore! :laugh:
:laugh:
:laugh:

Glad you got it sorted.
:agree:

Ange x