Who uses ASIO

I’m baffled. Sometimes it works sometimes it doesnt. (ASIO) When it does, I cant disable my PC’s desk mic (I have the checkbox in the advanced volume control for muting it checked). I suppose I could unplug it. (Box is under my desk against a wall :( ).


It worked yesterday, and I decided to buy ntrack based on that. I saw on the website a beta, so I attempted an install. I didnt have NET installed, so I just reinstalled the previous version. Now IT DOESNT WORK again. (It started out not working months ago. I have no idea why it suddenly started working).


I need ASIO because I am using SavHost to host VST instruments (SoundFont players and other synths). ASIO appears to be the only real common ground - and it seems unstable/wacky.


Anyone actually use it? I dont mean, yeah, I did a track once. I mean actually, reliably use it for real work. (Realtime audio from ASIO sources like hosted synths).


This looks promising, but if I cant use ASIO, its a drink coaster.

Thanks
Jim

Yes, I use it. :)

With an Aardvark q10, no problem, nice very low latency, sometimes I can get it down to 3 ms with synths that don’t demand too much. Now that Aardvark is out of business I’m going to be careful about changes in n-Track, at least until I get a new interface, but it has worked just fine for a long, long time for me.

Dunno if that helps you.

EMU 1820M here… ASIO works great with n-Track. I’m running the Beta version on one partition and the last release version on the other. No problems.

TG

I think I am beginning to understand. It either works or not. I’m guessing that it wouldnt matter in your cases whether you were using the commercial version or demo of ntrack.


Which means, on my system, that if the demo doesnt work, the commercial version wont either.


My luck, I have an AC97 on board sound system which is known to be a little bugger. It just never stops. I tried for years to get away from audio hardware dependencies. (VST’s, samplers, digital digital digital) and am finally in the end hoist on the petard of crap support (ASIO) for AC97.


I need a red pill.

Um, yeah, AC97 ain’t great. I too am an ASIOite and it works swell for me and has on several different interfaces I have owned.

ASIO works fine for me (Edirol DA2496).
Whether it works or not will be more a factor of the ASIO driver for your soundcard.

I didn;t even realise onboard cards had ASIO drivers… can’t imagine they would be that good though as the hardware developers probably wouldn’t be too focused on serious audio applicatoins, but more general audio and games…

Rich

I’m using ASIO4ALL on it. It’s about the only choice there is to my knowledge.

Well I’ve never used ASIO4ALL but considering the driver wasn’t written specifically for your hardware that may be the problem.

If ASIO as an absolute necessity then you may need to get a soundcard with an ASIO driver available for it…

Savhost won’t work with WDM?

Rich

savhost, http://www.hermannseib.com/english/savihost.htm , is a nice freebie. (Its called SaviHost, except I have bad eyes and missed the i :) ).


I believe it only supports MME or asio. (ASIO being yet another Steinberg technology - they did VST).

I may have to buy a soundcard (non creative). I prefer to remain digital and not depend on soundcards really. Funny that I may have to do this even though I have no intention or need for one. :) (I dont do analog).

When it doesn’t work double check what clock is being used in the preferences. Also be aware of which input and output devices are selected. (system or wave – wave is the soundcards clock) I’ve discovered that when using a particular input device that the same output device needs to be selected. I usually use MME or WDM, but whichever I always select the same input and output. The same goes true for multiple soundcards. I switch from the Gina24 to the Layla20 inputs (Gina24 is for 24 bit recording of drums via ADAT input - the Layla20 is for MIDI and most other uses including mixdown - it has more analog line level inputs) I also select outputs from the same physical device. When using the GuitarPort USB input I MUST use the GuitarPort output or it won’t work at all. Maybe something similar is happening.

Ahh…one more thought. The Layla and Gina have a function to sync inputs inputs. The Layla has four stereo pairs possible. If sync is on and I have not selected the first pair for recording the n-Tracks will appear to hang if the clock source is the soundcard. n-Tracks is waiting for the soundcards timer, but since the ports daisy chain disabling the first pair also disables the clock n-Tracks needs. It blindly waits for ticks that never start. Leave the sync ports option (soundcards control panel) on when recording from all ports, but off when recording from anything less than all pairs from a single device.

I use SaviHost and Asio4All on my laptop’s builtin SoundMax audio for live work (Native Instruments B4 plus SFZ running my own Rhodes soundfont, jRhodes3. (Pardon the shameless plug, but it’s free and I don’t get anything from sharing it other than an occasional nice email!)

Works great.

I’d guess that more people use ASIO than any other format but ProTools, for serious audio work. The exception to this is folks doing lots of tracks (16 or more), where you can run into buffer problems that are easy to work around using WDM.

I just went through a frustrating experience with ASIO. i have a Layla24 and Layla 20 in the same computer. I changed to the ASIO and set Ntrack to the Layla 24. Worked fine. Then, I thurned off the machine for a few days. Turned it back on and rest to WDM drivers. The computer (ntrack, sound Forge, windows player) couldn’t find either sound card drivers! The hardware (sound cards) was listed in control Panel as ok. Changed back to ASIO - still no luck. Uninstalled everything over a period of trouble shooting. Got WDM to work with everything Except Ntrack.
Started over - uninstall, reinstall everything. Tried MMN drivers - sound! It worked! Went back to WDM and now that is working.
Weird.