Wot no DMA setting for hard drive?

don’t have this option - it aint there

I’ve noticed a few times folk mentioning that you should have DMA enabled for DAW hard drives. The problem for me is that I don’t seem to have the option to enable it.

I am using Win98SE and if I go to device manager, access any hard drive properties on my system (I have 3), there is no little box to tick/untick DMA. Even on my latest drive - a brand new 80G 7200rpm Maxtor which I bought just for audio files - I do not have this option available.

I have seen this setting on other PCs running Win98 so I know where it is.

Any ideas why this is guys, and how I should rectify it?


Athlon 1.8G
Epox 8Kem2 mobo (Via chipset, patched)
512Mb RAM
N track 3.3
Seagate 40G, 4G and Maxtor 80G drives

Think I have the solution, from the MS knowledgebase:


If anyone has any experience of this issue, thoughts etc, please let me know.

I’ve seen it greyed out under XP on a SIS based P45a motherboard (and couldn’t ben enabled), but was there under 98. The c-port worked great under 98 on this MB, but lack of DMA killed it in XP.