4.1 chaos?  Or just me...

So, I finally took the plunge from 4.0 to 4.1 (build 1969). I know, not a big step, but hesitant to do so nonetheless. More on account of Microsoft’s beta really, than N-Track. Here’s the problem. Formerly, I had two songs which would run at approximately 80% utilization (according to N-track) and 100% (according to Task Manager). On recording I would set the latency to 10 ms and it worked great. While tweaking and messing w/ the effects, though, I had to change the latency to 100ms to keep from stuttering.

Now, though, these same two songs (and a brand spanking new one recorded in 4.1) show utilization of 55% (N-track) and 80% (Task Manager). Great, I think–it’s really gotten better; however, the stuttering is completely unmanagable. Using the ASIO drivers, I’ve bumped the buffers up to 500ms with absolutely no effect. It still stutters. I’ve tried the WDM drivers with the same results, although the CPU seems to run a little higher. The confusing part is that it’s doing it on an existing track, as well as a new one. I’ve tried freezing multiple tracks, but that doesn’t seem to help. We’re talking about 12 or so tracks total. No midi – all converted to wave.

Now, here’s some more info, cause I know you’re going to ask:

If I disable the effects, util drops to about 15 -20% (Ntrack) and the stuttering goes away, although I’m not using a TON of them. And it DID work fine in 4.0 I’m running a Dell 2.4 Ghz w/ 512mb ram on two disk drives – one totally devoted to N-track data, and the other the O/S. I’ve tweaked the system per musicxp.net and kept the hotfixes pretty much up to date. I disable everything (ie., networking, virus scanning, etc) while using N.


FWIW Bill, I have been seeing the same problems with the latest build. CPU usage is MUCH higher than it once was…


So, that’s interesting…I’m actually seeing N report a LOWER CPU, but the symptoms are indicative of HIGHER CPU. I’ve looked at both the fractional display as well as the absolute, and they’re both displaying a remarkably lower number. I’d thought that one of the benefits of upgrading was supposed to be ~10% MORE efficient utilization. No? Maybe a bug? ???

I dunno. I was in a hurry after I installed the last build (1969 I think?) and it’s possible a restart or reboot could have cleared out some poop. I’ll try to report back later. When I install a new build, I have one project I open to test playback, plugins and CPU usage. Since I did not restart the PC, maybe there was some crap in memory or summat?