Beginners MIDI keyboard Question

problems recording

Before I wrote this topic I did try to find the answer in previous threads. Just so you know. I am completely new to MIDI, and have run into some troubles recording on N track 7

1. I have an iRig Keys connected with USB to my PC.
2. I have downloaded a lot of cool free VSTs and put the DLLs in the VST-plugin folder for ntrack. Martinic Combo-F for instance

3. I have followed the instuctions on how to obtain lower latencies, and I can play all I want. Everything works so far.

So, I first insert an instrument track choosing the VST-plugin.
Then i insert a blank MIDI track. in the properties box i coose the VST as output.
I then get several new tracks in my timeline, not sure why. I only want one.

Still Everything seems fine, I play and I hear it well.
Then I record, and after recording I can see that there is a pattern in the MIDI track and when I press play i hear what I just recorded. There is no wavefile, the instrument track has a straight line instead of a jagged. The only visible trace of something being recorded is the pattern in the MIDI channel.
The problem is I can’t mixdown it this way. I tried twice. The first time it was all mute, and the second time I heard a noise and some echo of the synthesizer.

Does anyone know a step-by step instruction for this? I’m sure I have forgotten some important detail somewhere.

/ Martin

My USB keyboard records both MIDI and Wav files at the same time; so, I may not be much help. When you get it to work. please let us know what worked.
try: on the main menu bar
Select Track > Midi > convert Midi tracks to Wave Track.
I found this is the manual:
“Mixing down works only on audio tracks, so if you have included a MIDI file, you’ll have to “record” it by selecting MIDI as the recording input in your soundcard mixer, so the program will be able to treat it as a WAV file.”

I don’t use MIDi so I may be wrong on this one
try MIXDOWN - save as a wav file and select MIXDOWN While Playing

Thanks for the reply Bax. I can’t believe I haven’t seen that before. However now all of a sudden I get annoyingly long latencies when I play the keyboard. No matter how I change between the drivers in the “audio devices” . Mostly I get the message “error opening wave device” or “multiple audio outputs selected”.
My Asio4all drivers make the VU meters move accordingly but there is no sound…
Getting more and more frustrated.

Not sure I can help. If you listen to the audio from/at the keyboard instead of through the sound card you will probably reduce the latency greatly. Maybe?

Hi, grodkropp.
I use a combination of midi and audio all the time. Which build of n-T7 are you using because you should indeed be able to “mixdown” midi tracks straight off without jumping through any hoops (this wasn’t the case with all Vs of n-T6). Why not restore n-T to default settings and run a couple of tests (I’ll be around for the next few hours).
The extra tracks you are creating are probably due to you having the input selection set to “audio + midi” (button in the upper left toolbar - keys/mic/keys+mic).

(PS to Flavio. Do we have a problem with 7.1.2 3277? I’ve been experiencing extra audio/midi tracks when input is set to midi only)

Hi Tony,
thanks for your response. I’m not by my Music PC now but I will try this as soon as i get home. I know for sure that I have been using both MIDI/Audio setting, I will change that.
I have been looking for a “restore to default button”, could you please tell me where I can find it? Thanks again! :;):

Oh and by the way, just curious: when will there be a use of both keys+mic?

Right now I’m struggling with my ASIO4ALL working with my iRig Keyboard (USB)
I get the VU-meters moving, but there is no sound. I have taken a few actions to no avail:
1. Unchecked the “exclusivity” boxes, both playback and recording
2. Shut down all applications I can think of that will make sound. (Spotify, web browser and Windows Media Player)
3. Made sure all sample rates are 41000 hz (at least at the places I have found where this can be done)
4. In the midi settings I have made sure the MS Wavetable Synth is not checked. That is the only Place I have found anything to do with MS Wt Synth.

In the ASIO4All Control panel the Output option has a red X for unavailable, but the above actions have not made it available.

Am I supposed to see my iRig in the My Computer folder like I do when I jack my iphone or a portable hard drive? I don’t. There is just a keyboard symbol down at the right corner. It sometimes turn red. I can’t open it and make any setting options.

Thanks in advance for any comments. :agree:

What audio interface/soundcard are you using?

Some crappy motherboard integrated (DELL) card. Conexant HD
All of a sudden that Xed output is active! Hooray! I think i opened the ASIO control panel outside of ntrack before and not i opened within ntrack… Will try to record something and let you know. :cool:


Still no sound, when i jacked the iRig in and started up ntrack again that X-ed output is X-ed again…

The output device looked ok an running just briefly, but that was when i didnt have the keyboard jacked into the USB port. I did notice when i jacked in and tried again that there were TWO asio control panel icons visible down to the right of the screen… Weird… To me at least.