Blue screen of death

What the heck is wrong here?

Ntrack is giving me some serious grief!
It “might” be hardware or hardware driver related, but it’s rather strange if that’s the case.

Fact is, PC seems stable when doing anything that doesn’t involve Ntrack. Ntrack will crash when changing settings. Ntrack will crash when I hit “play” on a simple midi track. Ntrack will crash while playing, while recording, while doing pretty much anything.

I started to think it was my Notebook, so I tried my other notebook… same issues. One’s a Dell, ones an ECS. Tried multiple 4.x versions of Ntrack.

Is anyone else having a heck of a time with ntrack stability?

I had a defect mouse at one stage and ntrack got wiped out when I pointed the mouse at it. Funny thing was, other progs didn’t seem to mind. It got better when I changed mouse though. Worth a try.

Are you using the same audio interface with both laptops?

Quote (jmccullo @ Aug. 15 2006,09:58)
Are you using the same audio interface with both laptops?

My thoughts exactly. If so it's most likely a driver issue.

Yup, I’m using M-Audio Transit and M-Audio UNO (1x1 Midi). I might try a fresh install of XP on a separate partition JUST for recording etc… see what happens.

Does anyone know if a USB attached HDD is fast enough to be used with nTrack? I might do an install on a separate HDD even…

My experience is that n-track and usb (albeit a usb2 soundcard) did not get on well together. Ntrack doesn’t seem to cope with the data block type of transfer, especially with asio. Somehow the asio stream is interrupted and ntrack crashes, or it did on my system. :(

Asio drivers are very susceptable to a break in data apparently.

How about making sure you’ve got the latest soundcard drivers downloaded and then trying the WDM drivers? You could also try at 44.1, 48 and 96 KHz and see if data throughput is an issue.

The drivers are the latest according to M-Audio’s website. I’ve tried both ASIO and WDM drivers (WDM seemed a LOT more stable, but still not stable enough).

I’m wondering if I ended up using a Echo AudioFire 4 (firewire) if it would have the same problems… I’m guessing Echo would have better driver support than the bottom-line M-Audio stuff does. The last updates were early last year.

It’s certainly worth a try. Sometimes there’s just a fundamental issue between n-track and some hardware and there’s not too much you can do about it. I had an problem with an M-Audio Delta-44 card and n-track a couple of years back that took 6 months to get fixed - a workaround was eventually added to n-track that got around a driver error in the soundcard. You should also put a bug report through which may even get your issues resolved in the next version. Have you got the problems with both 16-bit and 24-bit?

I have come to conclusion that M-audios Asio drivers more or less suck. WDM works without any problems for me.

Now I have M-audio fw 1814 in my laptop, I have a separate usb2 HD connected in the system (where the wav’s and stuff are), N-track is on laptops own HD.

With WDM it works very well. However, I don’t do anything with midi, pure audio.

I have found n-track to be quite stable while recording on my Dell Precision M70 laptop with an M-audio audiophile USB audio interface. As long as I am simply recording audio tracks n-track hardly ever has a problem. This casts doubt on the idea that the problem is simply that ntrack doesn’t work well with a USB interface. By the way, my system seems to work fairly well with both M-audio ASIO and WDM drivers.

N-track becomes considerably less stable when I’m using midi or I use VSTI inserts.

Since you are having problems running n-track on two computers, it suggests to me that the problem does have to do specifically with the interaction between ntrack and the M-audio interface. I think that there is still a chance that there is an audio or midi setting in the n-track setup that you haven’t tweaked properly yet. Problem is with n-track crashing every time you crank it up, trial and error will be slowand tedious

I assume that you’ve tried turning off network cards, shutting down anti-virus software (and other stuff running in the background), disconnecting all other USB devices, and deactivating your internal soundcard.

Have you had success using your M-audio interface when running other audio recording software (eg. free download Audigy)? I too had trouble getting N-track to run when I first installed it. Audigy installed properly on the first try, and tweaking settings from within Audigy helped me to figure out what was going wrong with my N-track setup. Sorry but I can’t remember details of what the problem was.


16bit vs. 24bit. My project is only 24bit so I’ve had no need or desire to try 16. I’ll have a try.

When recording, I shut down everything I can find, including anti-virus, network connections, IMs, useless tray tools, etc. etc.

I’ve done all the tweaking I can find, with the only thing off-hand that I don’t feel confident with being the “Buffering” settings. I have tried a number of the settings from low to very high, but don’t really have an understanding of this.

I should say, I was creating an auxilliary channel for the midi click track using the Ntrack Instruments (drums). So I do have a midi click track playing, a midi input from the TD-8 drums coming in, and 2 audio tracks from the TD-8 as audio references. Once this portion is done, we take the drum midi file, snap it where needed, adjust any mistriggers etc. then using Drum Kit From ####, create audio tracks. Once the audio tracks are ready, then the rest of the recording is audio only.

I suspect the audio only portion will work fine. It may very well be that I have to skip the click track altogether or at the most, get an audio-only click track in a wave file. That would eliminate any midi processing and allow only the recording of midi notes (midi echo is OFF). That might help me get to the end results sooner than a lot of troubleshooting could.

I did run system diagnostics overnight on the notebook, and all is coming up fine. So it’s not RAM or HDD or general system stuff… it must be drivers, ntrack, or some combination of those.

Maybe I’ll do some drumming in a bit on audio only, lay out a couple of guitar tracks, and see what I get. Thanks for your posts!

Ok, Here’s what seems to have brought a little success.
I took the midi click track. I preset the BPM to 165 and cut the midi to 5 mins (song is approx 4mins long). I then had it converted to .wav files.

I save that as a new file.
I recorded a full audio-only session of drums against the wave click. No problem so far.
I then recorded another full audio session PLUS the midi.
No problem so far.

So, what I think we’re seeing here, is that Midi drums in + analog in + midi through instrument channel = bad hair day.

Now, I’ve only tested this for the last 20 minutes with success. I’ll need more time to ensure it’s actually working in a solid manner before I get too excited, but 0 crashes, even on save, exit, moving sliding the time position bar around, and most interestingly, updating settings.

Whaddya think of that?

I’ve been using 3.3 on my dell 600m with very little problem. Using a Tascam US122 USB1.1(i think) interface. I DL and looked at 4.2.1, but wasn’t impressed by what I saw, plus all the stability problems wigged me out =).

I do kill non-needed proggies when I’m working in audio, so I’m sure that helps. Using ASIO, btw.

Happy camper (in the 3.3 camp).

An update. I spent the day yesterday recording drums and some sample tracks. Not a single crash. So the verdict (to me anyway) is in.

If you are recording MIDI and need a click track, avoid using a MIDI click track that is routed through a VSTi Instrument channel. You may have a bad day.

My Inspiron 9400 didn’t even flinch when using the .wav version of the click track.

This is a little sucky however… I would much rather be able to record the MIDI from the drums directly against the midi click track so that any adjustments to the speed of the song can be done with the click track lined right up… at the end of the third day, the job got done.

THanks ALL who posted here, your help was invaluable.

cool deal. on 3.3, i tried using the built in click, but found it was off time. both me and a guitarist noticed the off-time nature of the metronome.

Instead, I used a boom-tap wave file, made in FL studio in the fashion you did. Yeah, the time can’t be changed, but listening to an off-time metronome was not going to work.

Glad you found a resolution.