Bx_rockrack V3 plugin

Hi. Does anyone use any of the plugin alliance plugins? I’ve been trying to demo bx_rockrack V3 but Ntrack doesn’t seem to recognize it’s there. I’ve moved the file around to everywhere I can think of but still no luck. It’s a VST3 64bit plugin. Any help is appreciated. Thanks

Are you using the 64 bit version of n-Track? Post the VST scan log so that we can see if n-Track is finding the plugin and if there are any errors. To find the scan log select Settings -> Plugins -> VST scan log.


Thanks Flavio for getting back to me. Turns out for a number of DAW’s plugin alliance doesn’t work unless you install visual c++2015/17 redists from Microsoft. This is the current workaround for Reaper, FL Studio , Gig performer and apparently n-Track. Worked for me. As long as I have your ear I just bought and downloaded Scuffham S-gear and am having a compatibility issue with their new upgrade 2.9. Their version 2.7 runs perfectly with ntrack but new 2.9 upgrade crashes and I/O meters don’t work. They are VST3 and I was told, “We had this meters issue with a few DAWs and it is because the host is not implementing ‘output parameters’ which is part of the VST3 spec”. Can you be of any help with that? Thanks again.

We’ve reproduced and fixed the bug in which the meters of the Scuffham S-gear VST3 plug-in don’t work.
As soon as possible we’ll release a new build of n-Track with the fix.


1 Like