cant get rid of echo using live processing

live processing

I cannot get rid of an echo (not delay) when using the live processing. I have looked everywhere and cannot find any FX on. When I use other FX it just over lays with the echo. Any ideas why this is so? Or is this normal? I even tried to reinstall n-track.


Best guess - your sound card is performing some “direct monitoring.” When you turn “LIVE” mode on you’re also hearing the output from N-track, which will have some latency (how much latency is sound card / driver dependent) thus the echo. First you hear the sound card’s direct monitoring output, then miliseconds later you hear n-Track’s output.

For an experiment, close nTrack completely - can you still hear sound? If so your card is probably set to do direct monitoring. Turn it off via either a knob/switch on the soundcard itself (if an external audio interface) or in the soundcards software/driver. If you think this is the issue, tell us what kind of soundcard you have and someone may be able to help with how to switch off direct monitoring.

Thanks for the quick reply HotDogWater…

Your post must have got the hamsters running faster because I think i found the problem. I was running my mic through a P.A.'s mixer (before going to the PC). And I also had the output of the PC going back to the the mixer. So I tried a few different ways of connecting and presto! No more echo. I now just have the delay witch is understandable. I guess it was some sorta feedback loop causing the echo.

Thanks again for you input on the problem :)