Complete MIDI incompetence

Greetings all,

I have been messing around with recording on computers for a number of years now, last year + with ntrack. My recordings are getting better, my mastering skills are so so, and apparently I am incapable of making a peep with a MIDI keyboard.

I really have done very little with MIDI since I don’t play the keyboards but a CASIO CZ-101 sort of walked into the house and I figured the time has come to learn how to use it. I plugged in the MIDI cable, armed a MIDI track in ntrack, enabled the MIDI slider in the sound card mixer and played a bit and got nothing. After messing with it for and hour or so, I gave up.

Yesterday I pulled out my old 486 since I wanted to move the keyboard out of the way of my main recording computer. So the keyboard is now hooked up to the 486, Windows 3.1, DOS 6.22, Voyetra MIDI Orchestra and an ISP 16 sound card. I figured if I can get it working there, I will be able to get it going with XP and ntrack. I haven’t been able to make it record with Windows 3.1 either.

I think we can pretty much rule out equipment failure here, since I tried 2 different MIDI cables and a second cheapo MIDI keyboard that walked in with the other one.
Can anyone lend a hand here and walk me out of this abyss of ignorance and into the light?


Dont worry Doug, when i start with the midi thing i past a month figuring how to connect the thing. (yeah, im slow)

Some little steps maybe help you:

-You need attach your “midi out” of the Keyboard to the “midi-in” of your soundcard. In cheap soundcards, usually is the port that is used for Joystick. You need an adapter from Din to Joystick.
-You need that you windows version (basically are not diffrences between win3.1 and XP in that busines) list your midi drivers. Go to your sequencer (Voyetra one or n-Track) under “Preferences”>“Midi devices” “Input” and select there the one where is attached your keyboard (can be MPU-401 input, or similar) (if i correctly remember, voyetra call them “port setup” or “port mapping”)
-After that you would must be able to record midi (even you dont heard nothing). Be sure that your midi keyboard is transmitting midi (most of them by default do, but check the manual)
-Well, now you need an output where hear what are you playing. You need to select a valid one in the “midi devices”> “outputs”. Some soundcards includes their own synths, in your ntrack computer maybe you have something like “Microsoft GM/GS wavetable”, and in your old one maybe you have something like “FM synth”. You can try diffrent ones to find the one that is sounding. .In n-track you need to check the “Keep devices open” to hear actually what are you playing.

Well, that is the basic, let us know what are you missing in this info

Quite a bit learning curve to midi…

Another starting point might be to download a midi file or two from the Internet and see if you can the keyboard to play them triggered from the PC.

You would have to tell windows to send the midi to the hardware output as opposed to the onboard synth (as marce has touched on above), but I can’t remember how to do that on Win 3.1 !!! You would need to connect MIDI OUT on the PC to MIDI IN on the keyboard.

You might be fighting with the PC (ie Win 3.1) technology though. Why don’t you try it on your main PC. Should be fairly safe.


Mark and Marce,

Just got back from being sucked out of town for a day and I will try your ideas tomorrow night and report back to let you know how it is going and possibly to whimper a little.

Thanks for your ideas,


Marce and Mark my mighty MIDI Mentors come back,

I have tried both your suggestions and I have no communication In or Out from the Casio CZ-101 to either of the computers.

I have the Cable that came with the keyboard, DIN OUT and DIN IN to Joystick on the other end.

The instruction book for the keyboard says you have to get this window up on the keyboard readout to start transmitting and receiving data.

1< or = nn < or =16

I have that window up and have tried all values 1 to 16 with no communication. The MIDI IN drivers available for the Win 3.1x computer in MIDI Orchestrator are “ISP16 in” and “Voyetra Super SAPI FM driver”. There are no options for MIDI OUT.

I can play MIDI files no problem on either computer but can’t talk in or out from computer to keyboard.

Any other ideas?



I had a Casio CZ-101 years ago and I seem to remember that it was always a bit tricky to get going, but (unhelpfully) I can’t remember any more than that.

Hmmm. Fuzzy thoughts. Something to do with the MIDI channel it sends and receives on? A MIDI mode? Dunno. Yes something to do with that setting you were talking about. “nn” is the MIDI channel. Most MIDI devices should do something with Channel 1.

At this point I would reach for my Midi Monitors… One is a hardware device built into a 5 pin DIN which I can plug into a MIDI cable. The LED lights (flashes) when MIDI is being transmitted down the cable. I’d plug that into the MIDI OUT of the Casio and start pressing keys. I made mine but you can buy them.

The other is a software MIDI monitor (there are several around - try a Google search. But I don’t think you’ll find one for Win 3.1). This runs on the PC, and gets pointed at a MIDI port. It then listens and displays what data is being recieved. From there you can a) check that you’ve actually got something coming in and b) make sure it looks right (right channel etc).

Time to try it on the other PC? Can you get your new PC to play a MIDI file out to the MIDI in on the Win3.1 machine? That would eliminate the PC end of things.

Sorry I can’t be any more help, but that’s all I can think of.


HI Doug, some questions:

There are no options for MIDI OUT

But you say that you can hear midi files without problem. That means that you have for sure a MIDI OUT port (i guess that the “Voyetra Super SAPI FM driver” is the one)
What model is the old soundcard? Maybe you have not installed the mpu-401 input port or something.

Just so we don’t over look the obvious, but do you have the cables set up correctly? The out od the keyboard should go to the in of the computer and the in of the keyboard to the out of the computer. Also, do you have the correct port selected in the software? As Marce mentioned, it is usually called something similar to MPU401.


When it comes to MIDI, nothing is obvious with me at this point. I will recheck the cables when I get home. The Windows 3.1x computer has an ISP 16 sound card with a joystick port.

The main recording computer with nTrack and XP has 3 Creative sound cards, Audigy 1 and 2 SBLives with the kX drivers. They also have joystick ports. MIDI is enabled on all three although I don’t have the MIDI adaptor for the Audigy 1 card so I have to select one of the other cards as the main card in the ASIO control panel.

The cable has 2 DIN connectors labeled IN and OUT with the 25 pin connector on the other end. The keyboard has 2 DIN ports labeled IN and OUT.

I have switched the keyboard back and forth with the 2 computers figuring one must be easier than the other but haven’t had any luck with either.

As far as the selected Port, I don’t know, In MIDI Orhestrator, on the Win 3.1x computer the only choices I have are:

ISP16 in
Voyetra Super SAPI FM driver

There is no selection for MIDI out although it looks like by default in MIDI Mapper, channel 1 is MIDI out.


I downloaded a MIDI monitor software thing for Win 3.1 and will try that out tonight.

Thanks all,


I will check the cables again tonight after I get home between painting the

I have the cables that come with my old sblive or awe64, dont remember to connect to midi. In one extreme it have two Din connector for the keyboard and in the other one to connect it to the soundcard and other to connect a joystick.
One Din connector says “OUT” and i must connect it to the “IN” connection of my keyboard. Is the OUT of the PC but is the IN of my keyboard. I connect IN to the OUT of the keyboard. My first thought was connect OUT to the OUT, they was labeled same, but this dont work.

Maybe the case?

luck Doug, and remember:

“El que persevera, triunfa” :wink:


Voy a triunfar. Es muy posible que tengo los cables conectado al revés en el keyboard.

I will look tonight.


HA! Marce you get the cupie doll prize! They were connected backwards!

I had to run home from work for a minute and my daughter was upstairs playing on the keyboard with headphones. I switched the cables around, fired up the 486, started MIDI Orchestrator and selected ISP 16 as the input.

She played for a few minutes while I had it on RECORD. After I hit STOP the timeline thing showed a pointer for the first time and the LEDs showed something was playing back although I couldn’t hear it-I will try to figure that part out tonight.

So, thanks to you and everyone else for helping me on this. I’m getting there. Now if I only knew how to play keyboards…



Well now I was even able to record a really cheaZy sounding song and play it back through the speakers. Haven’t figured out how to play back through the keyboards yet but maybe I can switch to the real recording computer now.