Crashing problems, Midi sync problems

what to do??

Hi–

Wondering if anyone out there has any ideas about what to do with this situation…

I’m having all sorts of problems with version 4.2.1 (build 2099), which i just downloaded a couple of days ago. I was hoping to fix a problem that i was having previously (version4.1 i think), where ntrack would not record midi when clocked as a slave to an external hardware sequencer (i wish to transfer old midi files and do midi recordings from an external sequencer as part of a larger process). The initial problem in 4.1 was strictly limited to recording midi input while syncing to an external clock (i could record midi if ntrack was not slave, could play back files as a slave, but ntrack clock would not start running when in record+slave mode).

The new problem seems much more severe. When i try to tell ntrack to slave to the midi clock input, it now crashes, generating in the event viewer a .NET 2.0 runtime error faulting ntrack.exe, and usually, though not always, seems to leave a copy of itself running in the memory. When i try to end the process from task manager, it does not end, and it is clearly still running since if i restart the program, there is virtually no load time.

While v4.2.1 has (i think) crashed once or twice for no apparent reason, the main problem seems to relate to this midi sync issue.
Tinkering with the midi settings in preferences don’t seem to have any meaningful effect. Any ideas?

i’m using
win xp
ntrack4.2.1
usb midisport1x1


thanks very much to anyone who can throw any advice my way…

hmmm…

well i guess i’ll be writing to support…

in the mean time, can anyone recommend another program that i could use to record and edit midi files? just something simple and free (so i can start doing what i want to do without waiting for a fix).

thanks

just tried my scrabby old (pre GM) yamaha keyboard on midi record (via midimapper as my midisport usb is at my studio)
added midi track hit record and N recorded OK -

1… can you record direct from a kbd ?
2… to get N to lock to incoming midi timecode correctly you must set the default frames per second in the box,s on the Appearance page in prefs, and this default must be the same as your sequencer outputs n will always refer to this setting when opening up - you may set it via sync page but it wont hold your settings -
3… what sequencer are you using ?
4… untill you have more time to xperiment with settings N should be the master not slave - it your sequencer has Transport controls dont expect then to work with N -

make sure the seq and N are talking the same MTC, make sure you have as many midi tracks open as the seq outputs - some midi files have 20 or more tracks - hit record (may have to press enter if record OK box appears) then start sequencer you can edit out blank space later

hope it helps
yours Dr J

hey, thanks dr j…

i didn’t see your reply right away.

while i haven’t been able to solve the problem with crashing (and haven’t really had the chance to put too much time into it), your last suggestion seems to be the key, as a workaround. if ntrack is the master (i.e. sends timecode out to drive the hardware sequencer as a slave, which passes the data to the other hardware sampler to play the music, which passes the midi data through to the computer and into ntrack) then that accomplishes the same task without trouble, just a slight (basically inaudible, but visible in the events list or piano roll) wobble in the precision of the individual notes.

so for now my problems are effectively solved… thanks again.

-alex