creative asio recording gets no sound

I have sb audigy2. wdm drivers record fine, but If I choose creative asio, if i only tell it to use 1st input, when i record, it records nothing.
how do i use only one input and record correctly?

I don’t use the Creative ASIO software but I would guess that in the Creative Mixer, you need to make some adjustments to select the proper ASIO recording input. Maybe someone that uses the Creative ASIO drivers will jump in here.

not quite sure what your prob is, but a couple of things:

1) the asio driver will only record stereo pairs of inputs. If you want mono you have to record to two separate tracks at the same time or alternatively split the stereo track later.

2) certainly on the audigy zs platinum pro the creative mixer has no control whatsoever on what is recorded when using asio driver. The source is determined by what asio channels you select. If you RTM you will find that there will be up to 20 channels - some relating to physical inputs, some to virtual inputs sourcing a signal from within the card.


so what you are saying is, if i use creative asio or sb asio, i need to record things in stereo, not mono?

Also, what input should i use(as I don’t want to use more than one wav file, can I still uncheck all but one input?)

if i choose creative asio drivers, and select all 8 inputs, input vu meter does not detect anything coming in through microphone, despite choosing stereo under input preferences.

it seems no matter what i do it does not recognize I am sending information/sound. ASIO control panel button, from n-track just brings up a creative dialogue that lets you change latency.

select creative asio driver for both recording and playback. From the hammer you can select record to stereo or 2 x mono. Makes no difference. It may be you are using a physical input that doesn’t come in on channels 1&2. best way to check - under preferences, audio devices, advanced, select 20 inputs. (max no. for the audigy) This will give you 10 pairs of VU’s. (you might have to drag them out to see them properly) From the hammer make sure that all channels are selected. Try recording from your mic. At least one pair of VU’s should indicate an input. Prob more than one pair will - the others are “virtual” inputs recording processed signals thru’ the cards DSP. I can’t tell you for sure which channels relate directly to the inputs as they are different on different versions of the audigy. RTM. The asio control panel does just bring up the latency control. Note that unless you are monitoring using the “live” button you can quite happily set this to 150ms to ensure no pops and clicks.