Direct-X instrument not played

Deleting Direct-X instrument from MIDI t

I used the NI FM7 as an out put for a MIDI file. I did Track -> MIDI -> New Direct X instrument -> FM7
Then I opent the MIDI track proparty and selected the FM7 (as an MIDI output). This worked fine the first time.
When I wanted to do the same thing with another MIDI track (in the same song), I repeated the first sequence of actions again (Track -> MIDI -> New Direct X instrument -> FM7), but when I opened the MIDI track property dialog, I saw that now it has in the MIDI output list two instanses of FM7.
I selected the FM7 instrument and tried to play the MIDI track, but now, no sound was generated.
I think it is connected some how to the fact that I made two searches for the Direct X instrument in the same song.
Now I don’t know how to delete those extra instanses of the FM7 from the MIDI output list of the MIDI track property dialog.
Another option is to try and uninstall the Direct X instrument from the MIDI instrument list, but I can’t see a way to do this.
Need your quick help (especially you Flavio).

To delete an instance of an instrument plugin.

1. Open the mixer (F3).
2. Locate the stripe for the Plugin, then click on that stripe’s title bar.
3. In the “Instrument plug-in channel properties menu”. Click on “Delete channel”.


I’ll try it and let you know.

You should have no problems running multiple instances of FM7.

If the first FM7 you created worked and the second didn’t I would suspect that it is a midi setup problem. When you create an instance of FM7 what is its default midi channel. If it is anything other than omni you will have to ensure that your nTrack midi track is transmitting on the same midi channel as the FM7 is listening for.

I followed your instractions and it worked fine.
Thanks again.

Cool! :D