DirectX Plugins


I wonder if anyone can help me with problem…I can’t get n-track to find it’s own DirectX plugins…Nothing has been recently installed or removed…It just happened all of a sudden…Don’t worry I am not a computer moron…I’m a computer Programmer and musician…I’ve tried everything from uninstalling to reinstalling n-track…even reinstalling Direct X drivers and software…But nothing works…everytime I go to open a song I have done or anything in the effects, it hangs and stops responding…The only thing it says in the bottom left corner is searching for directx plugins and then I have to manually stop the program by crtl-alt-delete…Any help on this matter will be greatly appreciated…

It seems that the plugins are not there because the DirectX scan is not completing - because you are having to stop it.

It may be a rogue plugin - tyr removing all your VST plugins (just in case) and re-trying. Otherwise, try AnalogX’s DirectX plugin manager - perhaps you have a duff one in there:

The current versions of N-track reates a VST scan log. I don’t know if there’s such a log for DirectX plugs? (maybe it’s all the same log) - worth a look around.


It may be hanging after the dx plugs. A major point of concern is bad vst plug-ins. Check the vst scan log like Mark suggests. Also, move all your vst plugs out of the vst fold to somewhere n-Tracks won’t find them temporarily.

Delete n-track2.cfg (file in the n-tracks install folder). This will reset your config information, but this can cause the kinds of problems you are seeing if it gets slightly corrupted. You’ll have to setup you config again.

By the way, there is a good chance that the song is trying us a plug-in that might be not quite right, either as the parameteres are stored in the song, or some other way. That could be vst or dx plugs. Removing the vst plugs will cause n-tracks to skip adding them to the song when it’s opened. Because of this posibility you may have to uninstall any dx plugs that you know are being used in the song, of if you don’t remember, uninstalling any that you may have used.

Don’t blindly get rid of any dx plugs you don’t know what are. There’s a lot that are used for purposes other than audio effects. Getting rid of them with dxman (a really great app) is easy, but may really screw up other apps that need them, including Windows.

Can you get it to search for effects in a new song? try creating a blank audio file and inserting an effect. That might help in narrowing down if the problem is effect related or song file related. Perhaps you deleted an effect the song file is looking for on accident, or some other odd problem? ???


Perhaps you deleted an effect the song file is looking for on accident, or some other odd problem?
This is a good thought. If a vst is indeed missing then n-Tracks won't try to insert it in the song when it's opened. If a dx plug-in has been properly uninstalled then then same. On the other hand is a dx plug-in was simple deleted, but left registered then n-tracks, and any other app that uses dx plugins, will simply try to use it as if it was there. Depending on the error handling in the app and what bits of the dx plugin are still left the app might catch it or it might crash. DXMan will help if that's the case, but may not completely fined errors.

One other thought. Was the song created in the same major version of n-Tracks that you are working with now?

You may actually be hitting a legitimate bug. One of the earlier builds of V4 was crashing after I opened a series of songs. I narrowed it down to opening one particular song and then another. The bug (a fix was in the very next build) was that the first song only had one aux return. The second needed two. The aux returns was lowered to one by opening the first, but opening the second didn't raise it back to two for some reason. When n-Tracks tried to fill in the second aux it crashed since there was no second aux return. This is just an example. Flavio needed to see my sng file to figure it out.

Update on that problem I have…I can open the wav files individually, of course they are out of sync with each other…but i can’t open any of the effects at all…Yes, it was recorded with the same version I have now…I even have a problem with the midi files also…It just locks up if I even go to the effects with no tracks recorded…I’ve tried all of your suggestions to no avail…and thank you all for them…I’ll keep trying…Hopefully I don’t have to do the drastic redo of Windows!..Thanks…Ace

In which case my guess is that you have a duff effect in there somewhere. Did you try removing all the VST effects and putting them back one at a time (or a few at at time) until the scan crashes out?

I had this recently; I’d added a couple of effects but when N4 re-scanned the scan crashed. I routed through the effects and found one I hadn’t used for ages was causing the problem. Out it went and all is fine again.

Yes, I’ve tried taking all of the vst effects out, but still the same…it seems like it has no idea where it’s effects are…I’ve tried recording a track with no effects saving the .sng file…it opens fine. Each time I open the file it’s ok…but the very minute I put in compression or EQ and save it, it crashes again…Help, I’ve fallen and I can’t get up! Thanks again…Ace

Update on my problem…First thing I would like to thank everyone who has replied to my questions…I had to do the one thing I didn’t want to do and that was wipe everything out and start over…Apparently there was some codec causing a conflict with directx…but it’s working fine now…Again I thank you all for everything and keep jamming!..Ace

Explain “wipe everything out”. Did you reinstall Windows or just n-track? If just n-track, did you uninstall first?

What I mean about wipe out everything…was to wipe out and reinstall windows…I could not find the particular codec that was causing the problem…:stuck_out_tongue:

AH! What was probably the cause was a registered dx plug-in that had the underlying dll or a dependent dll missing. When a dx plug-in is registered the app thinks it’s there, but depending on the plug-in and what might be gone, there might be no problem (doesn’t get loaded - plug-in missing from the song, just like removing vsts from the vst folder) or a crash can happen at worst (tries to use a non-existent plug-in).

This is the kind of thing that AnalogX DX Manager can help track down and rectify.

I tried the DX Manager to see if I could track it down, but apparently it couldn’t find it either…so I just made a copy of everything on my hard drive and decided to rectify it…Thanks again…Ace