Downloading & Installing Lame package on Mac

trouble doing same

I’ve tried several times to download and install the lame package on my Mac under Snowleopard (for the nTrack32 program). Even though I run the .dmg package, I’ve never been able to find the actual files for the Lame, so I can’t mixdown to an mp3 file.

This is what I get after running the .dmg package, but I can’t make nTrack locate it. I’ve tried putting the folder in Applications, and also in Documents, but I’ve never been able to get it to work.

Can anybody help with this?

Try this:
- open a Terminal window (Applications/Utilities/Terminal)
- type something like:
sudo cp “/Volumes/LAME 3.98.2/libmp3lame.dylib” /usr/lib

The system will ask you for your password and then copy the folder to the hidden /usr/lib folder, which is one of the folders where n-Track searches for the libmp3lame.dylib file.
The “LAME 3.98.2” part of the line above might be slightly different depending on the dmg (which is a virtual disk that is mounted under the /Volumes folder).
Alternatively you may be able to find versions of the Lame library that automatically install themselves (the DMG you found is simply a folder with the file that you need to manually install).
The next version of n-Track will allow to manually install the Lame library without requiring typing on the terminal.


Thanks, Flavio. I’ll give your way a try and if it doesn’t work, I’ll wait for the next build of the Beta.


Looks like I will be waiting for the next build. I did the terminal thing, but I still can’t get it to downmix an mp3 file.

Probably because I’m not all that educated on the inner workings of OSX.


fjbrad08 , the latest build of n-Track for Mac should open a file requester when it detects that it can’t find the Lame encoder.
Make sure that you have copied the libmp3lame.dylib file from the .dmg you downloaded to a permanent folder (the folder that opens when you double click on the .dmg file is temporary and disappears when you ‘eject’ the dmg).
Let me know if you still have problems with the mp3 encoding.


Thanks, Flavio, that did it.