EQ makes CPU go through the roof

When I open the channel EQ my CPU usage goes up to the nineties. A soon as I close it, things go back to normal. Anyone else having this problem? Anyone got a fix for this? This is with the latest build.

Blessings, Terry

Have you put a report into Flavio? There was a previous bug with the EQ similar to this. By any chance do you have hyperthreading enabled on your machine? I have seen reports of disabling HT clearing up similar issues. I noticed when I went from my Athlon to a P4 the CPU usage going nuts and I haven’t looked to closely as to why, but I am wondering if there isn’t a P4 issue with n-track.

Hi Terry,

I just ran a quick test with the demo. 14 mono tracks, reverb plugin on aux, 42% CPU on a Toshiba Laptop PIII 900mhz 256meg RAM. Opening the EQ for a track caused CPU use to go up to 68%. By making the “Window size” smaller for the response display, I could lower the CPU use by 10% or so. Disabling the graphic display dropped CPU down to about 45-50%. Calculating and displaying the frequency response curve in “real-time” must be a very processor intensive task.

Of course, there may still be a bug-a-boo or two in there…


I have the same problem exactly.

I’m running with a 2.0 GHz processor and 512Mb Ram and even with only one track of audio I get a CPU usage problem upon opening the EQ window.

Surely it cant be affecting the majority of us or we’d be seeing a lot of posts.

I’d be very interested to hear of a fix (apart from keeping the window small).


Mike F

Surely it cant be affecting the majority of us or we'd be seeing a lot of posts.

It could, I don't know how many folks really use the FFT to its full potential or even know it is there. HOw many times do folks post asking for a free EQ plug when they already have a free 20 band built in and go "I didn't even know that was there." I have a hunch it is something to do with P4s specifically because my Athlon was a peach and my P4 is a pig. Notice Athon and PIII users aren't posting with any issues.

Yeah, I probably should send an email to Flavio. I just wanted to see if anyone else wa having the problem too before I bothered him.

It’s really cool that he put the compressor there but I can’t deal with that kind of horse power loss. I haven’t tried shutting off the spectrum part. That may have something to do with it. I’ll wait until I get home and can run a few more tests before I write to Favio.

Blessings, Terry

I have also experienced the same CPU increase with an Athlon processor, but not to the extent Terry or TG reported.

You noticed the increase going from 3.3 to 4.0? I am talking about the same version on two different machines. N uses much less CPU on the Athlon which makes no sense. My old machine was an Athlon 1800+ which runs about 1.5 Ghz with 1GB of RAM and my P4 is 2.66 Ghz with 1.25GB of RAM. Apples to apples, the P4 should be faster and it isn’t.

I’m inclined to agree with Bubba that it may be a P4 issue. My old PC was a PII 450 and n-Track 3.3 performed remarkably well on it. Just had to be careful about too many plugins. My PIII laptop seems to do OK…my newer DAW, Athlon 2500+ (1.8ghz) SMOKES with n-Track. Seems the majority of peeps who post with this bug are P4 V.4.0 users.???

I dunno…


Could be a normalisation issue… Try digitalfishphones normaliser and see if that helps.

Ooo, good idea Willy. I’ll give it a shot. i also need to check to see if I have HT enabled or not. A quick BIOS tweak may be all us P4 folks need.

There is a similar thing going on with the mixer window. Opening it used to make CPU usage jump up from something like 70 to over 90% on my Duron 1000. It would make the program a bit sluggish sometimes. I’ve upgraded to an Athlon now, so it’s not really an issue anymore.

It might be the calculation required to run several input meters at once that uses a lot of CPU power. Overall, I have the feeling that the GUI could be optimized. DirectDraw and things like that?

Quote (Willy @ Oct. 06 2004,14:50)
Could be a normalisation issue... Try digitalfishphones normaliser and see if that helps.

You lost me. What does that have to do with with the EQ window? I suppose it could be isolated to a P4, but if so, then Flavio needs to do something about it. There are a lot of folks using P4's and that's not likely to change anytime soon. I don't think I'm going to run out and buy an Athalon, just so I cna run N.

Blessings, Terry


I’ve got a p4 and I’m definitely having these cpu problems.

At the moment I’ve n loaded with just one midi track and Linplug’s RMlll with only one pad loaded. I tried moving the mixer window (v. small - only 4 channels) with the Windows Task Manager on and it zooms up to nearly 100% cpu usage when moving the mixer window around.

Surely a 2.0 GHz P4 with 512 Mb Ram should be able to cope better than this?

Oh and I checked and HT is not enabled.

I know little about computers but it all seems to point to the graphics side of things - ie eq window & moving windows.

Any more ideas?

Mike F

Terry, this isn’t normalization in the “raise peaks to 0” sense. Normalization in the sense that all the math going on has the right number of decimal places kinda thing. Some plugins go nuts and spew to much data back to the host and the normalization plug he mentioned cleans that up. But, I kinda don’t think that is the issue. Even with no plugs loaded, 6-8 mono tracks takes 15-20% CPU which is much more than my Athlon.

Back when N4 was still in Beta, Flavio sent me an email stating that:

"I’ve just uploaded a new build that fixes a problem with excessive cpu utilization with the built-in EQ and signals fading to 0. It was related to the denormal floating point efficency problem (i.e. cpu performance degrading with extremely small floating point numbers). I thought it might be related to the problems you reported with high cpu usage. If you happen to try the new build I’d be glad to know if anything changes in that respect."

The fix definitely helped reduce the problem on P4’s. But somewhere along the line the excessive CPU problem seems to have crept back in.


Ha! Who’s the man? I’m the man!

My machine runs a p4 1.7ghz, and I tested both the mixer and the built in EQ plugin. The mixer makes the CPU usage jump about 6-8%. The EQ jumps about 20-30%.

OK I checked out that fishphones normalizer plugin. Interesting, but doesn’t seem to help at all with this problem. I’m hoping Flavio is seeing this thread. I haven’t had time to sit down and create a decent email for him with all the info on my set-up. Seems like I’m not the only one having this problem though so it would appear that it’s not just my setup.

Blessings, Terry