Error opening in midi device

Have just recently bought N-track & being an old guy I’m
very slowly making my way. Every time I go to use, I get
" Error opening in midi device", so came to see if I could
find a solution._Great stuff. johnb

Hi John !

(And welcome to the forum)

1st off - do you have any need for midi ?
(If you record anything, do you record only the sound ?)

If you don’t need midi then you can go into File -> Settings -> Preferences -> Click on the midi tab and then the devices button.

Disable any midi devices in there.

You can also set the default recording mode to only audio (there should be a icon on the top menu that has either a picture of a microphone, piano keybaord or both in it. That should only have a microphone in it.

If you have need for midi then you can check in the same location (midi settings) if the correct midi driver/device is selected.

Hope this helps.


Hi Wihan
That does seem to have solved the problem. Many thanks. Ihope Iget to really learn this prog.
Iwant to be able to play & record some songs on my keyboard. johnb

Quote (jaybel @ July 20 2006,06:36)
...Ihope Iget to really learn this prog...

Pleasure !

I'm glad it was an easy fix.

About your comment: N-Track software and this forum have eased lots of people into the recording 'game'.

Stick around, ask questions, visit the n-track wiki and for starters and you'll be fine.

You might just (for future reference) wanna post technical questions in the top forum. There are a couple of people who never come to this side as it is the off topic (dark) side...

Once again - welcome !


Used to have the same problem. If your using windows, in nTrack change your midi output device from GS Wavetable Synth to Microsoft Midi Mapper.