First....and last post

nTrack problem

AMD64 3000/ GigabyteK8-9nf MB / 1.0GbPC3200 / Gigabyte PCI-E6600 128Mb / 2x Samsung 80Gb HDD / M-Audio 24-96 PCI s-card /WinXPhomeSP2 all updates.

I downloaded nTrack 4.1.6.beta. It wouldn’t install without .NET framework V2. I installed .NET then nTrack and it ran OK for that session.
Next day on booting up I got a CheckDisc run on DriveC…strange! That had never happened before.
Next day I could not boot up at all!! Each time I got a quick flash of a blue screen message about ‘Registry corrupt’.

It ended up with BOTH hard drives TOTALLY WIPED AND ALL WORK LOST.

Luckily for me the rig is only 9months old so the HD’s are still under guarantee.

I’ve lost 9 months of recording work and many, many downloaded VST’s, etc.




I bought a new car.
I had it almost a week.
A drunk driver ran into it and it was a complete wreck.
I will never buy that make of car again.


Hi offthewall:
That’s a pretty tough exercise… Too bad…

What makes you think it was n-Track that caused your grief?


Next day I could not boot up at all!! Each time I got a quick flash of a blue screen message about ‘Registry corrupt’


Is there anything else that you can think of, that might be in your "Corrupt Registry? That may have caused that?


I’ve had such things happen (never with N-Track). I think you would be more accurate to chalk it up to the wonderful OS, Windows. There is an easy answer though. If you really want to get back 9 months of stable N-Track music files, all you have to do is download a program like Active Undelete, then reinstall windows and you can get back all (or certainly most) of your files. If you install windows on a drive other than the drive you kept your audio files on (like most people who do this seriously), you will get back all your files. The hardest thing about using the program is that once the program finds all your files, you have to go through them to locate the precise files you want. Took me about 20 minutes to do it.

good luck


To give you an idea on how well the “Active Undelete” works, I have actually formated a drive, reinstalled windows and was still able to recover my entire documents folder that was on that same drive.

Hi DrGuitar and Steve:
Nice reply to this topic…

I have a feeling that this guy is “Gone”… I’d be surprised to see him back here on the board… I’m sure he thinks that n-Track caused all his trouble…

There’s nothing worse than a Bad Working Machine that is Jamed with Conflicts-and-Corruption… :O :(


If there is one thing I have learned in the last 30 years of working with computers (34 to be precise), no computer is absolutely stable and practically anything can screw it up. The good thing is that there are plenty of tools (software) out there willing to help you find answers, as long as the tools themselves do not cause more problems… :(

I think the most important word in his post was “beta”. Beta means it might break something, folks! Use with care!

But that is quite a shame about nine months of work gone. I’m terrified of losing stuff.


The dude’s being a fool, (a) having no backups and (b) jumping to conclusions like that. I’m glad to hear it’s his last post. Anyway, he’s the big loser here. But I’m glad he did post, just in case this actually is somehow related to n-Track, we sure do want to know. But I think we’ll wait for it to happen to someone else before we assume n-Track is the culprit. And, well, we’ve all been fools, haven’t we?

Aikan: replace your terror with a backup system. Hard drives are cheap! Even for those of us with laptops, an external cage with swappable drives, no sweat. (I actually got an external USB/Firewire drive, but now I wish I’d gotten a cage, to simplify the next upgrade.)

So, just for the record: this is the first report we’ve heard of such a thing.

So did the software PHYSICALLY harm the drives? I have never heard of that happening, so I would venture to guess that N-Track was not the only culprit. Sounds like some other issues arose.

Dave T2

Also make sure your computer’s pwoer supply is adequate. I was having numerous unexplained crashes. I tried a bunch of things and finally repalcing the PS did the trick.

I agree with Learjeff. The guy was not even looking for help. He only wanted to make a very inmature post. Problems after reboot? hhmmmm. If you ask me it sounded like he had some type of virus. I wonder what was he using to record for the nine months? Was he exporting from some other program? To been using an earlier version on Ntrack for nine months then to give up on it after a weird misfortune like that seems fishy to me. I would not be surprised if he had some type of pirated version so I do not feel sorry for him at all. And you can be sure that he is still reading the post (maybe not as offthewall), just by the statement “I WON’T BE COMING BACK TO NTRACK AGAIN !”. Yeah Right, looks like a plead for a response to me.

Sorry folks for the attack.
I just got my newly formatted drives back today.
In answer to your responses, yes, I was lazy this time in backing up…my folly!
I did not say I had been using nTrack for nine months…I had only downloaded and run it the one time, my lost work was using Kristal and Audacity and Tobybear.
Having a brand new rig last May and being scrupulously clean over installs and anti-virus and firewalls and everything else…the TWO factors governing this crash were .NET framework V2, which I have checked from the disc as a clean version…and nTrack.
As has been stated ‘Beta’ means not fully tested…again, this is a costly mistake that I will not repeat.

No problem, we all go there especially after an infuriating event.

I’m confident that there’s at least one more factor you’re unaware of, since this hasn’t happened to anyone else that we’ve heard. I mean, not in the 4 or 5 years I’ve been following this board on a daily basis. It’s understandable why you suspect n-Track, but it’s not a smoking gun quite yet.

Even with beta software, the kind of thing you experienced is really serious and not tolerable and totally unexpected.

I’m curious why you felt you needed to get the drives formatted rather than simply reinstalling Windows and letting the installer format them.

It would be interesting to know whether installing n-Track fresh causes a problem on your system. No surprise if you’re not willing, of course.

You’re kind of ‘in it’ now, dude! Let us know what happens! Especially since you’ve seen fit to check back in at this point- good deal.

having a corrupted registry HARDLY sounds like a n-track issue. If anything, I’d say it was the .NET. N-track would barely change any registry settings. It’d pretty much say “i’m here, you can use me” in there. While .NET could change a whole host of settings which if something went wrong, it would definitely cause that problem.

you say this all started the next day? had you restarted windows after your installations? I assume you did, and nothing happened then right? most likely not n-track, and probably not .NET then either.

My bet is you installed, maybe not intentionally, something else that had a virus or something.

Finally, there really was a lot of ways to get around losing your registry. even simply installing windows again and choosing the repair option, or “upgrade” rather than reformatting would’ve reinstalled windows and left all your files and folders still there.

could you have booted into safe mode? (probably not with a registry error) at some point you should’ve gotten an option to choose the “last known good configuration” as well.

you could also have booted to a command prompt and used regscan to check the registry and replace any bad stuff.

I’m sure you wanted to save money, but you really should’ve consulted a technician before having your harddrives just reformatted if you wanted to keep all your files.

oh well, live and learn :)

I had something similar but it was due to a failed restore of an image of my c: drive. The reason I did the restore was because n-track was playing up, but the reason I lost my master file register or master boot file, or whatever it’s called, was due to my own dumb fault. I learnt how to wipe a disc and rebuild my system, and thanks to Bart Lagerweij’s PE Builder, even managed to save most of my files. That guy is incredible. So I think I am the same opinion as most here in that it is easy to blame someones software, but it isn’t always that straightforward. I don’t use ntrack anymore but I keep in touch, and one day if I change my hardware I might give it another try. It has some really great features, and there isn’t an audio software out there that doesn’t crash every so often. Some guys are lucky and their setup all lines up and works, others have nothing but trouble. On my system I suspect the BCA 2000 asio drivers, they just don’t like n-track. Although I’ve cursed Flavio once or twice, the guy puts in a lot of hours on this programme, and has answered most of my mail, which is more than I can say for some companies. Kudos to Flavio.

Can anyone tell me how to tell if my v 2 of .net framework is good?I cannot run ANY version of n track with the framework without frequent error messages.And does v 2 replace v1.1? Or do some versions require the earlier one?
I will admit that The pc I run n track on is the family computer which throws alot of variables in there. ver 4.0.4
runs like a dream with no problems.

Yeah I’m running 4.0.4 and no issues at all on a PIII 660 xp home. solid as a rock so far 1+ years…I don’t believe it runs the .net framework…is this correct?



Hi 291dw:
Before you do this see if the other guys concure… or agree with this operation…

Go to add /remove programs in the Device Manager… Remove Netframworkv2 from your system… Then go to n-Track download and get build 2062… The BIG One… and install the Netframwork that is posted by Flavio… If that behaves poorly, then you can always go the the Microsoft download page and download the Netframwork again from that page…

I’m looking at my add/remove Files now… I have .net Framworkv 1.1 Microsoft .Net Framwork Hotfix (kb886903) These two files don’t have any file size attached to them (in the Coloumn) Then I have Microsoft .Net Framworkv2.0 (with the file size of 88.37 MB) attached to the coloumn… I also have MicroStaff WINStaff WINASPI… (file size 0.21MB)… I have no idea what that utility is…

This Add/Remove List is on the machine I call my editing P-111 … It’s the machine I connect to the internet, with… as well I have all the Garbage I use in this set-up I have here… It’s also the machine I try Anything-and-Everything I download from anywhere in the world. before I install it on my studio machines… Most of the time… everything is running on this machine… I rarely use EndItAll before I begin an Edit Session… But sometimes , I do… At the present time, I replying to the Board I have my Mail opened and running I have n-Track and a bunch of other utilities running on the taskbar and I don’t know what all is running… in the backround… It’s even connected to my internal network that I have here in the house…

What’s wrong with this machine? Why is IT working… ??

I’m knocking on wood by saying this… “Am I Lucky-or-What” ?? All of this stuff seems to work just fine on these machines…

One thing I did this afternoon was…

I attempted to install a WAVES Bundle of Plugins on the P-111 800mhz machine… I encounterd some “Conflict” “Corruption” or something. IT called for a Re-boot… When the machine went through the “Post-up” there was “NO Video” after that. even after a boot in the safe mode… I then booted to “The Last Known Normal Operation” of the machine and then went to to the Desk … After that, I did a Restore Point to an earlier date of this morning and All Is fine with that machine, now… :O ??? :;): Whatever that was? Who Knows??

Anyway, is that of any help to you guys who are in the process of installing build 2062?

I’d like to know more about these computers… especially the XP Desks… However, I am Mid-to-Lo Novice with all this set-up… But, I’m learning…