Genesis Pro VST

Has anyone else tried installing the Genesis Pro VST by Ummet Ozcan? I get it installed and can run fine on Reaper but it just crashes on N-Track. Tried both the 32 and 64 bit versions to no avail. Tried uninstalling and reinstalling the VST using a reg cleaner in between. Still crashes about 5 seconds after the interface comes up.
-Running N-Track 9.0 build 3636 64 bit on a windows 10 system with 16 gig of ram and a Ryzen 5 3600 processor running at 4.0Ghz

Hi buzz66boy,

Genesis Pro is a 32 bit only VST instrument, it means that you can load it normally in n-Track 32 bit or in n-Track 64 bit using the nBridge technology.
After a few tests, this is what I’ve found:

  • the VST seems to work quite well using n-Track 32 bit, apart from a sporadic crash that occurs inside the plug-in itself on loading it when there is no internet connection. I’ll report the problem to the plug-in developer;
  • I’ve reproduced a crash on loading the VST in n-Track 64 bit, which should be caused by a bug in the nBridge logic. I’m working on this.

Please go to Preferences->Path->“Set vst folders in effects settings dialog box” and check that “Add new plug-ins with nBridge” is disabled. Then try to load the plug-in using n-Track 32 bit.
Should n-Track 32 bit continue to crash, please remember to fill and send the crash report that should appear just after the crash, so that we can better innvestigate the issue.

I’ll keep you updated.

We’ve just released a new Beta version for Windows (v9.1.1 build 3641) that should solve the crash when loading Genesis Pro using n-Track 64 bit. To download it go to and mark the checkbox “v9.1.1 Beta”.

Please let me know.

Genesis Pro seems to work well but I am unable to open any .sng file without n-track crashing. I sent a crash report. I uninstalled, did reg clean, rebooted and re-installed with the same result.

I’ve analysed the reports you sent and it seems that the crashes are caused by an old duplicate of the plugin n-Track Sampler installed in a folder different from the one where n-Track usually installs it.
When n-Track tries to load a song containing n-Track Sampler, refers the old file which probably contains code no longer supported.

The problem should be fixed by resetting the plug-ins paths, where the scan is performed, so that n-Track can load the latest installed copy of n-Track Sampler.
To do this, please manually delete the program data folder (“C:\Users[Your Username]\AppData\Roaming\n-Track Studio 9” on Windows Vista and later).

Should the crashes persist, please write me at so that we can better investigate the issue

That took care of it. Thanks so much for your quick response and diligent work. I have been an casual n-track user since version 2 and this is one of the reasons I stick with you. You are awesome!

1 Like