Green light monitor

see input level

Seems like I am often resetting the Monitor green light in the recording VU meter, so I can see the next input signal. It is ON (green), but doesn’t show me the input level until I re-set it. I haven’t correlated exactly when that occurs.

Not understanding your issue here. When you select the “monitor input” icon, you should see the level of the signal coming into your computer. You have to select this for each track, and you can select them all or one, whatever you want. Options, man, options!