Help! Can play song, but glitches during mixdown

I sure could use some expert help… thanks in advance…

I have this weird problem that pops up every now and then. I eventually get it fixed, through some combination of voodoo and kicking the computer, but I’m not even sure what the fix is, exactly. I’m hoping someone can help me out. It’s driving me crazy.

Everything goes fine when I’m multitracking up until I hit about 20-25 tracks. Then this incredibly frustrating thing happens: The song PLAYS fine, interactively, but any time I go to mix it down, there are glitches or dropouts that creep in that completely throw off the syncronization between the tracks, and the mixdown is completely unusable.

This happens even when I choose “mixdown while playing”. Then I HEAR the glitches while it’s being played. But if I just play the song without mixing down at all, everything is fine.

And what’s really weird is, it seems like the .sng file itself is corrupted. Why do I say this? Because I have taken a copy of the song, and stripped out, literally deleted, all but three tracks*, and I still can’t do a mixdown of those three tracks without glitches that affect the tracks being synced.

Has anyone ever experienced this issue?

A little about my system:

My computer: Acer Aspire X1301-U9032 - Athlon II X2 215 / 2.7 GHz - RAM 3 GB - HDD 1 x 320 GB

I have a Mackie mixer with an Onyx Firewire interface, I just downloaded Mackie’s latest Onyx drivers (v 1.7 I think). Not sure if that’s a factor since the problem is mixing down straight to hard drive without playing…?

Currently running XP Pro 32-bit, but I have the option to run Windows 7 64-bit if anyone thinks that might help.

I’m running N-Track build v6.1.0 v2655, I know there’s a later build but I haven’t tried it yet.

Thanks for any feedback…


Not sure of the answer - You are saying it plays okay when you are mixing but but when you do the mixdown - not something I have run into: you did not mention if you are using any effects.
In the Setting > Options make sure the “Shift mixdown according to pluggin latency” and " Compensate plugins latency" are both checked. Probably “Multithread audio processing” should also be checked. On the DPS thread I sould suggest you set that to at least 2. Try a mixdown, if no improvement experiement with the settings. If that does not cure it, try setting the buffers to a very high setting ( more buffering )

Let us know if any of this works

Are you using any midi tracks? I’ve had .sng’s become broken and un-usable - usually down to the midi. (doubtless dodgy plugs).

Hi bax3,

Yes, exactly, it plays fine while mixing, but the mixdown is all glitched up and not synced up.

All those settings are as you suggested, DSP prio is 3, I reset all my settings to defaults recently. I tried the very high buffering and still no love.

And yes of course I’m using effects :O) not TOO many, but generally I’m using reverb, maximizer, a little echo, volume envelopes, some pan envelopes.

Still puzzles me that even when I delete all tracks except 3 of them, I still cannot mix down and have it work. It’s like the song becomes cursed.

Thanks though…


Hi TonyR,

Nope, no midi tracks at all…



You might have to ask Flavio about this one.
But some other suggestions: just some ideas to trouble shoot;
Copy all the files to a different directory - you can use N_Track File > Copy/Move to do this.
This is just a precaution in case something else goes wrong - the SNG file will copy this way also.

You Might have an effect that is not playing nice ( although why it would show up only on mixdown is a new one on me.) However, being as this is not a common problem the only thing I can think of is an effect.
Try turning off the effects completely and try a mixdown and see what happens. If that works add them back one at a time until the error occurs.
I don’t know enough about Windows 7 to know if there could be a problem with Windows 7, 3 gig of memory and 20 odd tracks - maybe try different sound drivers - MME, or WDM or ASIO.
Mixdown half (or fewer) of the tracks to see if maybe the computer memory is running short -
As a last resort - freeze the individual tracks and then mixdown
Good luck

Thanks Bax3, I will definitely try to turn off all effects as a sanity check. But I sort of already did that when I deleted all but three tracks and the problem still occurred – the three tracks remaining had no effects.

Definitely already copy the song to different directories – don’t want to lose our latest work!!!



In the top left of the timeline window is a tiny green button; “all processes on/off”.

OMG I think I actually figured it out. Somehow, the “current song speed” had gotten changed from the usual x1.0 to x0.99. Must have given it quite the heart attack to be trying to change the speed of 23 tracks by such a small amount. I don’t know how that could’ve gotten changed by such a tiny amount. Seems like I would have had to enter it manually, but of course there is no way that I did… so how did it happen?

Thank everyone for your help!

I think the newer version addressed the issue of the slider for the speed being easily changed unintentionally. Glad you found the problem - I still don’t understand why it only effected mixdown . . .

Actually, I listened to the entire six-minute song from start to finish, and I was wrong, the glitches WERE there, even when not mixing down. I was misled, because I was so frequently jumping to specific areas of the song to see if the glitches were there, and when you jump from point to point, the glitches AREN’T there – it takes some minutes of listening for the problems to accumulate bad enough to be noticed.

I logged a bug and Flavio said he’d put in a pop-up warning like “do you Really want to run at other than x1.0?” That will be awesome. I personally have been hit by this bug maybe 4-5 times over the last several years…

Thanks again all…

I think the glitches or another artifacts with slowing or speeding up the “tape speed” in digital domain is quite unevitable. Something must be left out (or added).

That’s really a thing I miss from dealing with real reel to reel, good varispeed.

FYI, this issue is happening in the latest version (2/15/2011) of N-Track.

I can reproduce the problem: All I have to do is, while the song is NOT playing, click anywhere on the “Adjust Playback Speed” slider control. If I click to the left of the slider, the speed changes to x0.99. If I click to the right of the slider, the speed changes to x1.01. I sent Flavio a message re: this but haven’t heard back. Hopefully this will be fixed in the next release!

Same thing happened to me. I must watch my speed. Thanks!