Help with recording delay problem

pause after i push record

Hey guys,

If someone could help me with this I would really appriciate it. I have noticed that when I’m recording sometimes a track will record about 1/2 second late. Definitly late enough to notice. I usually have to manually move the track back and try to audibly line it up with the other tracks. I’m pretty sure that this only happens with the following scenario: I press the record button, there is a delay, and then the time counter starts rolling. For some reason sometimes when I push record the time counter starts right away and sometimes it delays for a second.

I don’t think my hardware is lacking. I am using a Pentium 4 2.4 GHz processor with 256 MB of RAM and 40 Gigs of Hard drive space.

Any thoughts on why it might be doing this and how to fix it?

Another possible related question…Sometimes during playback I will hit a Solo or Mute button and the action will be delayed several seconds. Sometimes it works fine. I’ve tried reinstalling the progam and defraging the computer…to no avail.

Thanks for the help.


Hiya Matt,

Welcome to the forum.

Can you offer up some more specifics? Which OS are you running? Which version of n-Track? What soundcard are you using? There’s a lot of guys hanging around that have seen all sorts of problems and having more specific info will help!


Uncheck “Keep devices open” in your audio device properties.

also to get rid of the delay re solo/mute make sure that “read data from tracks even if muted” is checked under preferences.


I am using Windows XP on my Toshiba laptop with the onboard soundcard, going through the line-in on the card.

Does that help any?


oh yeah, forgot…i am using version 3.3 of n-track


Unchecking “Keep devices open” in N’s audio preferences didn’t work? Hrm… Do you have DMA enabled for your hard disk?

Well the others have already chimed in with some good suggestions. I’ll add one. On my Toshiba Laptop with W2K Pro, I had to disable the lappy’s infrared port in device manager to get ANY audio program to run smoothly. There would be hesitations and a barely audible beeping noise in the audio until I stumbled onto the cure at Toshiba’s website.



Sorry, I may not have communicated well. I’m at work right now, but as soon as I get home I will try unchecking the “keep devices open” box and see how that works.

I’m not sure how to enable or de-enable the DMA for my hard drive. Could you enlighten me?



Windows XP should have DMA enabled by default. You can check it by going to Device Manager. Also, check HERE for awesome how-to’s to get your computer and XP setup for audio work.


EDIT** In Device Manager browse until you find your hard disk controller(s). Click Properties to see which transfer mode XP is using. Should be DMA.

It shouldn’t have anything to do with whether DMA is enabled.

Are you using the WDM, MME, or DirectSound driver?

(Go to Preferences -> Audio Devices to see.)

Try them in this order of preference:


Frankly, if you can’t get WDM or MME to work, you’ll want to get a soundcard or else try installing ASIO4All and then trying the ASIO device. DirectSound doesn’t work well in terms of synchronization.

Also, try BOTH settings for the “keep devices open” checkbox and use the setting that works. Different systems want different settings for this.

Thanks, I’ll try this out.