hung up, frozen and locked out

not just another sunday morning.

Morning all.

I’m running ntrack with jamstix, an increasingly popular combination from what i can see on the forums here.

but i have a serious lock up problem,

every time i do something slightly unexpected (eg, stop the ntrack playback before stopping jamstix, or change the tempo…) it hangs and i have to reboot.

i know both programs are processor-hungry, but i’m running a p4, 2.8hz system with 512mb which i thought should be able to handle it.

my hard drive is pretty full - 5gig of 60 is to spare -

but does anyone have any other suggestions before i start wiping off my mp3 collection?!


What OS are you running on your computer?

it’s xp, running sp2. i’ve got the latest versions of both programs.

i’ve washed windows through with antivirus and spyware - there’s nothing else running in the background,

i’ve also cleared off an extra 10gig and defragged, but it’s still the same.

the lock-ups seem worst when I’m freejamming and hit stop on ntrack without stopping and closing jamstix first. it also tends to lock when i’m playing about with the percussion effects.

it seems very fragile!


i’ve got the latest versions of both programs

What build of n-Tracks? Flavio just uploaded some fixes to a few bugs that were blocking me unless I went back to build 2008. (I missed a few builds because of vavation) That latest beta is build 2026 as of this post. I’ve downloaded it but haven’t yet tried it to see if there are any other issues.

I always use n-track to start and stop Jamstix (the play and stop buttons).
Haven’t had any problems with the JS GUI open or closed.
I start and stop a lot with the JS window open as I put the drum part together using the arranger in manual jam mode.

I do sometimes get the program crashing if I try to remove the JS plugin - I thin kit happens if you are playing and don’t stop the song before removing the plugin… but it’s not really an issue for me.

I’m using build 1846 of n-Track as the later builds are buggy on my system (take up a lot more system resources and crash)

I’m using a P4 2.6Ghz with 1G ram on XP sp2


thanks for the advice. i’ll see if i can find an old version somewhere on the net.

You can download previous releases of n-Track from the downloads page.

found it, downloaded it, fixed it… thankyou!

(maybe someone should let flavio know his updates are hurting his product)

hmmm. noticed a bit of a bug in this version.

on the rare occasions when it does crash, it corrupts itself and requires a fresh install to get up and running again; any attempt to import the old settings mean it refuses to load - so i’ve been through the whole set-up rigmarole several times.

when the 2 play together it sounds pretty incredible though, huh?!

Whenever n-Track has crashed on me with build 1846 I haven’t needed to re-install… just restart the app and it fine (touchwood…)

do you need to do a full install or just reset the preferences ?

Rich - you mentioned on audiominds that since build 1846 CPU usage was higher. Has that issue been resolved?

Thanks in advance.

No I didn’t…
I said build 1846 is stable for me. All builds I’ve tried since have not been stable and been more cpu hungry.

Build 1846 has probably crashed less for me than v3.3 build 1516.
That may also be in part to me having a bit more experience now and not using every plugin under the sun and having settled on plugs that I know work well and get the job done…

Rich - you said the same thing I said (I only mean builds you’ve tried)?

Oh OK… I read it that you thought I was saying build 1846 was high in cpu usage as well.

I can’t remember all the buld I’ve tried but have’t tried any for quite a few months now so they were one of the 4.1 builds not a 4.1.5 build.

I haven’t had time to try any for a while

hi - thanks for taking the time to help out. it’s really appreciated.

it’s very strange … the build will load happily three or four times and then just give up the ghost: on first attempt to reload it draws the ntrack control screen which then disappears in a flash… on subsequent attempts to reload it goes straight to the install shell and makes me reinstall the software again.

this happens no matter whether i use wmd or asio… its very frustrating!

Sounds like memory corruption to me, and memory leaks that are causing memory to get fragmented. That has been a problem is some builds. The need to reinstall isn’t memory corruption, but could be related depending on the corruption and what the reinstall is fixing.

ok, it’s taken a while to figure this out. basically the problem was that after downgrading to an older version, the newer one refused to uninstall properly. flavio pointed me in the direction of the Windows uninstaller utility and its now absolutely brilliant!

by sticking with an old build does that mean i can never upgrade? (i liked the nice gravelly background on the latest one!)

Well you can upgrade once you find a newer build that you works well and is stable on your system and you are happy with…
Just means you will miss out on any new features that you may want if the newer builds don’t play nice for you.

I’ll be sticking with build 1846 until that happens for me…


I am curious.Where can I find that windows unistall utility?