[iOS] Using multi-input AUv3 plugins?

Hey staff, the community,

This is actually a question I have for quite some time but just figured out some time to ask it here - also because as time goes it actually becomes more & more relevant since there are more plugins out there that include this functionality to the workflow.

Since my personal first multi-in plugin download a couple years ago, which happened to be RoughRider 3 with a support for a dedicated external sidechain input, i witness similar symptoms for any AUv3’s of that nature when loaded in n-Track FX chain - the sound of the whole project becomes stuttering, no matter how heavy it is in terms of DSP load levels.

At first I thought that it’s just unsupported technology for this DAW and that’s it. But as I happened to work with more material spending in n-Track more time I started to notice that the 3rd party inputs are actually often recognized by the host.

Not to go any further, here’s the familiar routing dialog window with the mentioned above RoughRider’s sidechain input available with the same logic as n-Track’s native compressor’s input for the same purposes:

image|281x499

Still even considering the possibility to choose it, I experience the same app’s behaviour, as when not using this input - audio is stuttering.

Through the time I faced this problem, it got me stuck in attempts to figure out the solution for it and/or the roots of it happening in the first place -

from changing every imaginable setting of the DAW (32bit/64bit audio engine, input/output settings, etc…) to checking if it’s a hardware issue (started using the DAW on quite dated iPhone 7, then upgraded to SE - 2nd 2020 generation - earlier this year - which is far more capable of any processing task - the symptoms are still there with no dependence in a device being used for testing it out)

So my question is quite logical considering all the text above - is there any technical possibility to use multi-input 3rd party software solutions within n-Track or not? I believe there are some conditions in which it actually works, since it recognises external inputs of the plugins within its interface - otherwise it would not make any sense, right lol?

Would really appreciate any comments regarding this subject from the staff or any user who has an idea of what’s happening here

Thanks!

Yes, multi input AU plugins are supported in n-Track Studio.

I made some tests with theRoughRider3 compressor piloted by the sidechain. It works perfectly on all the devices I tested, but only up to a buffer size of 512. At 1024 it starts introducing big artefacts.
That’s a bit odd.
So I tried with another famous AU side chained compressor, and the same thing happens.

I’m investigating the issue because there’s probably something we can do. In the meanwhile, can you double check you buffer size, so that we are sure we are talking about the same issue?

3 Likes

Hey, thanks for the rapid reaction to the question.

:point_up:t4: Regarding buffer size - indeed it seems to be the case that you described, ‘cause I use n-Track mostly on the final mixing-mastering stage, which is why my buffer is set to at least 1024, 99% of the time.

Quite funny that I didn’t figure out to play with this setting in all the previous attempts to deal with this problem - seemed to me that there are absolutely no possible connections between them. Ideally it shouldn’t be any, but since I tried every other setting, ignoring buffer size kinda makes no sense lol.

:v:t4:Tried to test RR3 with 512b buffer size - works as expected.

Hope that you’ll figure out a fix for this one, since it would be really useful to have this working properly in heavy-load post-productions that are usually the case for raising buffer size

Thanks again for the prompt reply!

1 Like

thanks for the awesome information.