Lag or Sync or what?

Intel 1.3/p3/384k - Layla3G

Hi - my first time on the forum. I just made the jump from 3.3 16 bit to 4.2 24bit. I’m using the same computer as I did with 3.3 (Intel 1.3/p3/384k). My new card is Echo Layla3G. Everything is working great… except…
I bring in track one - a drum track - and it sounds great. Then I record the next track (just guitar). When I playback, the 2 tracks are not in sync. Track 2 is slower and gets further out of sync as the track plays. I hear small pops and cracks in the guitar track like it’s pasuing. With each pop/crack the timing gets worse. I did a test and cloned the drum track 10 times. No problems - sync is fine. I deleted 9 of those tracks and laid the guitar again - same out of sync problem. While recording, NTrack reports that I’m only using 3-5% CPU. I’ve been using Ntrack since ver 2 and not inclined to change. Any Ideas? Thanks - Michael

Do you have programs running in the background disabled (msconfig)

What drivers are you using (MME,WDM, or ASIO)?

What sampling rate do you have set?

Does your cards software indicate what type of latency you have set?

When your laying down your guitar tracks are you using live monitoring?

Are starting recording at the very beginning of the song, or at some time later in the song - ANY time not at the very beginning? I’ve seen this when starting somewhere not at the beginning.

Check to see what you settings are for “Keep audio devices open” and “Use system clock”. Whatever they set to, try toggling them one at a time to see if there is any change.

Also, try the different pre-defined buffer setting. Go one step higher than what it is, then another. I find that while the default settings worked well in 3.3, 4.2 needs to use higher buffering on my machine. I don’t know for sure if it’s a change in n-Tracks or my machine. I’ve gone to a faster motherboard and CPU so it seems to reason I should be able to use less buffering, but not so. That doesn’t rule out other non-n-Tracks stuff but it sure makes n-Tracks look suspicious in this case.

I use Layla20 and Gina24. For 24 bits I use the MME Purewave devices (Gina24 via the ADAT input since the Layla20 doesn’t do 24 bits). ASIO and WDM don’t do well for me, and never have, though they are MUCH MUCH MUCH better in the latest Echo drivers (6.11 in my case). Use what works best.

First fix the dropouts and don’t give the sync issue a second thought until you’re recording solid tracks without pops/clicks/zippers. Dropouts can cause sync problems, but that’s the least of the problems they cause.

First, make sure you’re using the latest drivers from the soundcard manufacturer’s website. (As usual!)

Try the stuff Phoo says because it might help. But more likely, you tried to configure for very low latency and now your system can’t quite keep up. That’s n-Track buffer settings, but only if you’re not using ASIO, in which case you control it using the soundcard’s control panel.

Having buffer sizes set to low can cause tracks to fail to synchronize. It can also can cause pops and crackles, but these dropouts, caused by the buffer overruns, are sometimes not easily heard. If setting buffer size to the maximum values allowed cause the synchronization problem to dissappear, then that was the problem. But there is a balance between buffer size and latency, so you don’t want to set them any larger than you have to. When I had synchronization problems on my system, I was able to determine that drop-outs were the problem. Here is the way that I evenually optimized my buffer settings: First I recorded a click track on one track. Then I put a mic in front of one of one of my monitor speakers, and recorded the click track (from the speaker) to another track. Then I would play back the two tracks and listen to how far apart in time the ‘matching’ clicks were. Then I would decrease buffer size, rerecord the second track again, and listen to see if synchronization was achieved. When I found the minimum buffer size that worked, I added some back to this buffer size, and my problem was solved. I think that it was LearJeff that put me onto this solution.

NOte that there may be cases (at least, I think) where you can get dropouts without a corresponding sync problem. So, tspringer’s suggestion is a good one, but in the end be sure to record a good clean track at least 5 minutes long without much silence or percussion and listen carefully for dropouts. I’ve had enough dropout problems on my rig (for reasons I won’t go into and that aren’t typical or informative) that I routinely check each track I record.

But that’s a good idea using sync to check for dropouts. Never thought of that myself!

StuH: Great question- “do I have programs running in the background?” I hadn’t considered it. I used that system for everything including Internet. I had anti spyware, antivirus, and several programs that I don’t even know all running in the background. I decided that the best thing was to dedicate a computer exclusivily to audio. I downloaded everything I needed (drivers, apps, etc.) first, unplugged it from the internet and partitioned/formatted the drive. Installed XP+SP2+Echo+NTrack. Perfect! I will never let that box on the Internet again. Of course, now I have to use an old slow Dell to access the net but hey, what’s really important here? Anyway, good call, Thanks!
As for the drivers, I’m using WDM because choosing AISO doesn’t work. I get a loud pulsing sound and/or NTrack will not let me proceed (some incompatibility somewhere).

Phoo: I think I have it fixed as per above but the buffer setting has been somewhat of a mystery to me. When I look at my settings, it states the preset as “custom” and live, playback, and recording are all set at 512 / 2. Where does 512 / 2 fit on that scale (low medium high)? I have had some intermittent pops or snaps in playback but the track seems to have recorded ok as I don’t hear them in the same place every time. hmmmm.

LearJeff: Yep, got it. I do hear some snaps and I’ll play with the buffers. The sync problem is no longer an issue. I have DL’d the latest drivers from Echo but the stuff Phoo said is where I look next.

Tspringer: That’s brilliant! What a great test. I was kind of lost about the buffer setting and where to start.

LearJeff: Another great test.

Thank you everyone. It is very much appreciated!
I’ll keep you posted - Michael

Note that there will always be some lag in the test that Tspringer suggested due to the fact that N-track has no way of knowing the delay in the souncard and certainly not the amount of delay in the speaker-to-microphone path (about 1 millisecond per foot).

Another variation of the “loop-back” test is just to connect the output of the soundcard to the input with a patch-cord and measure the delay by comparing the tracks. You should then compensate for that delay by shifting each new track by the amount of the loop-back delay. While I have used N-track for years I have only recently begun doing overdubs where this matters (I do mostly “live-in-the-studio” stuff). I am currently compensating manually but I seem to remember that N-track may have a place to enter the delay to make the compensation automatic. Anyone know how to do this? (I am still on 3.3 but will be upgrading soon).


Good point: I missed the mention of the mic & speakers! Line loopback is better.

Note that you can measure time in milliseconds in n-Track. Right click one of the time bars in the timeline view (above & below the wave display). Select “Set Time Format” and “custom”, and enter 1000 in the space. The number to the right of the period is now a number in milliseconds. Note that it’s NOT a decimal fraction: 12.34 means 12 seconds and 34 millisecons. It would be nicer if it was “12.034”, but you take what you can get!


The electrical loop-back test is probably what most people will want to use unless they are monitoring with loudspeakers for the overdubs. The delay for headphone monitoring will be very close to the pure electrical delay. If you are monitoring with loudspeakers you want the microphone distance to be the same as your listening distance. Small errors will not have too much effect but it is good to get the tracks aligned properly.


Good info learjeff and jimbob. I wasn’t trying to deal with the inherent soundcard lag, but why not eliminate its effect if you can? What about Jimbob’s question about a place to enter an offset? Is is the ‘compensation’ entry box in the wave devices advanced settings panel?