Layla 20 v5.x multi-input crash

Version 3.3 works great - no problems, everything sounds awesome like it always has. I upgraded to version 5.x and the program crashes whenever I try to select more than one audio input at once. I’ve got an Echo Layla 20, Windows XP running on an Athlon XP2800+ with n-force chipset. It crashes whether I try to use MME or WDM. Any clues? I’m sending in a crash dump, of course, but has anybody else run into this and solved it?

I’ve even installed Windows 2000 on another partition, installed the Layla drivers, and then n-track, and still the same thing. Incompatibility between v5.x and the Layla 20?

Maybe - I had a major problem using version 5 beta with my Layla 20. I reported it to Flavio, but that was before the dump feature and he could not determine any link to Ntrack. I have been afraid to try it again I actually had the entire system end up crashing. Please let us know if you get a fix.
I was using XP Pro and an Intel 4, 3.2 with 2 megs of memory.

OK, good to know - I’m going to get Flavio a dump tonight. We’ll see if he can figure anything out. For now I’m just using V3.3, which works great, and he was nice enough to send me codes for it, since I’d bought it a few years ago.

We probably should rename this thread to see if others are having trouble with the Layla products. Anyhow,wmjosiah, any news on your request for a fix from Flavio?

So far so good with V5 and my Layla20.

What’s your settings in the Echo Console and which I/O and MIDI devices are selected in n-Tracks Prefs?

For the most part I use WDM analog. I have used tha ASIO but have better luck in Ntrack with WDM. I do not use Midi with the Layla 20 ,at least not with Ntrack. I have PowerTracks and it works find there. The only program that I have experienced a problem with the Layla 20 is Ntrack and that may not be the Layla - I just don’t know. I am in the middle of a project, so after my crash I went back to version 4 as I have few problems with it.
I am concerned that the drives for the Layla 20 may have a problem with some new aspect of Ntrack. I am using Echoaudio’s drivers - when I open the About it says I have Console version 6.14 and driver version 6.11. This is the latest version availible for the Layla 20 and has been called a bata for over two years.
What driver version are you using?

6.11 beta. That’s the last version. In all respects it’s not beta and we can’t expect another as far as I know. It got good enough and Echo stopped development. They should have removed the beta tag but they didn’t. There is a later console as you have but I still have 6.11. That shouldn’t matter.

I usually use MME since latency isn’t something I’m concerned with. I have in the past had problems when using WDM and was able to use ASIO at all. Most of those problem were fixed with newer Echo drivers. Regardless, any driver before 6.11 had some kinds of problems since Win2K came out (n-Tracks V2.1 at the time – 2.4 never worked for me on any platform). For a long time 6.11 has seemed ok with all three device types, but I haven’t done much with with any except MME.

I’ll have to experiment to see what’s up now. Sorry, I don’t have a suggestion.

Build 2161 and reverting to default settings seems to have solved my problems, so far - I’ll report back after more extensive testing, but recording from four inputs at once works and sounds good, which was definitely not true before :)
Thanks Flavio!

BTW, can I rename this topic? It might indeed be helpful for it to say “Layla 20”… but I can’t see how to re-name it.

Can’t rename the topic, but anyone searching for Layla20 should still bring it up.

Reverting settings is a good thing to do, especially when working with a new version of n-Tracks in the early stages. Funky configs is one of those “interesting things” that happens quite often.

Any more problems since you upgraded?