length limited by buffer size

I know there are some other out there who’ve had this particular situation, so i’m writing to see if anyone has figured it out yet.

For some reason when using Echo Audio products the length of a track you can record is influenced by the number of tracks and buffer size. I don’t mean that my computer can’t handle more, but that when I record, n-Track will hit a point that it simply stops recording as if you hit the stop button yourself. The more tracks, the shorter the time you can record. Turning up the buffer size makes the time longer, but it is consistently as certain length.

Such as this, 16 tracks 1024 buffer= 2:36 total recording length. No more. Ever.

Turning the buffer up to 2048 increases the time to 4:45 or so.

at 4096 I can record up to ten minutes, at 8000 I can get 20 minutes…

WHY DOES IT STOP!!! Flavio didn’t seem to know why when I encountered it a long time ago, but I figured I wouldn’t be recording that many tracks anyways… but now I am.

I know I could just do high buffers and record, but I’d like to do LIVE input on a couple of tracks during the recording.

Any ideas?

2.4 GHz
2 10K rpm drives in a striped RAID
1 80 GB 7200 rpm drive
Echo Layla 24/96


Hi guitars69:
If I didn’t know better I am thinking that you are recording to a pre-set temp. File size… If that is the case. then the Temp File Size is the “Bottle-neck”. Is there something in the preferences that you can see where you can adjust the recording-time versus the file-size in the software you have for that hardware you have?


well, I don’t think my echo has any options like that. And I don’t believe N-track does either. But that DOES sound like what’s going on doesn’t it. interesting…

Hi Again:
Does Echo have a Message Board/Forum that you might be able to post this question … on… Mabey you might get a reply back from some of the clever guys, over there, that is… ???


I’ve been using a Layla20 and Gina24 for a long time and haven’t had that problem with either. I suggest going to http://www.echoaudio.com and contact tech support. They are pretty good but take a few days to get back to you usually. I usually talk to Marcel.

No problems like that here either…using the Echo MIA. Are you using the AISO drivers? I had problems with those…so I gave up and am happily using the WMD drivers now.

Hi phoo and guitars69:
I was sure you had some of that Echo Audio stuff… and would reply to this thread… I don’t have any expirence with this hardware so… I was more-or-less bumping the post…

However, I’m into this ATI Video Capture Process… And Sure enough, If you don’t config. the Temp File to how long you want the “Capture” process… to run… IT’ll Run and shut down at 10 minutes… It’s defaulted for 10 minutes… Game Over… :O ???


I had problems ASIO and gave up, too, but I was using a older driver at the time. I found that MME was more stable on my machine, which is different than most other folks that use WDM. I don’t need the lower latency so it was no loss. Try them all and use what works.

Just in case you have, definitely get the latest drivers from Echo. There was a huge difference in a few of the previous versions. Heck, ASIO might even work for now.

By the way, I brought a Layla24 home from work last week. I was having a problem that came out of nowhere that I hadn’t seen in years. I had not changed my hardware or software. All I did what move to a new apartment. I brought the Layla24 home to see it it too had the same problem that I was seeing with the Layla20. At the time the Gina24 didn’t seem to have it, but this weekend it too started having issues. I did discover the problem and it had an easy fix.

If I get some time this weekend I should be able to try a repro of the stopping problem with the Layla24. It will be interesting to see if it repros with just the Layla24 or if I can get it to happen with the other interfaces as well. I don’t record at 96k so maybe the higher sample rate is related. I might not have hit it during normal recording since I only do 8 tracks at 44k at any one time. The max time would be a lot more with that config.

echo has no forum. sample rate doesn’t affect the time limit, just track count/buffer size. I use ASIO exclusively for LIVE input processing… I’ll try WDM. using latest drivers, and have been since they quit making 24/96’s

Phoo, you’ll probably be able to record 8 tracks for like a half an hour, but I’ll bet you it’ll stop. I remember someone else had a layla 24/96 and had this same problem last time I brought it up.

I tried it out with wdm drivers and got a buffer underrun error. said I can adjust the warning in the preferences, but I couldn’t find it. I bet that’s what’s happening with the ASIO, but I don’t get an error message.

so I got a response from echo audio and they suggested I try asio4all.

so I’ve downloaded/installed it and read the manual and all. I’ve got it all configured to work with n-track, and it’ll play a song file through my speakers.


I can’t record anything? none of my inputs are showing ANY activity on the VU Meters. My preamps show signal so I know it’s getting there, but nothing in N-track.

Any ideas?

If you haven’t done so since you installed the ASIO4ALL driver, try the following…

Make sure that your Layla is on.

Then, click as follows:

Start-> Settings -> Control Panel -> Sounds and Audio Devices -> Audio

You should now see a panel labeled ‘Default Recording Device’, and in the device field you should see something like ‘Echo Layla’. If the name of your device is not the default, click on the drop down list for recording devices and select it. If the Layla doesn’t show in the list, then try to reinstall your driver.

I’ve got it working. I didn’t expect to be able to use the Layla control panel simultaneously with the asio4all panel. The problem was that my layla wasn’t synced up to my ADAT. I shoulda’ been able to hear 8 of my channels with the internal clock, but I couldn’t. First tests show that I don’t have to worry about the program stopping. I still can’t use the LIVE feature though. It clicks and pops. One thing I noticed so far is that when it’s working, my controls are more responsive without problems. I used to just open up my eq controls and the audio would quit playing before. Now I can open it and move the controls around without having some problems. I’m gonna’ experiment some more tonight.

BTW my audio device is ALWAYS my layla. my internal card is disabled in the BIOS.

thanks though.