Lost or confused  notes

in vsti playback or mixdown


I’ve I problem with midi playback and mixdown.

When I use sfz (freeware sf2 player) in a midi track the software do not play some notes. Or play two notes instead one. This change if I started the playback from an another time.

Have anybody similar problem. Is there the problem with the sfz or the n-track?

What can I do?

I had this problem so bad I couldn’t use sfz. It was VERY frustrating. It went away when I upgraded to a faster motherboard. I don’t know if the CPU speed fixed it or if it was something else. Other than that nothing I tried helped before the upgrade.

What CPU do you have? My old machine was a 750 mhz PIII. The new one is a 3.2 ghz P4. I upgraded to the same brand MB and kept (for a while) the same hard drives.

I don’t think the cpu upgrade fix that problem. I’ve P4 2.6 G processor. And If I mixdown the song there is lost notes too. And it is independent from the cpu.
It is surely a software problem. But I don’t know which software wrong: the ntrack or sfz. But I think i try sfz with samplitude demo and there was not the problem…

Is there any free sf2 player which works good?

Or could Antonio fix this problem?

I don’t use SFZ, (I have an Audigy2ZS), but, does it happen when used as a plug-in with other apps?

Does it have a stand alone mode, and if so, does it happen with that?

If it’s only with n-track, then you may have a reason to appeal to Flavio, but check first. :)

When I use sfz as standalone there wasn’t any problem with it…

I have encountered this problem quite a bit. My thinking is that the MIDI data in n-track gets “corrupted”, for lack of a better term.

My workaround is to export my MIDI tracks, and then import them into Anvil Studio, which you can download for free. Anvil will tell you that there are errors in the file, and repair them for you. Then just save the new midi file, and then import that back into N-Track.

Then delete the original midi tracks, and map the new ones to your VSTi’s.

It works for me most of the time. Your milage may vary. There also may be a better tool for this than Anvil, but I haven’t gone looking.

Hi cmw!

I try what you suggest. Indeed the anvil studio found errors in the exported midi file and corrected them. But when I import it in n-track there wasn’t major changes. Maybe a few lost notes now play but most of them are mute. :(

It is intresting with the midi file. If I use sf2player it works good. But sound of sfz is better than sf2player…

I uploaded a part of a song.

In the firtst time I playback the music but not from the begining.

Second time I mixdown the music. When the song is playing missing some piano notes.