Metronome not on Grid

Midi clicktrack records faster than Grid

Hi - not happy to be back!

I had this problem for months when I first got N about 3 yrs ago. Somehow it got sorted and now it’s come back to haunt me.

To diagnose my problem, starting with a new track I’m trying to make a simple recording of the metronome playing through MIDI (either through internal MIDI via MIDI MAPPER or through my Audiophile soundcard’s output to an external MIDI instrument).

When I record the metronome and display the Grid, the recorded/played .wav plays a tiny bit faster than the grid. The problem seems worse if I use vsti N-TDrums than if I use an external drum machine, when it’s only about 1/2sec in a minute off.

Thing is, I’ve loaded N today on our family PC and it works fine. The differences I can see are:
1) that the success is in 16bits, the failure is in 24.
2)the system clock with the failure is an Akai dugital multtitracker - but that’s always worked fine and I don’t doubt it.
3) The success is on XP, the failure on Vista.

I also reinstalled N-Track (Version 6.0) and my soundcard recently as part of this dismal episode, so I don’t feel doing the again will be answer.

Any ideas?
I guess the

Hi Gusto Belly:

I see pingcat up here as well, at the moment…
Maybe, he has the FIX you need…

I’m not sure if this will work…
Not being a MISI freak or spending much time around n-Track and in the Midi world…

I’m sure someone who has this knowledge will see and respond to the issue…

However, I wonder if hi-lighting the metronome track on the timeline and pressing ctrl-A or under the edit drop-down click on “snap-to-grid” or ctrl-B, might FIX the issue you have…


Thanks for trying, Bill. For this situation though, there shouldn’t be any question of fixing anything - it MUST be made to just work. It’s so fundamental as the basis of every song, and certainly for me it’s worked for over a year until recently. You record the clicktrack, play along badly with a MIDI keyboard and everything just lines up beautifully with the grid so that correcting the MIDI notes with Piano Roll is straightforward: no timing issues.

What’s up docs?

what are you using for timing on the Vista machine?

System timer
Wav. timer?

is it set up the same on the XP machine?

keep shinin

jerm :cool:

Quote: (jeremysdemo @ Nov. 13 2010, 12:08 PM)

what are you using for timing on the Vista machine?

System timer
Wav. timer?

is it set up the same on the XP machine?

keep shinin

jerm :cool:

:agree: Aye, Jeremy.

Plus. Have you tried an earlyer n build? I often work in a similar way and have had a bit of this with various builds.

I thought of something else…

Do you have “echo” clicked on one of your midi preference? I remember that could cause what you “hear” from the metronome to not be on timing with midi tracks.

Have you thought of using a midi click track? it would then be played at the same time as all the other midi tracks? that is how I do it…(or make a wav. click track)

keep shinin

jerm :cool:

Germ - I’m using system timer. I’ve experimented with “Wave” in trying to sort this but now stick with “System” for recording and playback.

I know this has worked for me in the past using version 6.0, which i’m using now.

I’ve got the MIDI echo on Auto, which I’ve never ever changed.

I think I’m going to reinstall the soundcard. If that doesn’t work, logic seems to point to the Optical->SPDIF connector between my Akai mulltitracker and the PC. Trouble is - I really don’t think those are the trouble and that latter process will require cash. So still - any suggestions will be appreciated!

Sorry - “Jerm”, not “Germ”!!! No offence!

None taken.

So your not going to try using a midi click track instead of the metronome?

What are you running the Akai on? 1.2?
I know they had a problem with Vista when 2.0 first came out and a lot of guys went back to 1.2.

Have you thought of using the PC as the Master and the Akai as the slave?

Check your snap to setting too make sure they are at 0.

Also are you using up the polyphony? that can put strain on the processors.
What is your quantizing setting if you are using it?
I would keep that below 70% and see if it makes a difference.

Your using the MTC and not the midi clock right?

keep shinin

jerm :cool:


For the past 2 weeks I’ve tried everything with this;(i) MIDI clicks via my soundcards MIDI out to a Roland drum machine,(ii) Midi clicks generated from VSTi N-Drums.I’ve generated the clicks from the metronome, of course.

I’ve just checked my Akai DPS12i’s O.S… and it’s 2.1.

Iv’e just had a mess about and realised that a click .wav using N-Drums IS in sync with the grid! I’ll report back again shortly …

… to continue …

When n-drums plays in line with the grid, it’s playing its own patterns, and not being driven by the metronome. That’s interesting, and probably should be helpful - but I don’t know how!

I only use the Akai for a mike and guitar input and to drive the clock from optical out (then converted to SPDIF). the settings I’m using have never changed and I know they work.

I try to avoid snapping to grid - these clock-driven events must line up without making adjustments (and I know it’s possible!)

The metronome’s only driving one drumbeat at a time, so I can’t be using up too much resource that way, and no other tracks are playing.

I’m going to go and disconnect/reconnect all my MIDI cables and if that does nothing I’ll reinstall the soundcard again.

I’ll keep you posted. Thanks for your help.

Hi, Gusto. Turn n-TDrums off.

Turning N-Tdrums didn’t seem to help, TonyR - but I think I’m sorted!!!

I diconnected all my cables & reinstalled the soundcard: - no improvement. Then I did something I’ds already tried - and it worked. I set the timer to “Wave”. It suggests it in the manual, so it was one of the first things I tried last week, but this time it seems to have worked and I can record Midi data to .wav and .mid files that stay on the Grid.

Must’ve done something right!

Thanks for your help, guys. Till next time…