missing .dll (help)

I have a registered copy of version 3.3 (16bit) I just reinstalled it after wiping my computer
it opens fine but whenever I open a song file I get the following two messages as it searches for VST plugins (I click okay on each and the song seems to open and work fine though)

This application has failed to start because+l32v20.dll was not found

This application has failed because CWDXPX1.dll was not found.

I’ve tried reinstalling the program and re-registering twice but it’s still doing it…ideas ???

Well, I’ve had the warnings too, vstscan doesn’t like all that it finds from your plugins folder. You might want to remove some plugin that you recently added to your collection and see if it still isn’t happy with the way things are.
//edit: and if it seems to work ok, you don’t necessarily have to change anything.

I have CWDXPX1.dll posted on my downloads (bunch of random stuff) page: http://downloads.phootoons.com It’s zipped up, so unzip it to c:\windows\system32 and you’ll be done with one problem. Tht file is required by many dx plug-ins that were created using the cakewalk directshow sdk.

I don’t know about the other file. Sorry. Is that filename correct?

Sweet, thanks Phoo! I am not on my home machine right now so can’t chech the name of the other file but I am pretty sure I typed it right. At least it looks like one problem will be solved. I guess I can look around the net for the other .dll and just load it to that same dir to fix the other problem?
I think it may have something to do with rgc reverb hich I haven;t found to download again but had on my system prior to my wipe clean…only thing I can think of.

I am using version 3.3 (16 bit) build #1516 and did a search on my machine for the file you mention. (+l32v20.dll )
No result. I tried various combinations using wildcards during a search. No luck there either. I guess this file could be from a plugin that you have and I don’t. Anyway, good luck with your problem.

I have this problem, too. Another .dll is missing when scanning for vst-plugins :


Does anyone know where to get the .dll ? Otherwise I´ll have to search what plugin needs this .dll and remove it.
Thanks !

I would guess that it may be related to a DX plugin which is installed on your system which doesn’t have all the dlls it needs - maybe a bad install/corrupted uninstall.


Are you getting these errors when opening n-Tracks or when you open a song? Daniel is right. I too am pretty sure you have some dx plug-ins that appear to still be installed that aren’t there anymore. They will show up in the registry but the required files are not there.

Check out DXMan from AnalogX. http://www.analogx.com/contents/download/audio/dxman.htm

It does wonders when trying to fix registry problems (which is what missing dx plug-in files becomes) caused by incomplete dx plug-in installs.

Thanks so much for your replies. It is happening when I open a song not when I just open the program. It also only happens the first time I open the song. If I open a different song then go back to the original song it doesn’t do it. I will install the .dll file phoo provided tonight to fix the first problem and see what results I get. I also have a couple registry cleaners already that I will try to run and see if that helps as well. Looks like I’m on the right path though, thanks to you all. I did try to search the net for that second .dll file and found no info on it either. I have not added much in the way of plugins so it shouldn’t be hard to trace down I guess…

by the way, how can I tell which plu in needs this .dll do I have to go through each one and just see if it’s working or is there a better way?

DXMan might tell you, but you’ll probably have to narrow it down yourself…the one that doesn’t work might need it. Yeah, it’s a pain. :)

Opening a song on a machine that doesn’t have all the pug-ins needed is suppose to remove the plug-ins from the song. I don’t remember the waring, but ther should be something. If it gets opened once you should be able to save it as a different filename, and that one should be fine from now on, of course minus the missing plug-in.

THAT is for truly missing plug-ins. Partially installed plug-ins or ones missing support dlls aren’t missing so the problems that can arise are anything from none to total crashes. It depends on lots of stuff.

Flavio has a new build posted of V4 that creates a log file if VSTscan.exe bombs for some reason. I would assume this would help one sort out such problems. Obviously the dude looks at the forum and listens to users!


Yes , with help of the log-file I could find out what plugin it was (FuzzPlus and TK - LPFilterMod)
and now it works fine…:slight_smile: Thanks to Flavio !!!

Bat also thanks for your answers !

Thanks to all for replies. I was able to fix the first error so Now I’ll just have to look into which plug-in is not working. It is a pain but I don’t use a LOT of them so I can narrow it down pretty fast. Hey, this was my only problem after a total wipe clean of my system with installation of new operating system and some hardware changes…I’m not going to complain!
I backed up N-Track as well as Fruity Loops and am already up and running again on both…sweet.