any help greatly received


I have been messing around with nrack for a few yrs now but have only recently took it upon myself to try and do some recording that could possibly rival my local studio and justify me spending my hard earned cash on new gear and not with the studio. After reading a few books, countless hours on the web and investing in some new mics, leads, mixer, monitors and pc upgrade the time came to put all this study to work. Only to learn that I also had to be a pc tech aswell. Night after night discovering that there were different drivers, sample rates, midi (something which is totally new to me)started to take its toll and the whole process stopped being fun.

All I wanna do is to record some bloody music.

I have a addictive drums, but it only seems to work in live mode. when I play back everything is out of synch… Im sure my pc should be up to the job latency shouldnt be a problem.

Are there any settings, pointers or links that you nice folks think would be of any use, I think ive read tweakheadz guide about 100 times. I have trawelled through this forum and countless others. Any info would be greatfully appreciated. My g/f is getting fed up with my frustrated musician moods… hehe

AMD athlon 7750 dual core 2.71 ghz
4g ram
500g hd 7500rpm
windows xp
audiophille 2496 pci card
600w psu

BTW, the midi learning curve is a steep one…

What do you use for a midi controller?

Anyway, I gather you are not able to do what you want to do. Is it that you are having computer problems or is it just a matter of learning how it all works?

About the sync thing. How do you create the drum MIDI files, with a controller or by programming? Do you get imported MIDI files to play back OK? Do you get any VSTi’s at all to play back in time?

If you totally stuck, try downloading something like mda Piano. Program a simple melody with the Piano Roll and see if you can get it play back on the Piano-VSTi. Once you get that far, you should have a basic idea of how MIDI works with software instruments.

The work-flow in nTrack is pretty simple, once you get everything up and running. But I know that getting there might be problem. I’m having some really frustrating times myself, with a misbehaving drum-plugin.

Good luck!


I know that Flavio, our GOD, is working on a setup routine for N-track that will save your configuration, (many Configs) in case you have to reinstall N-track for whatever reason. This way once you have it working, you’ll have a working configuration so you don’t have to “re-learn” how to set it up.

Just chip away it, ask how to do one item at a time, and people here will help all the way. Remember the more information about your system, and what your trying to do will help those who know what to do, help you. Everybody here has been through it once or twice, it’s just a matter of asking the right questions and taking your time. Welcome to N-track.


Hello again

thanks for the words of encouragment…

I programmed a simple click track using the piano roll and addictive drums on TRACK 1. The click track plays back just fine.

I record a simple guitar strum pattern via a mic onto TRACK 2, no probs so far, everything souding cool in headphones.

TRACK 3 I record something a little more complex which picks up more during the chorus, once again via a mic. As i am recording everything sounds just fine, I can hear the
previously recorded guitar strum and click track in my headphones all is good…

When recording track 3 is over and i playback the end result, the third track is always off regarding the timing - not even close especially on the chorus (this is only a 100bpm song, my playing is not at fault here.) How come with just 2 audio tracks and 1 vsti?

Im recording with version 5.1.1 build 2313.
recording in 24bit mode, 44100hz.

buffering is set to fast response, latest wdm drivers, asio just the same.

I have tried re-recording track No.3 with just the click track, vu meters off. makes no difference.
live button is off, keep audio devices open is unchecked.


sounds like a difference in sample rate playback being set not the same as sample rate recording? not saying that’s it but do check your drivers that they match by setting both input and output the same - either asio or wdm same set of drivers in settings - audio devices.

Only thing I can think of - my apologies if you’re way ahead of me on this. I know how frustrating it is.

I just been playing with it…

if i play back all three tracks, track No.3 is out

If i must the click track, track number 3 suddenly fits into place and I start smiling

If i unmute the click track, everything goes wrong again.

Jamstix for the click right? Vsti?
You might want to mix that click down to a wav file then import it back in. Sounds like it’s draining resources or a bug with JamStix?

Jamstix is really cool, but there is so much going on with it, it sometimes does weird things. But he said Addictive drums…?

Export the click as an audio, that’ll take care of the problem, I’d bet.

Addictive - I see said the blind man. Mix to wav if not already.

I was on the similar train of thought. But if I mixed the click to audio, eventually I would want to put a proper drum track on there. Wouldnt that put me back to square one. Im worried about working my ass off on a song then when I come to add the drums it all goes wrong again.

BTW, is the new version 6 much better than the previous version 5? Or am I just as well sticking with version 5 and saving my

Good points both.
Invest your time then get screwed?
Invest your money and get the same?

With timing issues you might convert to audio then the mid for new track may be impossible to get right if the mixdown to wav is “off” then nothing done in mid will match or you will have to find a “magic” BPM then you’re into it so deep the song doesn’t mean anything but work and frustration, you hate everyone and everything and just want to give up. :p

I’d personally spend some time in preferences and settings and buffering to see if I could get Addictive to play nice before making the call.
I upgraded and tested ver 6 bought EZDrummer fought it until I had to give in and find another program to do my drums in. The difference in how it handles my VSTi is like night and day,… anyway my loyalty to n-Track took a back seat to my love of the creative process, my sanity, my God given gifts and talents. But that’s just me.


at least im greatfull to learn that I am not alone with such problems, as for hating the world I think Im already there. I hate using drum loops as their so untweakable and was so looking foward to using addictive drums but this really is starting to do my head in. I may have to revert to the loops. uffff.

Well what I do a lot ‘ralph’ is map the song out in my head or even on paper - drop all my loops in from EZDrummer and just do a drum track mix to stereo wav to record the rest of my files to. Sometimes if I’m good enough at it I’ll get the levels good enough to hold up for the entire song project. Other time I may have to go back to my drum sng file and remix after all the other tracks are done and get it better. It can be done if you save the drum sng file and go back to remix.

Ideally though using your program the way it was designed to be used as a virtual instrument is the way to go.

Anyone else using Addictive in n-Track?

You might also try to use a low-resource VSTi as your click, just to test things.
Only other suggestion I can think of is to try different buffering settings…
BTW, what you got for sound?

Let us know how things works out!

Is anybody else using Addictive drums with nTrack? There might just be an incompatibility problem.


Im using audiophille 2496 card. latest drivers.

Ive now tried various buffers and drivers. WMD and asio. I had 128 buffer samples right up to 2048 and still the same. Im get a reading of 1ms plugin latency (bottom right) no matter what I have the buffers set at. The cpu meter on the bottom left is usually at around 6%

This afternoon I got so paranoid about my playing I did an audio take of what was coming through my headphones during recording. On playback It was perfect so i know it was not my playing at fault here. That prompted me to record just the AD midi as audio once again from the monitor channel. On playback with just the audio take and the midi track playing, within a few seconds the two drumbeats started to seperate, and by the time we got the chorus is was no where near in unison.

Ive spent about a week on this now… enough is enough. My first venture into VSTI and midi has so far been trying to say the least. I have to say tho, I have learnt a hell of a lot during that time. I will soldier on and find another way. :)

Read this link - it’s come up on the forum before.

And again - better results probelm solved.

Quote (RichLum @ June 27 2006,02:27)
Also make sure you have your soundcard clock (timer) set in the preferences (not the system timer).

Just to clarify Richlums point, untick both the system timer boxes under prefs/settings/options.

Also, try alternative drivers under prefs/settings/recording settings/audio devices button. Try both wdm and asio, or mme as a last resort. If that doesn’t work, update your soundcard drivers and try it all again.

Also, check your own soundcard’s control panel to see what your sample rate is set at (ie should be the same as in your n track settings).

It sure sounds like the clock s drifting. Poppa is on to something when he reminds you to uncheck the boxes in the Settings that us the systems clock. Any “Pro Audio” cound card should have a clock better than the system clock.