Pianoroll Editing

Hello,
I’m stuck in a recurring nightmare with Audio where upon loading a sng. and pressing “Play”, N-Track will either crash or pop up a screen saying “Do you want N-Track to find a compatible Audio Device?”
I always click “Yes”. Sometimes N-Track will crash, sometimes the song plays, quite often the Hz will be changed from 44100 to 48000 and I have to go through the settings to change it back.
It is frustrating.
Also, if I change an instrument on a track I have to save and restart N-Track to hear the new instrument, very frustrating.
More recently, I’m unable to watch any of your tutorial videos after using N-Track as I’m prompted with an “Audio Render” message.
I can tolerate all of this to a point, but what I cannot tolerate, and this has happened many times before, is that I cannot hear any of the sounds when editing in Pianoroll unless the song is playing.
I’m not a great keyboard player (I have an Oxygen II 49 when I’m feeling lucky though recently my MIDI keyboard doesn’t play unless in Record mode) so I usually create everything on the Pianoroll, which is really difficult when you can’t hear anything.
I really don’t know where I’m going wrong. I’m using the same equipment since I purchased N-Track 9 some years ago, HP laptop on Windows 10 and Oxygen II 49 MIDI keyboard, and I check regularly for updates.
I’ve been using N-Track a long time and created hundreds of projects with it.
Surely, if the equipment is the same and this problem reoccurs, it must be the software?
If you can help, please let me know.
Many thanks,
Adrian

Adrian,

I’ll try to respond to all the points you wrote:

  • the problem with the sampling frequency could be related to the song having been saved with 48000 set as sampling frequency, so when n-Track loads the song it reverts back to the song’s sampling frequency, which the audio device possibly doesn’t support so you get the prompt
  • if you get a crash report prompt after n-Track crashs, please fill the report so that we can try to investigate the crash
  • is the audio engine is not running you won’t hear MIDI notes played on a keyboard and the instrument may not change. Make sure that the button on the left of the time position indicator says ‘Live’, if it’s showing a blue button with a crossed speaker it means it’s not running, click the button to make it run
    image

If this doesn’t help, please send a short video showing the issues to support@ntrack.com and we’ll do our best to help. Please include the Settings → Audio devices box showing which audio device you’re using.

Flavio.

Hi Flavio,
Thank you for your detailed reply, it did eventually lead to a solution.
The “Live” indicator was, like you said, a blue button with a crossed speaker. No matter how many times I tried it would not change to “Live”.
I ran a “Troubleshooter” in Windows and it seems I have a faulty Audio Driver.
After re-installing and restarting, N-Track is now working fine again.
The Hz, MIDI in/out and crash problems must also be associated to the driver fault.
This reoccurring fault must be due to a Windows update. I’m sorry to have raised this with you again, it was the audio driver at fault, not the N-Track software. I know what to do if this occurs again.
Thank you once again Flavio, you are a genius!
Adrian

1 Like