Problem: Can't hear input, but i can record.

Hey everyone

I hope this post isnt a repeat but ive searched and searched this forum and the net and all the solutions that seem to work for others isnt working for me :(

My problem is this: ive hooked up an external drum machine to the line in of my dell laptop computer (sigmatel audio soundcard). i can’t hear anything through my headphones (which are connected to the soundcard out) without any programs open (im not even sure that im supposed to hear audio without audio programs open???).

that being said, within n-track, i can see the recording vu meters working properly and at a good level just below the red but there is no action with the playback meters and i can’t hear any sound. if i press LIVE button, i then hear sound, nice and loud and the playback meters then start working. once i turn the LIVE button off - no sound and no playback meter. if i press record, i cant hear what i am recording until i stop it and then press play - the audio file is recorded perfectly.

this same thing happens when i use goldwave - an audio editing program. i can see the recording vu meters jumping but cant hear audio until i actually hit the record button and start recording.

my question is this - on my old computer i used to be able to hear the audio through the computer speakers with the exact same setup. i used to be able to preview the audio with my equipment plugged in before i actually pressed record. im not sure what happened???

ive gone into the soundcard volume mixer and made sure all the sources are checked and turned up appropriately for both playback and recording. this doesnt appear to be the problem?

any suggestions?

thank you in advance. :)

It would help us if you gave some details about the OS system, and card.

You say you recently changed computers so as you may be finding out not all fish are the same.

I do remember this problem occurring on several systems and usually with new ones until the initial setting were set up correctly, so have no fear you are not alone, and the answer can be found once it is narrowed down to the type of soundcard and OS.

I found two similar problems in the recent past with DIGI001 and M-audio JamLab.

The solution for the Jam labs was:

In Settings --> Preferences --> Options I had to check the box in front of Auto add tracks when live button is pressed.

and the DIGI001 was:

for live monitoring…it had to do with clicking on the monitor button to turn it on.

That’s all I can think of from memory without knowing what soundcard you have.

keep shinin’

jerm :cool:

your old PC may have had a soundblaster onboard chip/soundcard and it would do as you say, your new PC does not have that and does as you say above which is correct - you only hear the input through the output when LIVE is enabled -

Dr J

i am running windows xp w/ the factory sigmatel audio soundcard that comes from dell.

shouldnt there be some way to route the input (line in or mic in) directly to the output (line out / speakers) so that i dont have to actually be recording a track in order to hear my input?

thanks again! :)

Quote: (temporary_saint11 @ Oct. 02 2007, 2:08 PM)

shouldnt there be some way to route the input (line in or mic in) directly to the output (line out / speakers) so that i dont have to actually be recording a track in order to hear my input?

Absolutely! You should NOT have to use LIVE to hear what you are playing. Not sure where the comments about the SB cards come into things either... anyway...

I'm not sure how computer savvy you are, and I'm not familiar with your exact setup but most of these types of issue can be solved by getting familiar with the mixer applet for your soundcard. Some cards have their own mixer applet but I suspect that in this case you have to use the Windows applet.

I know you say you've checked the settings but I'll mention them again just incase...

The Windows mixer is two mixers in one - a RECORDING mixer and a PLAYBACK mixer. The way of switching between them is a little confusing at first... Go to "Options-->Properties", and then select the mixer you want. Tick all the boxes in the "show the following volume controls" area below the mixer selection so that you get ALL available controls.

On the RECORDING mixer you should be able to select only one recording source. Let's assume that it's LINE-IN.

Now go to the PLAYBACK mixer (again selecting ALL the volume controls on the way in). Make sure that LINE-IN is enabled and not muted. That should sort it. I have seen some cards though where the volume controls have been mis-labelled in the mixer so it is worth going through them all.

If this fails, then perhaps check to see if there is a later driver for the Audio chip on the Dell site. Just enter your PC's tag number and it should list you all the available drivers for your machine.

Hope you get it sorted.

insert a blank audio track - leftclick on the little grey button that appears to the left of the track, select which audio device you want to use for recording and also tick echo live input (button will turn red to show that the track is armed) - now click on the live button and what goes in the input comes out of the output -

you have to arm the track (set recording device) this does not mean that you have to record anything, youve just prepared the track incase -

when you get that far you may find that what comes out is quite a way behind what goes in - this is due to the buffer settings being to high - change buffer settings, the lower you go the faster it is between input and output -

Dr J

I had the same problem with my dell lap top,i even took it to a music store and tried with a external sound card and they couldnt get my input to monitor.i bought a desk top more power for less money

hmmmm… that doesn’t sound good if your dell didnt work out…

the problem is i can’t monitor anything without having the LIVE engaged, which means i can’t hear myself at all when its not on. i can see the recording vu jumping, but i can’t hear anything until i stop the recording process and listen back to the track. when i try to actually record with the LIVE button engaged, a warning comes up saying that its using too much cpu power - so that’s not an option.

XonXoff - i have gone through the windows mixer applet, both recording and playback mixers, and made sure everything was set properly - all boxes ticked and levels up. still no solution :(

i am going to try a new driver from the dell site, but im not too optimistic about that working.

i just dont see why i can’t monitor my input without having to record it and listen to it through playback. it should technically be as simple as plugging in a mic and being able to hear myself through the speakers without even using n-track. i should be able to monitor my input without having to press LIVE and have the cpu process it.

this should be simple but its frustrating me like crazy… there’s gotta be something small that im missing!!! :angry:


this should be simple but its frustrating me like crazy... there's gotta be something small that im missing!!!!

Well I think you've been through all the usual steps so perhaps there's a bug in the driver or laptop design - or mabye even a "feature" (let's face it, you don't need to hear yourself through the speakers when using Skype etc so it might be considered "better" to not allow it at all incase a non-savvy user gets into trouble).

Using LIVE to monitor yourself introduces the whole latency discussion which is a complete waste of energy unless you are trying to use VSTi. I do all my monitoring through my mixer so perhaps that's comething to consider? Or possibly a new soundcard?

Have you tried Dell support? The whole n-track thing doesn't have to enter into your discussions as this should work outside of any application.

Just searching around -
but it appears you have to use
either MME mode in options/audio
or use ASIO4All driver

I would try the asio4all driver since it’s a stand alone driver/app. Also in your post you said headphones connected to soundcard out? Is this a headphone jack?

Thanks for all the suggestions guys - I think I may have figured things out… haven’t had a change to try it yet, but after trolling around on the Dell support forums, this monitoring problem appears to be a common issue on Dell cpus and can (hopefully) be fixed with a simple registry change to allow for monitoring.

Check these posts out:…&page=1…#M23240…#M27465

This seems like a completely stupid setup error on Dell’s part. Let me try this sometime over the next couple nights and see if it makes a difference. Here’s hoping!!! :)

Best of luck to ya!

keep shinin’

jerm :cool:

Like I said I had the same problem w/my dell laptop.i borrowed my freinds laptop and found that if you can plug in a mic and hear yourself thru the internal laptop speakers your good to go.i called dell and none of their laptops support this funtion due to feedback and speaker damage.let me know if you have better luck w/an external sound card i didnt.anyone wanna buy a like new dell laptop b130 for $400?

Many laptops have built in mics that are enabled by default, so throughput monitoring is usually disabled since the same machines usually have built in speakers. If they didn’t defeat this functionality by default (and make it hard to enable if at all possible to enable) there would be a huge number of support calls.


makes sense i guess. i would just imagine this would be easier to fix than a registry edit!! my cpu doesnt have a built in mic so this technically shouldnt be an issue but alot of things that dell does don’t make any sense… oh well! :p

I got it figured guys!!! I just followed these instructions and made a few registry edits to bring up an input monitor line in my windows mixer applet:…=&s=gen

Problem solved!!! Thanks so much for all your help! Very much appreciated! I hope this thread can help some others out too! :)

Quote: (temporary_saint11 @ Oct. 03 2007, 6:59 PM)

I got it figured guys!!! I just followed these instructions and made a few registry edits to bring up an input monitor line in my windows mixer applet:

Problem solved!!! Thanks so much for all your help! Very much appreciated! I hope this thread can help some others out too! :)

Well it is appropriately titled, so if someone is having a problem with hearing the input this will pop up in that search. :)
Not only does this thread display the common solution for a dell, also a few other common related solutions as well. :D

keep shinin'

jerm :cool: