Q10 and n-track problems

n-track does not like my soundcard

Hi all.

I’ve got the evaluation version of n-track installed on my pc.

I’m trying to use it on a Carillon AC1, a built for audio PC, on which I’ve been using Sonar, Cubase, Kristal, and several other programs.

My soundcard/interface is 2 Aardvark Q10s.

I cannot for the life of me figure out how to configure n-Track to record from the Q10s. I try to record a single mono track, and no matter what I’ve tried, it records 2 or 3 new tracks of silence.

I’ve seen where a user on this forum uses n-Track with an Aardvark Q10.

The documentation for recording a mono track is VERY confusing to me. All I can record are mono tracks, and the documentation has all this nebulous info about a ‘stereo source’ and whatnot.

All I want to do is record multiple mono inputs into this app. How is it done?




I’ll also point out that some years ago I had purchased n-Track and had it running on a Win98 machine. No problems then, as I was just using the cheapo factory pc sound card, never recording more than one track at a time…

Hello? Somebody? Help? Please? :(




Bring up the recording vu. Hit the hammer, select stereo->two mono tracks. Click on the red button on the vu meter, and select “don’t record from this channel” for each input you don’t want to record from.


Quote (Willy @ Aug. 24 2005,06:51)
Bring up the recording vu. Hit the hammer, select stereo->two mono tracks. Click on the red button on the vu meter, and select "don't record from this channel" for each input you don't want to record from.


Thanks for your help.

One thing that was really stumping me, that I think I've figured out now, is that n-Track is calling my mono channel four "two - right channel." That still kinda boggles me somewhat but I think I can work with it.

Thanks again, Willy. :)

[whispers to self] right two is four, four is right two......


That would be because ntrack deals with stereo pairs. While you might have 10 inputs (8 analogue, 2 spdif, yeah?), it’ll equate to five stereo pairs:

Mono1 = one left
Mono2 = one right
Mono3 = two left
Mono4 = two right



I’m not in front of n-track at the moment, so I can’t tell you exactly where, but you can also re-name the sound card inputs to names of your choice to simplify this.

If someone can point out how for me, I’d love to know that one… I know you can do it in a roundabout way by “Track -> insert blank track -> audio” and then renaming and recording from the appropriate input under the track properties button, and repeating for each channel. But I really need that to show up on the recording VUs. I’m on 3.3 if that makes any difference.


This new feature came in with 4.0.3 build 1711. Right click on any track, then select “Properties”. Click on “Output Names” or “Input Names” and you can change the soundcard default names to anything you like.

One apparent bug: “vstscan.exe” consistently gives me an error message, it hangs or crashes. Doesn’t crash the program, fortunately.

Suddenly I’m gettting some weird echo-y playback of sounds that were fine a few minutes ago.


hmmm, I’ve closed and re-opened the prog several times, restarted the PC, removed all effects, other progs are playing back audio fine, n-Track keeps giving me this echo-y playback.

Tried changing the buffer size, nothing seems to help, I’m stumped.


Sounds like you’re routing one of your outputs back to your inputs. Normally a soundcard setting.

Quote (jmccullo @ Aug. 24 2005,16:48)
Sounds like you’re routing one of your outputs back to your inputs. Normally a soundcard setting.

Could that be it, even though audio is playing back fine in other programs? Is it something I could change in n-Track?

Now playing a Cubase multitrack file, sounds fine.

Now playing n-Track file, getting weird echo.


Not using the wdm drivers and hitting the live button are you?

not hitting the live button (I promise), using asio drivers. Is asio a no-no for n-Track?

timmehfz3, I have the Q10, dunno if I can help, but I’m using ASIO, n-Track ver 4,something, windoze XP, no problems at all. I have no explanation for the echo, but I can at least tell you that it all works together somehow. :)

Heh, I promise I’m going to give up soon, and stop asking questions. :)

Just now, I hit the hammer on the playback vu meter to see if there were any settings I needed to change there, and when I tried to record again, the program had arbitrarily armed all my inputs. so it recorded 16 tracks. Funny thing is, that stopped the echo! :O

I put the input setting back to just the channel I wanted to record, and the echo’s back. sigh I have a hard time believing it’s my sound card, since other stuff is playing fine. I dunno, maybe it will decide to play nice later. Thanks all who tried to help…


Too bad Aardvark is no more. Anyway, just to make sure, it worked with all inputs going, but not when you have a single one going? That is, you set one to “record to a new track” and all the others to “don’t record”? Have you also tried using only one of the q10 units? I only have one, but I have never had the problem you describe, and perhaps something weird happens with two? Like I said, I’m not exactly a computer genius…


this might be of use to you, BTW:


Describe your cable routing, including MIDI cables if any.

vstscan.exe crashing and/or hanging point out that there may be a bad vst in the path. A log file is created that should let you see where it went down.

What you are describing sound external to n-Tracks (except the vst problem) unless you are changing the settings to turn on the Live button. Monitoring through n-Tracks (using the Live button) will cause the sound to be delayed. If there is a feedback loop external to n-Tracks there can be a similar problem.

Disable the inputs all together and pull the cables - see if that changes anythig.