"error opening .wav file" dialog when selecting

the .wav is in the right place and fine?

I’m running the latest build of nTrack on a Dell Inspiron 600m (2.1ghz, P4, 384mb) laptop.
I run all of my .SNG and .WAV files off an Iomega 250gb USB2 HDD.

Whilst working on a new song last night, I kept getting an error message that read “error opening .wav file” - the dialog box had an “OK” button, but nothing else - and the dialog box had no "title."

I would get this message when using the “select” tool to drag over a range of a track so I could zoom in and edit envelopes, noise, and start/stop points. The error would pop up as soon as I released the mouse button at the end point of the range I had selected.

And, I would normally get two at a time in quick succession. If I clicked “OK” to get back to the timeline, nothing more happened, and I never saw any side effects or problems.

Mostly, it was just annoying.

It did this on a couple of different tracks, but it didn’t do it on ALL the tracks on which I performed this operation.
And, when I removed one of the tracks completely, it stopped.

However, the .WAV files for all the tracks were in the right place, weren’t corrupt, were named correctly, and had worked the day before with no problems.

The only thing I may have done - and this doesn’t seem like it should have had an impact - was to “rename” a few of the tracks by clicking it in the timeline and typing a new name in the dialog box that opens allowing you to change track color, mapping, etc.

Any input?

Try copying your song and wave files to your local disk and see what happens. Sounds like the USB might be “dropping” connection or at least to N-track it might be seeming that way.

Eyup!

Windows does not instantly save any changes to any file directly to disk. It waits until it decides the time is right. Normally the disk cache is flushed every few milliseconds, but I suspect this may not be the case with removable drives. I know of instances with USB pen drives where data has been lost because the user simply unplugged the drive without “ejecting” it first.

Steve

Which brings up a topic I’m interested in trying…I wonder how N would react to me recording/playing/saving my songs to a raided set of disks across a small network…anyone tried it?

It depends on the transport protocol I would guess. I suppose you would be doing SMB as opposed to some iSCSI implementation and honestly, I don’t know how the overhead of SMB would behave. Can’t hurt to try, just don’t try it with anything really important at first. BTW, fellow storage nerds, check out these:


FreeNAS
SAN on the Cheap <-- I have used Heartbeat and DRBD in clusters before and it really does work. Pull the plug and MySQL or whatever just keeps on chugging. iSCSI is the last nail in the coffin!