Recording with POD XT Live via USB

I use N-Track on my WinXP Laptop. Unfortunetly it has no LineIn (MicIn only), so I have to operate with an external soundcard.

Recently I bought a POD-XT Live which offers to record directly via USB.

After the installation of the Line 6 USB drivers, my system offers some new Audio devices:

Line 6 PODXT-Live - MME, WDM, DS and ASIO.

When I record with WaveLab, using the MME device, everything sounds fine.
So far, so good…
…but Unfortunetly it doesen’t work with N-Track.

I tried to record with all available Line6 Audio devices, but I just hear noise. I tried to play back a song we recorded some time ago with the same result.

Any ideas?

I have a GuitarPort and I haven’t been able to get it to record directly either. I have to route the audio out to an audio input on the soundcard.

The error I get in n-Tracks is that the sample rate isn’t supported, no matter what settings are used. That’s a semi-generic error since I think anything that prevents the port from being opened might pop up that error. I’ve seen it before between my Gina and Layla when I know for a fact the problem wasn’t simply the sample rate (like when the Layla isn’t turned on or has become disoriented and needs resetting)
I have a feeling this is more than simple user error, but I hasn’t taken the time to dig in enough to know for sure. In any case it seems like it should just work as long as the sample rates match.


Bought a POD XT LIVE last month, and have yet to get Ntrack to record via USB with the POD. It’s just a bunch of LOUD noise, I almost went deaf with my headphones on and played back what I had recorded.

It’s ashame too, because the consensus on the Line6 forum is that USB sounds clearer for recording than running from the line out.

I read somewhere, here?, that some appliances like POD make a pc want to think its THE soundcard. Could it be an IRQ issue?

Not likely. If that were the case then it wouldn’t work in other apps and would cause other kinds of problems in general.

I’ve heard that but I’m sure exactly what it means to be THE soundcard. The way I interpret it is that it becomes the only soundcard available when it’s running, and that can’t be possible if they want these devices to be used with anything else audio. That would make them useless to anyone for recording.

I recently set up a new computor for recording. I also downloaded Line6 pod drivers and got it to record from my son’s podxt through USB. It worked ok but I’m not sure it was any better then going through my Delta soundcard. I’m not sure why it’s causing you trouble but you do have to select the podxt as your recording and playback device for it to work. then you can’t play back through your soundcard while your’re recording. I have had a lot of trouble getting my USB to work from my Digitek USB400.
Come to think of it I do recall getting a message about Sample rate not matching so I opened the pod driver control panel and set it to 24 bit 48000hz and then it worked.

I'm not sure why it's causing you trouble but you do have to select the podxt as your recording and playback device for it to work. then you can't play back through your soundcard while your're recording.
That surely would be indicative of it being THE soundcard. I haven't tried that yet.

I did go through all the supported sample rates/formats and not one would prevent the incorrect sample rate error dialog from popping up - GuitarPort and n-Tracks both matched and different.

Yes-when you use a USB interface, which the podxt functions as, it does take the place of your soundcard. I assume you are using a 24 bit version of n-track. I will try this out again tonight when I get home to see what happens, but what I can recall is that I select the podxt on n-tracks preferances under audio devices. Then click the hammer icon on the input meter and make sure I’m set at 24 bit and in one of these places you can also bring up the podxt control panel and set those as well at 24 bit 48000. Turn your outputs on the pod way down to start then bring them up untill you get an appropriate signal level. If you’ve done all that and it still won’t work then I’m not sure what’s up.

I got back to the last night and this morning. I had a bit of luck and a bit of not luck.

I could not get it to work in any way shape or form when the GuitarPort was set to 44.1k or when using any GuitarPort devices except ASIO. Different setting in n-Tracks have no effect.

Setting the GuitarPort to 48k 24bits would let it work. By work I mean the error opening devices dialog didn’t open when the GuitarPort was set to 48k - 24 bits and the ASIO Guitar Port input and output was selected in n-Tracks. That was the only combination that caused the dialogs to go away.

I did not record anything. I don’t use 48k for recording and have no projects done in 48k. I’ll try it later of course…BUT…

I reset the devices in n-Tracks back to the Layla20 and opened an existing project. It would not play. It was stuttering and the CPU usage was sky high and playback was stooped automatically. I had recently upgraded to build 1790 so I reverted but that didn’t help. I rebooted and reset the soundcard. That didn’t help. What did help and ultimately fixed the problem was to revert the setting in the preferences. This is the same as deleting ntrack2.cfg.

My guess is that all the changing of devices and settings in an attempt to get the GuitarPort working corrupted the preferences file in some way.

I’ll continue to experiment but for now I’m content to record the audio out from the GuitarPort as I have been. There’ no way for me to tell if this is a problem with n-Tracks but I can’t get it to work in Audition either, though I haven’t tried everything in that app yet.

It shouldn’t be this hard. It’s not when using the Layla.

So what happened for mash inc and caxn? Did you folks get your podxt’s to record USB. I just went down and did it on my computor using n-track. I’m not sure what happened with that guitar port but you’d think it would work about the same. I’ve recorded with the pod and digitek both with USB and just using an analog line out and I don’t really hear too much difference.

I have to post on this, I’ve been using my Pod XT Live as a recording device via USB. I have only had minor problems with clipping etc. - but otherwise it seems to be excellent. I didn’t do anything fancy as I’m new to ntrack and Pods.

I record at 48k 24bit. Make sure to set your Pod XT Live drivers to that format. Then in Ntrack select the POD XT WDM drivers for I/O. Then select 24 bit on your ‘hammer’ input devices.

I’ve even got 32D setup as a fairly clean but slightly eq’d and gated vocal input… but recently replaced that with an Audigy 2, which I’m not sure works as well.

I record at 48k 24bit.
Can you get it to record in n-Tracks when it's set to 44.1k? 48k seems to be the only option even though both n-Tracks and the PodXt/GuitarPort will do 44.1k.

First of all, thanks for all those answers!

We also did some testing in the meanwhile, with the Win2K LapTop of our bass player. The problem on this LapTop is diffent, but quite interesting:

1) When we playback a single track, everything sounds pretty normal
2) When we playback 2 tracks at the same time, there is a litte noise to hear
3) Playing more than two tracks you just hear noise

On both machines N-Track hung up by the time, when switching between devices and sampling rates.

At the end of the testing orgy N-Track was completely confused. It was not even possible to record or playback the usual way with the internal soundcard.

After unstalling the USB drivers and resetting N-Track to “default” the problem was solved.

I will try the settings of rotorboy and let you know the results.


I haven’t tried yet, I’ll try some tweaking tonight.

Oh, a note that might help. when I use the POD XT Live as my soundcard, I disable the other soundcard(s) in my machine. That way the POD is the only card.

This means I have to listen to the playback on my headphones through the POD, but so far that’s been working great.

Another thing I learned the hard way. DON’T use long USB cables! The one that came with the POD works great, but I’ve tried a couple of my longer USB cables with crappy results. It seems the stock cable or something of good quality that’s short is best.

Also, fiddle a bit with the More and Less CPU. I’ve often got mine closer to “Less” than “More”.

oh, and sorry :p , but I only use 24/48 setup. If it’s an option for you to do the same, I would suggest it. Why? Well, it seems to give me the best results. Honestly that’s based on what others have told me, not on my own tests. I started with 24/48 based on the words and wisdom of my producer (guru).


it works fine with 48kHz sampling rate.
Thank to all answers.