Runtime Error

1 Like

Hello all,

I’ve just formatted my machine and reinstalled everything. After assuring that the sound card works (Emu 0404), I’ve downloaded build 2099 (I’m a registered user, of course), only to find that it crashes within minutes (when trying to change my config., when using the ASIO control panel or even when just trying to exit the program). Before crashing, it displays this message: “Runtime Error! Prgram C:\program Files\FASOFT
-track studio 4
track.exe This application has requested the Runtime to terminate it in an unusual way. Please contact the application’s support team for more information”.
I’ve E-mailed Flavio about it, but he hasn’t answered yet. Does anyone have any idea what can possibly cause this error?

Thanks!

Oren

You’ll get this solved, allright, but you’ll need to post you PC’s specs, including CPU, Mainboard, RAM, et al. Also, what else you may have on your system HD.

I’m no PC dude, but if you give up all the info you have on your system, and even get set to give a step-by-step recreation of the crash scene, one of these n-Track Sharpshooters will show up and set you in the right direction.

Thanks!
The PC is an AMD Duron 2000+, with 732MB of RAM. 40GB HD (IDE 7200), an EMU 0404 Sound card running the latest drivers. There’s pretty much nothing else on my hard drive (except for the AVG anti virus and the Google Tool Bar), as it was reformatted yesterday. I’m running WinXP, Service Pack 2, with the following system services disabled:
Alerter
Application Layer Gateway Service (-> 2,3)
Automatic Updates (-> 17)
ClipBook
Computer Browser
DHCP Client (-> 4)
Distributed Link Tracking Client
Distributed Transaction Coordinator
DNS Client
Error Reporting Service
Fast User Switching Compatibility
Help and Support
HTTP SSL
Human Interface Device Access
IMAPI CD-Burning COM Service (-> 12)
Indexing Service
IPSEC Services
Messenger
MS Software Shadow Copy Provider (-> 10)
Net Logon
NetMeeting Remote Desktop Sharing
Network DDE
Network DDE DSDM
Network Location Awareness (NLA) (-> 3)
Network Provisioning Service
NT LM Security Support Provider
Performance Logs and Alerts
Portable Media Serial Number Service
QoS RSVP
Remote Access Auto Connection Manager (-> 7)
Remote Access Connection Manager (-> 7)
Remote Desktop Help Session Manager
Remote Procedure Call (RPC) Locator
Remote Registry
Removable Storage
Routing and Remote Access
Secondary Logon
Security Accounts Manager
Server
Shell Hardware Detection (-> 14)
Smart Card
SSDP Discovery Service
System Event Notification
System Restore Service
Task Scheduler (->1)
TCP/IP NetBIOS Helper
Telnet
Themes
Uninterruptible Power Supply
Universal Plug and Play Device Host
Volume Shadow Copy
WebClient
Windows Image Acquisition (WIA) (-> 8)
Windows Time (-> 13)
Wireless Zero Configuration (-> 9)
WMI Performance Adapter
Workstation

That’s pretty much all the info I can think of…
Any help would be appreciated!

Run msconfig again and enable all MS devices on service and startup.

I got a funny feeling there is a crucial program diabled

Hi Guys:
I believe there are MicroSoft Runtime Updates you need to install… If you go to this link you may find these files…

http://www.microsoft.com/downloa…C533E0C

Another thing to do is… Go to Windows update and run the wizzard… START > Windows Update or MicroSoft Update… Get Current with all the latest Microsoft files that are there… Mabey, updating your Windows Desk might fix the issue you have…

This might help… worth a try…

[EDIT]
Set a “System Restore” Point… Before you get too far along… with this…

Bill…

The system is 100% updated. I will try to enable the MS devices and see what happens.
Thanks!

I’ve enabled all MS services, updated everything, and it still doesn’t work!!!
Flavio has no idea what an cause this…
:(

I’ve installes build 1811 and it works fine. So it has to do with the .Net runtime component… Any ideas?

you have angered the micro$oft god and will have to sacrifice your firstborn for appeasement :D

What version of .net do you have installed? 2099 requires version 2.0. Have you tried uninstalling and reinstalling .net?

I’m using version 2.0. I’ll try to uninstall and reinstall…

Didn’t change a thing.
:(

Perhaps your n-track download or yours settings files have been corrupted. Try unistalling n-track, deleting the existing ntrack directory, downloading build 2099 again and reinstalling. This is kind of a long shot, but it won’t take long to do. Not a lot of options are available at the moment.

Can you create a track without crashing? Or does ANY action cause a crash?

T

Did all that and it’s still the same.
The program actually runs reasonably well (though it is slower than ever and pops and crackles appear all the the time, even though the CPU usage is at 20%). I can record, playback tracks, use effects and everything, but the minute I try to change something in the configuration, or just close the program, it crashes.
By the way, I installed build 2099 on my old PIII laptop and it works like a charm. This is getting really frustrating and I’m seriously considering (for the first time in 6 years) to forget about N-track and move to Cubase or something of a sort…

Hi Aren:
Could IT be that the audio card on this computer is sharing the IRQ with another piece of hardware? I say that cause I’ve been working on this P-4 rebuild and I’ve found that this setup didn’t like sharing the audio card with any other hardware on the same IRQ… On other DAW’s I have that issue doesn’t seem to be important… Networking wav files from one-DAW-to-Another I have to use an application called EndItAll… to ensure that any applications are not running in the background… Then… the tracks “Stream” just fine…

Could IT be that you have some registry corruption issues?

I still have a few performance issues to work on, with the setup I have… but IT’s getting better…

This all happened as a result of a Mainboard that failed… with a P-4 that I have in my setup…

Bill…

Tips to fix-

Restart the computer.
Update the program to its latest version.
Fully delete the program, and then reinstall it.
Install the latest Microsoft Visual C++ Redistributable package.
Use SFC scannow to repair corrupted Windows files.
Run System Restore to return your computer to a previous state.\

Regards,
Rachel Gomez