Skipping in recordings

After buying a used Focusrite Saffire Pro 10io, I upgraded to n-Track v6 and started doing various live recordings from the mixing console through this soundcard and my Asus laptop. But there’s one problem:
When playing back the recordings, there are skips now and then. The recording is usually fine for the first five or six minutes, but starts skipping more and more as the recording gets longer. About 0.1 to 0.2 seconds are skipped, and the intervals between skipping varies between a few seconds and a minute. I use the Saffire Pro ASIO driver.

I’ve tried lots of things to solve this problem, but none of them helped:
- Disabling unneccessary system devices like WLAN adapter, card reader, Bluetooth etc.
- Changing priority from applications to background services
- Changing from 48k to 44k sample rate and trying 16-bit rather than 24-bit.
- Increasing ASIO/Firewire buffer sizes.
- Using WDM rather than ASIO. Caused sync problems between tracks.

Are there anyone else experiencing this problem, or do anyone know any methods to try to solve it?

You can search the past posts for recording “live with ntrack and a laptop” by the user John. From Houston who gave weekly reports on his live recordings. He covered all his experiences good and bad. In 2004’2005 i believe.

If you are recording to the internal laptop drive, try using an external USB2.0 or Firewire drive. Look for one that is NOT buss powered, has at least an 8MB cache and a 7200RPM rotational speed.

Most laptops come with a 5400 or even 4200 RPM drive and are not ideally suited for streaming multi-track audio. I have recorded 16 tracks at 24/44.1 successfully many times to a USB2.0 external drive. Your description sounds like your disk subsystem can’t keep up.


PS Since your audio interface is already using Firewire, I’d try USB2.0 first. Many external drives are available with dual connection capability. USB2.0 and Firewire…

Are you using windows vista on your laptop? I have an asus laptop and I have to cripple the software/n-track in order to make it run generally without skipping. I do run vista32/home pre. Please provide some details about your system, maybe I can help.


Dubious: The problem appears even when recording just a stereo 48 kHz 24-bit track. I don’t think the hard drive (160 GB PATA) is the problem. The computer is otherwise fast and responsive.

Paco572: I’m running Windows XP Pro SP3. I’ll never “infect” my computers with Vi$ta.
The specs on my Asus A8F are:
CPU: Intel Core Duo T2300 @ 1,66 GHz
Memory: 2 GB DDR2
HDD: 160 GB PATA, 8 MB cache
Graphics: Intel GMA 950
Chipset: Intel 945GM

I’ve never been able to record at 24 bit (due to limitations of my sound card and BFD drums stand alone) only 16 bit at 96000 on my system check my sig… Anyways, rendering done to 16bit 48000hz for audio cd’s seems to be good enough. Have you tried ASIO4ALL?, it might help, but even it’s a bit flaky but it does work.

Special note for ASIO4ALL: When loading the buffering might take a little time, (flashing icon on task bar, this is normal) till it stops flashing, at that point the song will play without skipping. I have not experienced any recording issues whatsoever with it, only the periodical icon flashing which requires just waiting which can be from a few seconds to a minute, but it will stop flashing every time under playback conditions. Better than the Sound Blaster Audigy 4 pro AISO drivers which are hell and track bleed.

I run specifically Line6 Toneport UX2 ASIO drivers on my laptop for vocals and I run at 16bit 96000hz to match the drums which are recorded at that frequency. All N-track bells a whistles involving track textures are disabled, the 3d stuff.

You can use dpclat.exe to see how you devices are working in terms of latency. This is helpful tool to allow you to see how your system is responding to the devices it’s using. When you see all green bars you should be good to go. Enable or disable devices (in the device manager) till you see all green. Disable system restore.

Here are some links

Latency Checker:

Hope this helps,

I tried dpclat.exe in the “normal” hardware profile which I currently use, and there was one red bar. I do have a dedicated “audio mode” hardware profile where all unnecessary devices are disabled, the tool gives all green bars then.

Here’s an example of the skipping. It’s from a live-from-console recording of Havdur, a local band.
The band is tight, but it doesn’t sound so because of the skipping :p

UPDATE: I just discovered (using SIW) that my laptop features a Ricoh R5C832 1394 controller. A couple of Google searches revealed that the Ricoh controller is bad for audio recording. Could this be the culprit?

If your getting any red bars your going to have skipping. Red means excessive delay as the CPU stops to allow the device to finish it’s request for time to share the bus.

Have you tried the audio profile you mentioned with the 1394 port enabled, the one that gives all green bars, does the issue still happen?

It’s not the 1394 port but delay in your ASIO driver causing the skipping IMO. The port is high speed and should work flawless as far as the transfer of data. However not-with-standing what you have said and found out about your port, maybe it is the problem.

If it’s your 1394 port, you can get an adapter express card with a 1394 port. Bytecc makes one.


I’d definitely try another Firewire adapter. SIIG or Bytecc makes models with the preferred Texas Instruments chipset.

Also, try a different DAW software. It may be an n-Track “thing”. I had to abandon n-Track near the end of V4 or around the beginning of V5. If it does prove to be an n-Track thing, make sure and file a bug report!

Your Saffire should have included a copy of Cubase LE. If not, download a demo of something and try it just to be sure where the problem lies. It is probably the firewire chipset but don’t rule out another problem until you prove otherwise.

FWIW… I used to record 22 to 24 tracks of 24/44.1 audio every Sunday (2 services) with n-Track V4.0.4 Build 1811 (pre .NET) using a MOTU 24io PCI system. It worked great. No pops, farts or skips…


Speaking of not being able to record at 24bit 96hz, I attempted this a while back with dismal results. With the new v6 and updated ASIO4ALL drivers and my new TonePort UX2, I’m suddenly able to set things up at this rate. Got my drums (Stand alone software) to function as well (successful test). I’m currently re-mastering my fist album made in 2007 and plan to re-master my second album, which I just finished this week. (“Oil Kings” will never be the same Poppa.) The thread on mastering was a REAL wake-up call for me. I really never actually knew how to do it, but I do now. The OZONE mastering pdf on “how-to master” is a MAJOR turning point for me. The self sub-woofer calibration in that OZONE PDF is a real plus.

I hope you get things sorted out on your laptop.


Paco: I set up the “audio” hardware profile as a way of getting rid of the skipping problem, but it didn’t help.
I work in a computer store and we just got a few ExpressCard 1394b adapters with TI chipsets. I might try one of those, but I’ll need a 9-to-6-pin 1394 cable.

Dubious: There is no Cubase LE bundled with this interface, just some Focusrite VST plugins. But I might try a demo of Cubase or some other DAW software. Maybe Ardour on Linux if I can make it work with the Saffire.
Maybe I should just ditch the Asus for recording and get a Macbook, but I’m not sure which DAW software to use as there is no n-Track for Mac OS X yet …

Thanks for any help so far :)

Good luck with the laptop. I have problems with my laptop because of the “compatable” (read cheap junk) chips on the firewire. Unfortuntly, the problem probably extends to your card bus slot as well - so, a bus card may or may not help. Also, note if your interface can use the 800 express speed - most sound cards will only work with the older PCMCIA 400 prodacal. I also found that the video card caused problems - this laptop had the video card on the mother board and shared the memory, not a good idea with audio. I had to turn off all of the “extra” features (LAN, Modum, internal firewire - anything I coiuld turn off) of the laptop and set N-track to display a minimum of graphics.

My experience in live recording has shown a dedicated 7200 rpm hard drive is a must. Also the hard drive should have ~50% free space and not be fragmented to cut down on the work the drive must do to write the data. I have a dedicated 80 GB 7200 rpm hard drive that fits into my laptop’s (IBM T-40) removable drive bay. This means it is not on the same buss as the firewire.
I have done 8 track 24bit/44.KHz recordings for over an hour without any problems multiple times over the last 5 years.

My setup:
IBM T-40 1.4 GHz Centrino
Windows XP SP1
40GB 5400 rpm system drive
80GB 7200 rpm audio drive (removable drive bay)
TI PCIMA card for firewire
MOTU 896HD or MOTO 8-pre audio interface.
WDM audio drivers with heavy buffering.
No live input through N-Track. All monitoring is done through the MOTU hardware.

Other points:

Always have a backup running. I use an Alesis HD24 and also a Marantz PMD671. The Alesis can record all the tracks, the Marantz records two tracks. This way I am sure to get a good recording. Yes I might be missing some solo tracks etc. for small section where there is a skip, at least I can work with the two tracks from the Marantz if needed.

Yes disable network connections etc. and all those icons that rob CPU time.

Minimize the amount switching between applications during recording. Like the old days you don’t mess with a reel to reel tape recorder when it is recording.

I have seen comments about certain firewire chipsets do not do well for audio. TI is one I have had not issues with at all.

USB drives don’t do as well for audio recording as firewire. I believe it has to do with fact that USB drives are better for burst speed as opposed to constant throughput.

I have had better luck with WDM drivers over ASIO since you can do heavier buffering. With live recording you don’t need to worry about delays, especially if you monitor the recording via hardware and not the PC.

The amount of memory doesn’t matter that much provided you have enough to easily run N-Track and the OS.