.sng files launch re-install.

I keep all files related to individual songs in their own folders respectively including the .sng files. Over the last few n-T builds, clicking the .sng file causes n-T to reinstall rather than launching the track. If I run n-T from Start or prg’s it works fine. Any one else?

I store the .sng files in the same manner…
It seems as something happens when I attempt to make changes to a track on the timeline…
I’m am unable to Normalize a track’s level till I write a name to a “so called” new song on the timeline till I rename that song…
Say… Can’t process the file, or something…
The workaround is, give the new song, a name… Then all is O.K.

This has only happened within the last week-or-so…

I’m always working with the latest builds…
However, I don’t have b2656 installed… I tried and my build says 2655 or b2654
or something…

is on this machine…


This bug has been around for YEARS! Why can it not be FIXED once and for all?


Bill. Maybe the two issues are related - the timing is about right.

UJ. I’ve only been using n for a couple of years and this is a new problem for me.

Quote: (TonyR @ Nov. 22 2010, 11:08 AM)

Bill. Maybe the two issues are related - the timing is about right.

UJ. I've only been using n for a couple of years and this is a new problem for me.

That's good... but it's been a nagging problem for a long, long time. TOO long... I don't understand why it keeps reappearing but whatever. I'm sure Flavio will fix it... again.


This is actually a probelm with the way Windows behaves sometime.
Sometimes, you can fix the probelm by uninstalling the program from the controp panel and reinstalling - but if that does not work this Might work:
The sng extension has been associated with the wrong ntrack file.
The extension is the the characters that follow the dot(.) at the end of a file name. The “association” tell Windows what program runs a particular type of file (identified by the extension.)
I don’t know what version of windows you are in: so roughly,
>Read the Windows help/support for your version of Windows and go where the associations are set up and remove the current association that is being used for sng files. The browase to the directory where N_Track is installed ( normally, C: drive Program files FASoft directory)
> Select the ntrack.exe file as the one to always open sng files.
Let me know if that does it - it is suppose to, but . . .

If that does not work contact Flavio with the build and version you are using and he can help.

Not to beat a dead horse… blaming Windows is a cop out bax. None of my other software(s) do this nor have they EVER. Whatever the issue is, it’s not Windows. It needs to be fixed in n-Track once and for all. Period.

My two cents anyhow… (which is worth even less than two cents) :laugh:


It is windows in so much as xp worries that the installation is corrupt. A two second rummage in the registry sorted it.
Cheers bax - I’ll try that next time;-)