Soundcard seems ok, but cannot record

Hi On my NEC versa aptitude laptop i Installed windows 98, windows 2000, windows xp to test and record. My soundcard (ess allegro 1988) seems to work fine. Plays sound and when I put my bass in the line or mic Input I can hear my beatiyull playing ;-). When I push record in the Windows sound recorder or N-track or whatever app, nothing gets recorded, not with the mic, the onboard mic, nor the line input. I get no error messages whatoever. Like I said, tried windows98, W2k and Windows XP with all, including the latest, Drivers.

Any ideas?

Have you selected the input device in the n-Tracks preferences? Do you see the input meters working in n-Tracks? Does nothing gets recorded mean no wave file or the wavefile is blank?

…and have you set the recording source in the Windows mixer?



Hi Guys thank for reply but:

I selected the sources properly but when I record (in no mather wath apps) I see a straight waveform. I record nothig but pure silence

Hmmm. Curious…

Does the recording meter in N-track bounce up and down?

Obvious but is the volume of the recording source slider all the way up?



Volume doesn’t bounce and the sliders are up. Note that the problem is not directly related to ntrack. Commaon prolem with Windows recorder etc.


I don’t mean to dis you but are you really, really sure that the correct recording source is selected?

Windows Mixer–>Options–>Properties–>Recording

It’s a common mistake to make.

Other than that, your soundcard is knackered?????

Anyone else?


Hi Mark,

I’m abso-abso-absolutely sure is choose the proper recording options.

I did a visual check of the soundcard (took the complete laptop apart) en everything looks fine.

I’m considering the purchase of a relatively simple external usb soundcard (M-Audio Fast Track USB ) now. Hope that works.



Most of the laptops I have set up require special drivers for the hardware. I had the same problem recently, the system had 2 card and the sound came through with a mic or whatever.
Could not get the signal to record.
I removed one of the cards and then it worked fine.
I know yours is a laptop but the fix might just be an irq or somthing easy. Laptops have bad irq handling.
You might need to disable some other hardware in windows to get a dedicated irq for your card. The same may apply to a USB card.
A usb card is the way to go for good quality on a laptop.
I often need to push the monitor button when using n-track.


Thanks for reply. I de-installed and disabled the network card, lpt, com an modem, makes no difference.

What do you mean by “have to push the monitor button”?