Stop button does not work

After pressing Play to play a song consisting of several MIDI tracks, the songs plays, but upon pressing stop, the song continues to play and n-Track becomes unresponsive. This is right after importing. Nothing has been done to the tracks.

I am getting this very same behavior right now. OS is Windows 10. Hardware is ASUS - i7. It started maybe 6 months ago using N Ver 7 and I could not get it resolved, so I upgraded to N Ver 8 (swx648.1.4_3464) but it’s doing the very same thing. Most Midi songs I’ve had for years still play nicely, but once in a while the STOP button becomes unresponsive. When this happens, the Midi song continues to play and the song pointer keeps moving, then the entire screen is covered in a milky white “fog” and the mouse pointer becomes a small blue circle turning clockwise. Pressing Ctrl-Shift-Esc (Task Manager) gives the message “Ntrack not responding” and the ONLY way to stop it is to select End Task.

Clicking on Task Manager Details gives me a PID number, then clicking on Analyze Wait Chain tells me “One or more threads of Ntrack are in waiting status.” There are always 2 threads waiting when this happens. I do not have the debug tools to look any further into this.

After a clean re-install of Win 10, it happens less often now, but it is still happening.
I also tried the 32 bit version of N Ver 8… It happens much less but still does it once in a while…

It’s strange because all the other Apps and functions of this computer work 100%. Starting to think it may be a hardware problem after all.

Thanks for any help.
Paul B.

Can you reproduce this with version 9?


Hi Flavio, I did another clean install of Windows 10, then installed N Version 9, and I could NOT reproduce that problem… However, I did notice a different problem with N9: at the end of a midi song, the song pointer keeps on going, you must press the stop button to stop it… I am aware of the check box to “stop playing at the end of the song” and I checked it, but it does not work for me…

Also, in N9 when I want to play a midi song, all the track outputs are defaulted to “Piano.” Is there an easy way to set all the track outputs to Midi Mapper as the default ? Like the older versions of N-track…

Thanks, Paul B.


as you may have noticed the ‘Stop playback at the end of the song’ setting is no longer present. We’ve removed because it was not functioning correctly. We may re-introduce it in a future update.
For the time being if you need the playback to stop at the end of the song, you can right click on the timeline at the point where you want the playback to stop, the select Place -> Song Stop Marker from the popup menu.
When n-Track imports a MIDI file the instrument assignments for the various tracks all default to Piano, you need to reassign them manually to the desired instrument. One of the next updates will add auto-assigning the tracks to the correct instrument when importing midi files.