Tracks one and two are time-shifted

I recorded a rhythm guitar track. With identicacl settings, I recorded a second track while listening to the first. But the second track waveform appears shorter than the first, and does not playback syncrronized.

Where is the shift coming from? and what can I do about it? Thanks for any ideas.

What operating system are you using n-Track on? What audio drivers? If you’re using n-Track on Windows try following our video tutorial on how to configure audio drivers.


n-Track Studio 9.1.8
Windows 11Pro v.22H2
Behringer U-Phoria UM2 interface

SPeaker WasAPI USB codec
Recording WasAPI Microphone USB codec

When I pull down the buffering settings, then press APPLY, it doesn’t stay set. Next time I open, it has reverted to default.

Thanks Flavio.

during playback there is a moment that sounds like a pull-up audio edit.
Sound is continuous, but that one second of time is gone.

Is am still in settings listed above.
Please help.



Wasapi drivers dictate the playback buffer size and number so that’s why those settings can’t be changed. Make sure that in the buffering settings box, ‘enable write buffering’ is enabled with the default of 102400 and that ‘disk loading buffers’ is set at 3.0 seconds. Also try to set ‘audio engine threads’ to 1 in the Preferences → Options box to rule out that multithreading is causing issues on your PC.
I happen to have a Behringer UM2 and I wasn’t able to reproduce any similar problem.
Make sure you’ve set Windows to use the same sample rate as the one you’ve set in the n-Track setting. That process (recommended when using Wasapi drivers) is explained in the
user guide and in the video I linked above.
If you hear a jump in the playback during recording, it means that the issue is with playback, not recording. If the playback skips or delays and the recording doesn’t, the result will not be aligned.
If the song has many tracks and/or effects, then the skipping might be caused by the cpu not being able to process the song in realtime. If it’s as you wrote with just one base track and a track being recorded, that’s probably not the issue. You could be having a DPC latency issue, check out if these links help:


thank you so much for the detail. I thought I would receive an email notice, but didn’t see one.