Transport toolbar GONE

Hi, long time n tracker here (3.1?) anyhow, 8.01 now - and my transport toolbar is GONE.

I’ve been using keyboard commands for a while and don’t know how long it has been gone - but have now noticed when I click the View>Toolbars>Transport Toolbar menu item I’m given either Hide or Show for options, and neither option shows the Transport Toolbar. I can’t get it back. I have minimized all the menus I can. Turned everything on and off. Any help out there?

I just found out I can’t edit my own posts.

So I will add this; I am using a mac mini OS X 10.10.5.

I am also having issues with device drivers…I suspect it may have something to do with another app I installed previously that has left files behind (Mobiola) that were hard to get rid of. It may be that I need to reset the audio drivers on the Mac somehow but am not sure how - so if anyone knows this might also be helpful.

Here is the scenario; I am using an old Zoom H4 and an iRig PRO for input devices and have figured out how to create an aggregate device (for input) and still use the built in (mac) output. I am generating a stereo file (iRig) and two mono files (H4 mic inputs). The only way to hear the song played is if I leave the input devices (H4 and iRig) plugged in all the time. If I unplug them, the song will not play and gives me an error ‘error setting audio driver sampling frequency’ - even though I have not changed the playback device in the Settings>Audio Devices menu. There are no armed tracks for recording either. The reason for unplugging is due to limited USB ports for other ongoing things, otherwise I would leave them plugged in. It seems a weird issue I would rather not have to buy a powered USB hub to remedy.

ntrack also crashes often, has a lot of other weird things (graphic glitches being one, more often it is an audio glitch of one form or another - usually growing digital distortion in the playback channels but doesn’t affect recording) to which I need to restart the program often - often enough to say there is something weird in the drivers, IMO.

I was going to ask about multiple differing tempos in a song, but I thought I had figured that out a week or so ago when I had a transport toolbar - am I correct in that sort of thing cannot be done in the step sequencer alone (as I am trying to do without a transport toolbar)?


I have re-installed ntrack.

Still no transport toolbar - from a fresh install

When I click View>Toolbars>Transport Toolbar I am given an option to Show - I click, and no show :(.

When I click View>Toolbars>Transport Toolbar I am given the option to Hide - I click and ntrack crashes, every time.

So I edited the post last night but cannot edit that one today, or any others…must be a time limit thing?

I will add that I have also tried the ‘sudo killall coreaudiod’ command in my terminal application to reset the mac audio.

It appears you’ve stumbled upon a bug that causes the toolbar to be permanently hidden when you close it once. We’ll fix the issue in the next build.
To bring back the toolbar please close n-Track, then please try deleting or renaming the following folder to reset the n-Track settings:

/Users/[your username]/Library/Application Support/n-Track Studio 8

The Library folder may be hidden, to open it try holding down the Alt/Option key and selecting the “Go” menu in the Finder app. Library will appear in the list of folders (but only when Alt is pressed).


Excellent, thanks for that - the toolbar has returned! I shall not close it again! :agree:

I have also taken the time to reinstall OS X yesterday and am still having issues with digital distortion coming from the inputs. At first the noise isn’t there but over time it grows - seemingly irrelevant of how I am using the program. I am going to try the input devices with some other software to see if I can replicate the problem. In some cases there appears some form of feedback loop to which my inputs DB readings oscillate like a roller coaster - with no input signal being provided. In all instances I must reboot ntrack as it becomes unusable with all of that noise, however thankfully it does not manifest itself in the actual recorded tracks. I will report back on these things once I have investigated further. It may be that I will need to upgrade my input devices - however hopefully I was hoping to avoid that as I cannot afford to throw money at my music.

I appreciate the response and attention to these issues, so here is another one for you in terms of bugs to maybe fix next go round (or not as I am sure some things are more difficult to fix than others). It seems to me this has been a long term issue with the software versions as I have noticed it in other versions - when adjusting volume envelopes for whatever reason I cannot get nodes on the bottom (last) track to go all the way to the bottom (-Inf) when dragging with a mouse - unless I add a blank track below that (which is the workaround I have always used). Minor stuff for a long paragraph.

I figured out the Tempo business too - it is so nice to be able to use one program for everything, rather than importing drum tracks from elsewhere! :handshake:

I also have the “no edit” issue. It seems to happen after you’ve edited once or logged out of the forum.

On the up side, it gives you a chance to increase your post count (a big thing with some forum groups). :cool:

No edit is No issue :peace: . Just a different way of doing things. Too many erasers out there anyway…I digress…

Hey Flavio thanks again, that fix has solved nearly all of my issues here - so far the audio quality is great with no digital distortion or loops happening anywhere. I still can’t disconnect my inputs without ntrack crashing though which is less than 100% convenient but I can work with.

More feedback for you;

When working in the Trackbar list and selecting a track by left clicking an open area then right click - the selected track then reverts to the track listed two below and opens the menu for that track - for as many Trackbars as are available (when you get to the bottom two or less Trackbars the selection remains unchanged). When clicking on the tracks themselves or when the track properties are open this does not happen. The only solution I have found is right clicking the trackbar you want multiple times until it opens but sometimes this can be more than a few clicks.

Otherwise it feels great to be heavily immersed into learning to fly this thing again after being away for awhile - and happier still the crashes aren’t physical. Like quarters in the video game - except without the quarters.

Of course it is when things are going well the wheels appear to come off…

I am having some extremely strange things happening, and am wondering if this is a memory issue - as in maybe I don’t have enough.

At first it manifested itself as muting the entire song for not quite 20 seconds at the very beginning, coming in at a very abrupt weird time. I was working with volume nodes so thought that might be it. Through a process of elimination I eventually went to flattening all of the envelopes until I found the offender. It seemed to me that volume envelopes from other tracks (accordion+bass) were somehow affecting the volume level of the only active track (guitar) for the first twenty seconds. When the volume for the accordion and standup bass come up, then so too did the guitar. Really weird, because this has seemingly happened out of the blue and was definitely a case of volume nodes from certain tracks affecting other tracks. But it also only seemed to happen after about half the tracks were flattened (like I had used too many nodes somehow). So instead of nodes on the accordion and bass tracks I just cut the empty space :).

Thought it was fixed - indeed the guitar track started playing again.

But then a little more editing and everything cuts out. At some point I am clicking the FX button, and when it goes off the sound comes back on. Hooray. Click it on and the sound goes away. So I start turning off effects one by one (bypass). Lo once I turn off a few the sound comes back.

So I’m just wondering, once you start maxing out processor power does the sound cut out entirely?
If so what are some ways I can save juice…I already am turning off all mixers and VUmeters. Will removing more nodes help?

It might be something else as it seemed out of the blue, but maybe it is processor power. One of the first things I did was re-trash the /Library file as mentioned, but it didn’t seem to solve the problem. The other thing is, sometimes it seems I have enough things turned off for sound to happen, press rewind or click to an earlier point in the song and the sound disappears again.

I have spent the last three hours troubleshooting with this and am now tired. :D

We’re looking at the right click issue. The envelopes issue might be related to a non trivial signal routing. Are you using aux channels, sends or groups?
When you max out the cpu you typically start to hear the audio gradually breaking up, i.e. small clicks or 1/10 of second of silence every now and then that get worse as the cpu is stressed. If the problem persists it would be great if you could send us to a sample .sng file that exhibits this behavior.
If the sounds goes away for 10 seconds at a time then it’s probably something else. How many tracks and effects are you using? Try to see if you can pinpoint the issue to a single plugin. The problem might be caused by a numerical issue in the floating point signal, i.e. a very low or very big level that ‘saturates’ the signal inside a plugin which then propagates to the signal chain that follows.


There are no gradual signs of breakup - either the sound is on or off.

There are 19 Audio tracks, 1 Step Sequencer Track, 2 Instrument Tracks (for some reason when opening a step sequencer track it also opens 2 instrument tracks), 3 Aux and the Master.

There are two effects on each of the three Aux channels (Compressor and ntrack Graphic EQ) and also the Master Channel (Compressor and Reverb). On one of the Audio tracks there are 4 effects - Compressor, Reverb, ntrack nVocal, ntrack Graphic EQ.

I had thought the problem pinpointed on a single plugin for one of the Aux channels (a Compressor) so I removed it and replaced it with a new one and it was fine momentarily but then again as soon as I go to the beginning of the file again, things have cut out. These effects have been there since the beginning of the recording without issue in the past.

I will send the .sng file after this post.

Another strange thing that has happened (twice) when doing (multiple) punch-in recordings (and I think it relates the the ‘metronome on count in’ is the first track recorded ends up offset wrong AND more importantly EVERY track ended up being muted where the metronome counting occurred (when I click the Draw Volume Envelopes button every track has had four nodes installed to form a mute space - the fix has been to undo past the point of recording the punch-in tracks)…wow was it ever not fun trying to figure that one out. lol.

I have also figured out to keep multiple saves of works in progress so I can revert. There is a lot of work lost if I have to revert this one though.

Thanks for the help! :agree:

I have received a follow up from Andrea in short order - thanks for prompt attention to the issue.

I have responded to the queries with a few video links to better respond to the questions Andrea had for me. I have decided to post this links here in case someone else out there can see what is going on.

It is definitely a weird situation.

“In hopes of being able to clarify the issues I am having, I have made three youtube videos with descriptions in the link as to what is happening.

The most pressing issue I am having is with the sound completely cutting out - the other two are small bug items with easy workarounds.

Big problem - <a href=”"

onclick=“,’_blank’);return false;”>

( I am only using one Reverb - and although it does seem related to large resource using plugins such as Reverb or Compressor it is not specific to Aux 1 or Master although it seems most likely the problem will manifest itself with the plugins on those channels.)

Right Click track issue - <a href=""

onclick=“,’_blank’);return false;”>

(I have discovered since my last post this is likely related to the Input VUmeter as indicated in the video)

Volume Node issue last track - <a href=""

onclick=“,’_blank’);return false;”>

(another issue has come up aside from this where sometimes the individual node elected goes from a Log setting to a Smooth end setting)

Please let me know if you need anything else."

Thanks for everyones help. I am at a stand still with my work until this problem can be resolved. Please help and thanks again.

I can get it to where everything is on, leave it playing, and ntrack is using about 80% cpu in my Activity Monitor, and is pretty much the only thing running on my computer.

While ntrack is still playing, I open about a half dozen or so other apps, Safari, Chrome, and a couple of tab edit software programs that also run audio - I press play in both other apps and now there are three different songs playing on my computer no problem. Total cpu% for all apps is well over a hundred at this point :whistle: but no noticeable issues in sound quality, other than three very different songs playing over one another ??? .

So I decided to open up an earlier version of the song I had saved and see if I could reproduce the issues. The two little issues (Volume Node and Trackbar) I could reproduce but not the big issue (Sound cutout).

In this instance I put 6 effects on each Aux and Master channel, including the Compressor and Reverb. No noticeable drop in audio quality, and the CPU% for ntrack reads 96%.

So it seems there is something funny in the most recent .sng file.

I thought it might be something to do with the Nodes, so I flattened all envelopes. Still a problem.
I thought it might be the order of effects/signal path. So I reorganized them. Still a problem.

Of note : It seems the issue is related to Aux1 and the supporting Channels, although the Master Channel also seems to be suspect. Manipulating controls on either Aux2 or 3 and their feeding channels does not produce similar problems.

I have created another youtube video <a href=""

onclick=“,’_blank’);return false;”>

where the following experiment occurs;

Everything is on and running (I have removed effects from the Master channel for the purpose of this experiment)
Audio stops at the point where the bass (purple) tracks begin - although song continues to play.
Once all three tracks are muted audio resumes.
The purple tracks feed Aux1.
The green tracks feed Aux2.
The blue tracks feed Aux3.
Muting the three blue or green channels in the same manner does not produce the same results. Therefore the issue seems to be in Aux1 or the purple tracks.
Although it should be noted that when an effect (compressor or reverb) is applied to the master channel, this will also cut the audio - so it is also suspect.

I have replaced all of the Aux channels.

5 minutes in I’m thinking everything is great and weirdness occurs again.

I don’t know. I think somehow there is some bug that was enacted along the way that is not something I would have known I had done, much like with ‘punch ins’ there was a blank muted space that correlated with the ‘count in’ that manifested itself on every track not once but on two different occasions! I only discovered it looking at volume envelopes to explain the complete mute of the song - definitely not something I had consciously done! So I wouldn’t doubt this is more of the same.

I have been playing with the old version of the song for a little while now…I was able to run 3 reverbs on every channel, 3 compressors, and an eq. I didn’t much things to breaking. So comparatively, the old .sng file is running 26 tracks with 32 effects compared to the new .sng files 18 tracks with 12 effects - and not a stutter. It was also noted that the Activity Monitor generally indicated ntrack was using approximately 20% less CPU% than with the troubled version of things.

So a lot of editing is probably gone in a poof but if I don’t have that ‘other’ issue I must carry on.