Usin sfz with n-track HELP!

:p I am not very technical. I seem to find how to perform tasks and functions on the computer through trial and error. I think I have tried every way to set up sfz to play the soundfonts I have downloaded. Yet I can not get the sounds to transfer to the piano roll. I have ntrack 4.02, 24 bit, and a Audigy soundcard (which is 24 bit in playback only). Can someone walk me through opening a new midi track, how to select the sfz player, and how to get the sound to come out? I either get whatever is in the "track properties" box, or nothing if I try to change my settings/preferences/midi devices.
I appreciate any advice!
Billy Hopkins
:( Don't laugh, but I am not sure what a zipped file is , either. so some of the soundfonts I have downloaded seem to be zipped.
Billy Hopkins

Zipped files are files that have been compressed and need to be extracted before they can be used.
Winzip or WinRAR (among others) will extract zipped files to a location of your choice.

Now for n-Track and sfz …
Navigate to Track > MIDI > New VST Instrument Channel > sfz
sfz will load. Click in the blank area to the right of the arrow next to File in sfz. Browse for the soundfont you wish to load.
Now back in n-Track click Track > Insert blank track > MIDI
In the MIDI Track Properties where is says Output port, select Instrument-sfz and then close the track properties window.
Click the “Live” button (depending on how you have your soundcards I/O channels selected, you may see some audio tracks show up on the timeline)
Open the Piano roll and play your soundfont. :cool:

In addition to what crankz said, you can look a little online tutorial about using ntrack and sfzTutorial Online about using ntrack&sfz that can helps you.

:DThanks, Fellas!!!
It worked perfectly.

Well, well.
Now that I can open my sfz player, I get a message that some of the soundfonts are to big to open…something about not enough memory. any suggestions crankz1 or marce? ???

Quote (Billy Hopkins @ Jan. 30 2005,22:10)
Well, well.
Now that I can open my sfz player, I get a message that some of the soundfonts are to big to open....something about not enough memory. any suggestions crankz1 or marce? ???

Well, that's always an issue with certain soundfonts.
About the only cure is to add more RAM to your system or use smaller soundfonts.
If you work with a lot of large soundfonts, you may want to consider upping your RAM to at least 1 gig.
Of course this all depends on your computer and how much RAM it will support.

in sfz there is a “mode” setting which sets how the soundfont uses memory. IIRC SF32 uses most memory and DFD (direct from disk) uses least. The trade off is RAM v. CPU usage. There is some help about this on SFZ website somewhere.


I’ve used SFZ with the NSKit drumkit. I was not able to load the SF2 file, however, it’s perfectly possible to load “waves” instead.

This is all fine as a quick-fix, but in the end, it eats all the memory and I can’t do proper work anymore. Gotta go for some extra MB’s.

Try the PF16 setting.

Right – PF16 is the best bet. You can also try DFD (direct from disk), which may or may not work well (without crackle) on your system.

Also, shut down any program you don’t absolutely need. Close any open file folders. (Also, you’ll have a bit more memory available if you reboot your computer, so if you think you might be close, try that.)

How much memory do you have, and what are the sizes of the soundfonts you’re trying to use? If they’re huge soundfonts, there are often things that can be done to slim 'em down. It’s technical, but someone here may have a “diet” version or similar smaller soundfont to suggest.