V4 Build numbers after 1715

Build #'s greater than 1715 will not run

I have seen a couple of posts regarding this problem. I generally check the the download site and if there is a new build number along with a description of what has changed I will update my system with the new build version. I have found that build #'s 1721, 1728 and 1730 will not run on my system. The only thing that I have done since 1715 was to add a free VST plugin. When I try to load a .sng file that contains the new plugin the program hangs. Do I have to reinstall the new plugin with these later build versions? If anyone knows for sure please reply as I like to keep my system current.


Additional information regarding this issue…

1) I rolled back to 1715
2) I loaded the .sng file that contained the suspect plugin
3) I removed the supect plugin from all tracks
4) I saved to a new .sng file
5) I reinstalled 1730
6) I loaded the new .sng file without problem
7) I added the suspect plugin to 2 tracks without problem
8) I saved to a new .sng file
9) I thought I had the problem solved
10) I tried to reload the 1730 .sng file and “boom” it hung!
11) WTF!
12) I then rolled back to 1715
13) I loaded the 1715 .sng file without problem
14) I then loaded the 1730 .sng file again without problem
15) So now I am really confused??????????????????

I forgot to mention that before I performed the above steps I deleted the suspect plugin .dll and related directory from the n-track_program_VST plugin directory. I then unpacked the suspect plugin again and moved the newly created .dll plugin back to the above mentioned n-track_program_VST plugin directory. As I am writing this message it just occured to me that I should have checked the add/remove programs browser to see if the suspect plugin .dll appeared. By simply deleting the files from the system they may still have registry entries which is creating my problem. Hmmm…

Damm…you’d think that creating music should not require such technical acrobatics! I can’t wait to get past this shit and just go back out and play it live! No pain, No gain or at least that’s what they say along the internet highway…

vst plug-ins are just dll in the vst folder. All you have to do is remove the vst from that folder and it will be gone in the eyes of n-Tracks. Vsts don’t use the registry (usually) and won’t show up in the control panel so there is nothing to worry about there…but dx plugins will and blindly removing them – their files – can case major issues if they aren’t unregistered properly.

What would be helpful is to know which vst has they problem. Flavio added functionality to write a log of plug-ins when n-Tracks starts as an aid to help find troublesome plug-ins.

I had a problem with a reverb and the new n-Tracks multi-band compressor. Any song that had the reverb and compressor would load and play fine, but I wasn’t able to open and edit the compressor as long as the vst reverb was in the song. I mentioned it to Flavio and it was fixed in the next build.

Yea Chris it would be helpful to know what the free vst is that you put in when the probs started.

Some of them (vst) will bugger a system. I have had no problem with any of the new NT builds.

As a test did you remove the vst and try a later build? Or just remove it and reinstall it?

I did have a prblem where I would fire up NTrack just fine, but when I went to load a song file it would hang. That was when I had to delete the NT cfg files and let NT rebuild them from scratch. The last 2-3 builds have not had the problem and I am not sure it ever was a NT problem to be honest.


I was having problems too, big problems, then I decided to do a clean install as a last resort. THAT made a BIG diffrence, now it’s running right!

Thanks for your replies…

I have included the suspect vst plugin in this message. I copied the entries directly from the vstdat.log file. Now I am not sure if it is the multiband compressor not being able to coexist with the suspect vst plugin. I’ll have to test this further. While on this topic I noticed in the log file that
n-track is still seeing vst and directx plugins that I no longer use. I probably was just testing some demo stuff. Is this a way to clean off all the old test stuff so that it does not confuse n-track? I know that n-track does have a utility that displays all vst/directx plugins. I will attempt to clean up this first. Anyway here’s the suspect vst plugin info:

Path: C:\Program Files\FASoft
-Track Studio 4\Vstplugins\X-cita.dll
Sub path: Vstplugins
ID: ticx
Vendor: [elogoxa]

To cleanup or just recompile the log list I think you only need to go to File|Settings|Preferences||Paths. Then check the rescan checkbox under the vst section and it will do a rescan next time you start NTrack.


Hi All,

Once again thanks for your suggestions. I tried them all even a complete reinstall from scratch but to no avail. I e-mailed Flavio directly and the next day (today) he replied with a fix. Build # 1743 was just posted today and it has addressed my problem. I don’t know if any one else is having this problem but I know that it fixed mine.


One of the problems I had in a previous build was a conflict with the multi-band compressor. Glad Flavio got it worked out for you.