Waveforms stopped appearing when recording

My production was going fairly well, but - once again - it’s come to a screeching halt, this time because the waveform of the new track I’m recording does not appear. The timeline moves, but nothing is seen. Apparently it IS recording, since I can PLAY it and HEAR it afterward, but, out of the blue, new waveforms are not there, not being generated or at least not being seen - and having them is imperative for editing that will be required. I have multiple tracks already recorded, both stereo and mono, and it WAS working just fine as of yesterday. How this stuff can work one minute and inexplicably stop without me making any change in settings is beyond me. ~Lefty7

I’m not sure if I understand, can you see the track (even without the waveforms) after it’s been recorded? Maybe the tracks are below the ones that you’re seeing?
Try selecting the Zoom All command to make sure that all of the track is being shown.
If the problem persists please send a screenshot or a short video showing the issue to support@ntrack.com

Flavio.

Yes, Flavio, I am viewing all tracks, and the track I wish to record on is indeed represented. And the signal is recorded, but without a waveform showing. Actually, I’ve found that if I zoom WAY in on the x axis after making the recording, often there is the slightest sliver of waveform at the very beginning, but it does not continue past this initial blip.

After my last post, I left it for a while, turning n-track off without saving. Later, I restarted with the same song project loaded up. With that same track [12] enabled to record, I tested it, going into record mode, and lo and behold, it DID start and continue to show a waveform. Unfortunately, I was not prepared for this, so I stopped recording and undid the brief (blank) recording while I energized the other equipment needed. By the time I had done that and tried again to record, it would not show waveform. I tried several times, and it was the same. So again I left it, turned it off. Later, I restarted the process, and it did not generate a waveform for me to see on multiple attempts, but then (for no reason I can understand), on another try it suddenly did. I immediately made the recording, and the complete waveform was available – and I did use it for some trial edits. However, the recording had some other non-n-track issues which made it unusable, so I undid the recording in hopes of correcting those issues and re-recording the track. Since then it has not made a new waveform visible while recording or afterwards for playback.

Additionally confusing to me is this: in troubleshooting the problem, at one point I added another new blank track, [track 14], to see if there was any difference. There was not. But when I made the recording on track 12 (described above), the signal also recorded on track 14 even though it was not enabled. (?) ~Lefty7

There may be a bug causing the issue. Unfortunately we cannot fix issues with version 2.x so I can only suggest to try to find a workaround. For example, if the problem occurs only on recorded waveforms, you can try to save and close the song after the recording, close n-Track, relaunch it and then reload the song. Another thing to try is the ‘Recalculate npk files’ or ‘Regenerate waveform’ command in the Settings -> Waveforms menu.

Flavio.

Yes, thanks.

I had already come to a similar conclusion. In my workaround, I jettisoned what I was trying to do and how I was trying to do it - forced to do such to keep on production time commitments. C’est la vie.

I know this is a long-outdated version, and have wondered how many of the issues I struggle with have been corrected in the newer versions.

~Lefty7