What happened to my song!!??


The other day I recorded this really great, inspired tune I saved and played back for several days.

Today I went to play it and N-tracks said “error opening file”. What!!?? I searched the “C” drive and it’s gone. It shows up under “My Computer” but when I click on it it says “invalid path”.

Where did my song go? I did NOTHING that could have caused this. Everything else on my PC seems OK. I tried a file recovery utility and it couldn’t find it either. Other songs I created before this one still open OK. What happened here? Can I retrieve it?

wots appnin , slow mate ? yer files are probly still there mate
wot u gotta do is tyry the ole windows serch fer wavs.
in import em.
probbly yer machines a bit gone wrong. :D :D

Is this just another Limey impersonator? They are as thick as Elvis impersonators. Please don’t do this to me…me wee Irish heart won’t handle it! I’ve been mourning Limey’s passing for over a year and you say he’s alive and well! Very cruel indeed, mate!

Only the real Limey would know what car problem we once discussed on this board. Answer me that, Limey, and I shall beleive.


sent u a pigeon mail mate :D :D


Cruel joke, mate!

Hurts me 'eart real bad.


Hurts all of us Don…but as long as we know this Limey isn’t the limey (different caps) of old he’s still welcome, after all imitation is flattery…assuming this Limey isn’t trying to pull a fast one by claiming he IS the limey of old. We also know limey doesn’t do email.

As for the original reason for this thread, I’m wondering what might have either wiped out the original waves are caused them to not be found?

Are the waves missing or is the .sng file missing too? Is the error simply when using the Most Recent Files in the menu, or it the whole directory gone? Clicking My Computer and then clicking in a directory or file name that is visible and then getting the Invalid File error probably means a hard drive error (it’s still in the hard drives directory structure but the actual files have been corrupted). ScanDisk may fix the visible but not there problem, but that would surely nuke the files, not that they aren’t already nuked.

On the other hand, it may be that only the .sng file is valid and the wave files were either deleted or moved, or the .sng was moved. In any case a song is a combination of all those files and the path to each file needs to stay the same for the most part. Moving any of them can cause a missing file error, but not usually an invalid file error. That is the confusing part.

What’s gone is the “.sng” file. It was a pure MIDI composition using VSTi modules - no wave files.

I have since found it using a file recovery utility. It is considered in “poor” condition and would not open in N-tracks following recovery.

I did not delete this file. What could have caused this to happen? Hardware fluke or is N-tracks not all that stable? VIRUS?? Anyone else had this happen?

A crash or simply turning the machine off without doing the normal shutdown could cause file corruption if anything is writing to the harddrive when the crash happens or power is cut off. I’ve head that reading a file when power is lost can do it to, but I don’t know. It doesn’t take much to kill a file if anything causes the drive to write to the wrong place for whatever reason. Probably any flipped bit in just the right place could do it. It’s hard to say what did cause it but there are lots of things that can cause it, though it’s rare to happen.

Probably file restore found most of the files parts but restore can’t find parts that have been overwritten obviously. They restore the links to all the parts and copy the file to a new location. Any missing data is skipped. That’s not so bad for files like simple text but it can make most other files unusable unfortunately. If there’s enough missing bits that n-Track can’t open it I doubt you can get it back.

It’s hard to say if n-Tracks caused it. I seriously doubt it, but if it crashed it could have, or the crash did. As unstable as some of the earlier versions of n-Tracks have been I’ve never seen it do something like that.

This could be a symptom of a hard drive getting ready to fail. I had a major hang on one of my machines at work and had to pull the plug. After rebooting there were problems reading some directories in the D: drive. I ran scan disk on it and rebooted. After the reboot the whole drive, except a few files, was blank but still reported itself as containing almost 80 gigs of data. Unfortunately, the hang was the hard drive failing. I lost everything on the drive.

Last year we had a wind storm that flickered the power A LOT while I was at work. I keep some machines running all the time at home. Even though the power never went fully out two machines were running REALLY slow when I got home. Neither would reboot. The power had taken out the C: drive in both machines. Neither drive would reformat and had to be junked.

I suggest keeping an eye on the hardware for any other signs of corruption.

I’ve never seen N do that. Never heard anyone complain of it, either. I bet it’s something else.

Too bad – it’s always a bummer when we lose something we liked!

I’ve had it do that to me before on a midi file with several vsti’s gobbling up cpu usage all at once. I import my midi files into n before vsti, so I had a backup. I would recommend making a backup midifile before doing any vsti. just in case.