Windows XP with Service Pack 2

n-track Ver4 .exe program file update

I have just recently updated my system to SP2. I have not had any problems with the operation of software installed on my system specifically n-track ver4 build# 1970. It works just fine. Today I tried to download build# 1973 of n-track but I ran into the following problem. The download is supposed to be 4.2Mb in size but when I execute the download the file is only 3.06Mb in size. Also the iconic representation of the file is the generic Windows program file. I do understand that SP2 greatly improves the security of my system when connected to the internet. My question then is are the new security features blocking active-X controls from the download page which are causing the file size and iconic representation to change? I have downloaded other .exe program files from other websites without a problem but perhaps they do not contain active-X controls. Until I can get this clarified I will not update to the most current version of n-track which really bums me out. Any comments or suggestions to this issue would be appreciated. Perhaps this issue should be addressed by fasoft and corrected on their download page as there will likely be more users that could potentially have the same problem. If the new file is executed by the user it could cause un-needed problems.

Sounds like a corrupt-aborted download. It could simply be internet junk interrupting the file transfer. Try downloading it again. There’s nothing in SP2 that will prevent n-Tracks from downloading properly. That’s a coincidence. SP2 might prevent the auto-download from starting, but I’ve never seen it happen. I’ve had SP2 on my machines for a while (starting with the beta SP2, and how with the final released) and n-Track’s updates have always downloaded fine for me. There is a link to click if the auto-download doesn’t kick off. Doesn’t sound like you have that problem anyway.

Hey Phoo,

Thanks for your reply. As I mentioned I have downloaded other .exe files without a problem. Why would the n-track file download change in size compared to the website information as well as the iconic representation? I have attempted to download the file several times but I keep getting the same results.

Hi Guys:
I am downloading build 1673 at the moment… The file size is 3.06 megs…

Am I hearing you right phoo? The file is corrupt? I have win '98 with all the latest security packs for that Operating System…


I seem to be having the same problem as chrisd, I downloaded the file and get this error when I try to run it:
“ntrck_sw.exe is not a valid win32 app”. I’ve tried downloading a number of times, but with the same result. Interesting.


I have done some further investigation regarding the the download page and I believe that an erroneous file path has been entered regarding the V4.0 download. If you place your cursor over the V3.3 download the following path is displayed: “”. If you execute the download all is well. If you place your cursor over the V4.0 download the following path is displayed:”. If you execute the download Windows gives you a warning and the subsequent download does not work. It appears that others have also found the same problem. Please correct ASAP!

Maybe the one on the server is corrupt. I was suggesting that the download was bing interrupted. If it seems to always download fine, and all downloads are the same size, regardless of what the website says, and then doesn’t run it’s something else.

That last download I did (1670 a few weeks ago) was fine. I’ll check it again.

Followup…no problems with V4 -1674. It’s 4.26 filesize on my computer and it installed correctly.

If you have file size of 3.16 you have V3.

I’m running WinXP-SP2. The automatic download IS blocked by SP2, but there is a new bar across the top of the web page in in Internet Explorer that give the option of downloading the file or not downloading the file.

As a second test I did not all let the file be downloaded automatically, so I clicked on the direct link to the setup file. "The download should automatically start. If it doesn’t click here."

That one worked fine, too.

Check you security and firewall settings (I’m using the defaults SP2 sets up). Maybe that’s it, but if you getting a partial download then something else is kicking you off the download server, and it may be out of your or Flavio’s hands. A firewall will prevent the download from starting.

I’m gonna try the download again… build 1674… We’ll see…


This download seems O.K. The file size is right… 4.26 meg. in size… If I remember, builds 1670 and 1673 both had the file size pegged at 3.06 meg. in size… However, I have not installed v4 into my set-up, as yet…

I’m on a telephone wire and 56k modem, here…

1670 is 4.26 megs as well. I never saw 1673. maybe it was just a bad post.

No problems here downloading build #1674…I did however uninstall SP2 a couple of days ago due to too many mishaps with it such as what is being discussed here.