WMP 10 and dbpoweramp

Upgrade to WMP 10 causes problems

Just to let anyone who uses dbpoweramp know - when I upgraded to WMP 10, I lost the ability to use the WMP9 codecs such as lossless, VBR etc. I’ve tried re-installing the dbpoweramp application and v9 codecs etc but I can’t seem to get them back working properly. I’d certainly think very hard about making the change to WMP 10.

Thanks much for the tip! I didn’t even know v10 was out. I use V9, but won’t be tempted to upgrade, that’s for sure! Have you nosed around on dBPowerAmp’s forum? They might know about it and have a workaround.


Yeah - I had a look at the dbpoweramp forum and they mentioned various issues but nobody seemed to have got round them yet. It’ll probably take Microsoft to produce a WMP 10 codec distributable before it gets fixed.


Wow… Did they make changes to the codec?

New Codec? Not that I know of, but you never know. There are some new things added in the WMV9.5 Codecs - introduced in WMP10.

It might be that installing WMP10 is changing something that other apps have been using – regkey - codec location - who knows? It might not be a codec problem in other words.

For example: I found four different reg keys that might show what version of DirectX is installed. Unfortunately, not one of them is standard or available on all machines, and to make things worse they might all show different versions. The only way to really know what version is installed is to check the version on the actual DLL in question. If any app depends on any one of those reg keys to make sure the version of DirectX is high enough they might fail the test on some machines and pass on others when the exact same version of DirectX is installed. It’s a two part problem and causes finger pointing. DirectX doesn’t officially support a version key, but should, and apps use these keys all the time because they have worked for years without problems and it’s a easier (maybe) to check a reg key than it is to open a bunch of DLLs to get the versions then try to figure out which one is the real installed DirectX version…DX problem number two – individual DLL versions are independent of the installed DirectX runtime version in some but not all cases.

Sorry for the tangent.

I found this link:

Look around in there. There’s lots to pick through in some of the links.

It might help if it’s a codec problem. Might not if it’s something like the DX Version fiasco I flew off on.

This is a bit bizarre, but I was checking out the dBpowerAMP forum to see if anyone had resolved this issue and someone with the same issue said that it had just disappeared a few days ago all by itself. Imagine my surprise when I checked my version on the off-chance and found it was working fine as well. I originally spent about 5 hours trying to debug this including re-installation and re-booting numerous times, so I can only assume that this was fixed by either a “Windows Update” or an “Office Update” that has come out in the last week or so? Can’t think of anything else that I’ve done to my machine? ???

A “friendly virus”, maybe? ??? ???

WMP will download and install codecs it needs if they are available (MS owns or licenses them and has them posted), but not on the behalf of other apps. It is rather strange.

I upgraded to v10 of Media Player last night. Today when I attempted to convert a .wav to a .wma using dBpoweramp I encountered the same error. What I did was to go to their codec sight and downloaded the two recommended files and installed them using the Windows Run utility. The system did recognize the older version and uninstalled it and then installed the new version. As per their instructions I then rebooted my computer. I then ran the dBpoweramp program and tried to convert the files. I converted the .wav file to a .wma file without a problem. In fact when I loaded the file into V10 Media Player I thought that the converted file played back with better audio quality than what I was hearing with the older version.

I hope this helps…


I didn’t know what to attribute it to until reading this thread but the same happened to me after d/ling WMP10. I re-downloaded and installed dBPA and it works again. Incidently, I like WMP10. It has some nice new features and, I also think it sounds better than v9.0.

Aren’t those some nice skins for dBPA? I’ve forgotten the name of the skin, but I like that bronze-colored GUI with the huge VUs and 20-band EQ. I do have some trouble with the play list in dBPA. It will sometimes open multiple play lists then lock up. I had that problem with the original skin too and reported it to tech support.